X
Tap here to go to the mobile version of the site.

Support Forum

Horizontal scrolling results in rendering issues

Posted

I am using Firefox 38.0 on Linux Mint 17.1 Rebecca. I am using an Asus R7240-2GD3-L (Radeon R7 240). When scrolling horizontally, I receive rendering issues as seen here:

http://imgur.com/a/4swwv

The example above is plain text with a fixed width and overflow: auto. The issue does not occur with vertical scrolling. It does not occur with horizontal scrolling on the browser window. The problem appears to be isolated to horizontal scrolling elements on the document itself. The issue is resolved roughly 1-2 seconds later after the mouse is released, when the rendering artifacts disappear and the text appears normal once more.

These rendering issues occur whether or not I have hardware acceleration enabled. They occur whether or not I have smooth scrolling enabled. They occur whether or not I have auto scroll enabled. My drivers are up to date. The issue is isolated to Firefox, as the horizontal scrolling on the same pages in other browsers (i.e. Chrome) works fine.

I am using Firefox 38.0 on Linux Mint 17.1 Rebecca. I am using an Asus R7240-2GD3-L (Radeon R7 240). When scrolling horizontally, I receive rendering issues as seen here: http://imgur.com/a/4swwv The example above is plain text with a fixed width and overflow: auto. The issue does not occur with vertical scrolling. It does not occur with horizontal scrolling on the browser window. The problem appears to be isolated to horizontal scrolling elements on the document itself. The issue is resolved roughly 1-2 seconds later after the mouse is released, when the rendering artifacts disappear and the text appears normal once more. These rendering issues occur whether or not I have hardware acceleration enabled. They occur whether or not I have smooth scrolling enabled. They occur whether or not I have auto scroll enabled. My drivers are up to date. The issue is isolated to Firefox, as the horizontal scrolling on the same pages in other browsers (i.e. Chrome) works fine.

Additional System Details

Installed Plug-ins

  • DivX Web Player version 1.4.0.233
  • Version: 5.41.0.0
  • The IcedTea-Web Plugin executes Java applets.
  • The Videos 3.10.1 plugin handles video and audio streams.
  • Shockwave Flash 11.2 r202

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0

More Information

guigs 1072 solutions 11697 answers

Please update to the most recent version of Firefox:

Try to disable scrolling acceleration:

  • about:preferences#advanced under General -> Browsing
Please update to the most recent version of Firefox: *[[Update Firefox to the latest version]] Try to disable scrolling acceleration: *about:preferences#advanced under General -> Browsing
cor-el
  • Top 10 Contributor
  • Moderator
17696 solutions 160119 answers

Try to set gfx.xrender.enabled to false on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Try to set <b>gfx.xrender.enabled</b> to false on the <b>about:config</b> page. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Question owner

Please note: each configuration was tested by closing and restarting the browser to ensure the setting change was loaded on application start.

guigs2 said

Please update to the most recent version of Firefox:

At the time of posting, FF39 was not available. I have since upgraded but the problem still exists.

Try to disable scrolling acceleration:
  • about:preferences#advanced under General -> Browsing

As noted in my original post, unchecking any of the scroll-related options (in addition to hardware acceleration) in the Advanced tab have no effect. As of FF39, this statement remains true.

cor-el said

Try to set gfx.xrender.enabled to false on the about:config page. You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

This also had no effect.

Please note: each configuration was tested by closing and restarting the browser to ensure the setting change was loaded on application start. ''guigs2 [[#answer-750545|said]]'' <blockquote> Please update to the most recent version of Firefox: *[[Update Firefox to the latest version]] </blockquote> At the time of posting, FF39 was not available. I have since upgraded but the problem still exists. <blockquote> Try to disable scrolling acceleration: *about:preferences#advanced under General -> Browsing </blockquote> As noted in my original post, unchecking any of the scroll-related options (in addition to hardware acceleration) in the Advanced tab have no effect. As of FF39, this statement remains true. ''cor-el [[#answer-750555|said]]'' <blockquote> Try to set <b>gfx.xrender.enabled</b> to false on the <b>about:config</b> page. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config </blockquote> This also had no effect.

Modified by sdlambert

cor-el
  • Top 10 Contributor
  • Moderator
17696 solutions 160119 answers

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

There might be extensions and plugins installed by default in a new profile, so check "Firefox/Tools > Add-ons > Extensions & Plugins" in case there are still problems.

Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox There might be extensions and plugins installed by default in a new profile, so check "Firefox/Tools > Add-ons > Extensions & Plugins" in case there are still problems.

Question owner

cor-el said

Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile":

When I try to launch I get the following error:

GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

After that it says "Error: argument -p requires a profile name" (I am using a capital P)

''cor-el [[#answer-751552|said]]'' <blockquote> Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues </blockquote> When I try to launch I get the following error: GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed After that it says "Error: argument -p requires a profile name" (I am using a capital P)

Question owner

Am I allowed to bump?

Am I allowed to bump?
cor-el
  • Top 10 Contributor
  • Moderator
17696 solutions 160119 answers

Try to reinstall Firefox and delete the current Firefox program directory.

You can find the full version of the current current Firefox release (39.0) in all languages and all operating systems here:

You can rename the profiles.ini file to force Firefox to create a new default profile. You need to locate the profiles.ini file or use the Profile Manager to create a new profile.

You should find the profiles.ini file in this hidden location:

  • Linux: ~/.mozilla/firefox/
  • Mac: ~/Library/Application Support/Firefox/
  • Windows: %AppData%\Mozilla\Firefox\
    C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\

Try to reinstall Firefox and delete the current Firefox program directory. You can find the full version of the current current Firefox release (39.0) in all languages and all operating systems here: *https://www.mozilla.org/en-US/firefox/all/ You can rename the profiles.ini file to force Firefox to create a new default profile. You need to locate the profiles.ini file or use the Profile Manager to create a new profile. You should find the profiles.ini file in this hidden location: *Linux: ~/.mozilla/firefox/ *Mac: ~/Library/Application Support/Firefox/ *Windows: %AppData%\Mozilla\Firefox\<br>C:\Users\&lt;user&gt;\AppData\Roaming\Mozilla\Firefox\ ---- *http://kb.mozillazine.org/Profile_Manager *https://support.mozilla.org/kb/Managing+profiles *http://kb.mozillazine.org/Profile_folder_-_Firefox