Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google Maps No Longer Works in Firefox?

  • 3 replies
  • 4 have this problem
  • 79 views
  • Last reply by jscher2000

more options

I am using FF 38.0.5 and just went to Google Maps and got this error message:

"Your browser needs to be updated to use Google Maps"

I'm not blocking any functionality of Google Maps, so why am I getting this error message?

Chosen solution

Hmm, it's quite different on Windows. Hopefully a Mac user can advise on whether that combination should work on Google Maps.

Meanwhile, some general advice:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See the steps in this article: How to clear the Firefox cache

Note: If you have a large hard drive, that process might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page somewhere on google.com, try either:

  • right-click/Ctrl+click the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

Read this answer in context 👍 0

All Replies (3)

more options

Is this on the "main" page here: https://www.google.com/maps

Google uses a variety of graphical technologies that sometimes require updated graphics card driver software. We have a general article on that here: Upgrade your graphics drivers to use hardware acceleration and WebGL.

To see whether Firefox is disabling WebGL or some other technologies that might be relevant, could you check the support information page? You can open that using any of these:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

If you scroll down, you should find a table with the header "Graphics" above it. If you could select and copy that entire section of the page and then paste it into a reply, we might get a better idea of what's going on.

more options

Thanks:

Device ID 0x 166 GPU Accelerated Windows 9/9 OpenGL (OMTC) Vendor ID 0x8086 WebGL Renderer Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine windowLayerManagerRemote true AzureCanvasBackend quartz AzureContentBackend quartz AzureFallbackCanvasBackend none AzureSkiaAccelerated 0

more options

Chosen Solution

Hmm, it's quite different on Windows. Hopefully a Mac user can advise on whether that combination should work on Google Maps.

Meanwhile, some general advice:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See the steps in this article: How to clear the Firefox cache

Note: If you have a large hard drive, that process might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page somewhere on google.com, try either:

  • right-click/Ctrl+click the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?