X
Tap here to go to the mobile version of the site.

Support Forum

youtube won't play but no error message

Posted

This has been an issue for over a year now.

Youtube (or any video for that matter! ) refuses to play. When i click on a video or land on a video page, the video just shows the "loading" icon and will continue to "load" with no end in sight. I get no errors, no messages, NOTHING. So i can't even figure out why it won't go past the load screen.

The only thing that fixes this problem is to completely uninstall flash and leave it uninstalled but most websites require flash so it's driving me insane. I can't find a happy medium with anything.

I set my permissions to "require permission" and also tried " do not allow" and both dont help the issue or work around the problem.


What else is there to do ?? ... 13 months with this problem is long enough.

Thanks !

Tanya

This has been an issue for over a year now. Youtube (or any video for that matter! ) refuses to play. When i click on a video or land on a video page, the video just shows the "loading" icon and will continue to "load" with no end in sight. I get no errors, no messages, NOTHING. So i can't even figure out why it won't go past the load screen. The only thing that fixes this problem is to completely uninstall flash and leave it uninstalled but most websites require flash so it's driving me insane. I can't find a happy medium with anything. I set my permissions to "require permission" and also tried " do not allow" and both dont help the issue or work around the problem. What else is there to do ?? ... 13 months with this problem is long enough. Thanks ! Tanya

Additional System Details

Installed Plug-ins

  • Garmin Communicator Plug-In 4.1.0.0
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • Shockwave Flash 18.0 r0

Application

  • Firefox 38.0.5
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.5/WINNT/en-US/

Extensions

  • Click to Play per-element 0.3.1.1-signed (ClickToPlayPerElement@uaSad.addons.mozilla.org)
  • Garmin Communicator 4.1.0.1-signed ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • NoSquint 2.1.9.1-signed (nosquint@urandom.ca)
  • S3.Google Translator 4.02.1-signed (s3google@translator)
  • WOT 20131118.1-signed ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7})
  • YouTube™ Flash® Player 1.3.1-signed (jid1-HAV2inXAnQPIeA@jetpack)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 5500
  • adapterDescription2:
  • adapterDeviceID: 0x1616
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 06651028
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 0 Enhanced Contrast: 200
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17795
  • driverDate: 11-11-2014
  • driverDate2:
  • driverVersion: 10.18.10.4013
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 5500 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8703 solutions 71122 answers

13 months!!

Just to review your general approach to managing Flash settings, is this correct:

  • Shockwave Flash plugin is set to "Ask to Activate" on the Add-ons page, Plugins list
  • The Click to Play per-element extension modifies the permission management from a per-site activation (using the plugin notification icon in the address bar, it looks like a small Lego block) to a per-player activation (I'm not familiar with where you approve the player)
  • You are able to use the activation controls to activate the Flash media you want to play, but then it doesn't actually load once you do?

Note that some sites display a "poster" image in front of the video player and that may sometimes block the click-to-play activation link in the player. I'm not sure how the extension works around that.

Also, a few months ago, YouTube switched most Firefox users to its HTML5 player instead of using its traditional Flash player. I think one of your extensions (YouTube™ Flash® Player) is overriding that and forcing Flash. Did you try it without Flash and if so, what were the results?

13 months!! Just to review your general approach to managing Flash settings, is this correct: * Shockwave Flash plugin is set to "Ask to Activate" on the Add-ons page, Plugins list * The [https://addons.mozilla.org/firefox/addon/click-to-play-per-element/ Click to Play per-element extension] modifies the permission management from a per-site activation (using the plugin notification icon in the address bar, it looks like a small Lego block) to a per-player activation (I'm not familiar with where you approve the player) * You are able to use the activation controls to activate the Flash media you want to play, but then it doesn't actually load once you do? Note that some sites display a "poster" image in front of the video player and that may sometimes block the click-to-play activation link in the player. I'm not sure how the extension works around that. Also, a few months ago, YouTube switched most Firefox users to its HTML5 player instead of using its traditional Flash player. I think one of your extensions (YouTube™ Flash® Player) is overriding that and forcing Flash. Did you try it without Flash and if so, what were the results?

Question owner

None of these options work. :( all i get is a black screen with the center "Loading" symbol constantly spinning. OR it'll load the first frame ... continue to load... and never play.

Only time it works is when i completely uninstall flash ... still. :(

None of these options work. :( all i get is a black screen with the center "Loading" symbol constantly spinning. OR it'll load the first frame ... continue to load... and never play. Only time it works is when i completely uninstall flash ... still. :(

Modified by TanyaAD138

jscher2000
  • Top 10 Contributor
8703 solutions 71122 answers

Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart. It says add-ons disabled, but only extensions are disabled, not plugins.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''It says add-ons disabled, but only extensions are disabled, not plugins.'' ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any difference?

Question owner

OK i started in safe mode AND..................... No Difference :( same problem.

OK i started in safe mode AND..................... No Difference :( same problem.
jscher2000
  • Top 10 Contributor
8703 solutions 71122 answers

While you are on YouTube, could you block Flash just for the site? You can do that here:

  • right-click the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or globe icon to the left of the site address > More Information > Permissions

You should see a section listing different plugins and indicating the current permission for YouTube. Try setting Adobe Flash to Block, and then reload the page and see whether that makes any difference.

While you are on YouTube, could you block Flash just for the site? You can do that here: * right-click the page and choose View Page Info > Permissions * (menu bar) Tools menu > Page Info > Permissions * click the padlock or globe icon to the left of the site address > More Information > Permissions You should see a section listing different plugins and indicating the current permission for YouTube. Try setting Adobe Flash to Block, and then reload the page and see whether that makes any difference.

Question owner

I tried both blocking flash and disabling flash and both do no good. It's not just youtube but ANY sort of video playback ... i had this issue with my Toshiba laptop too .. i am now using a new dell xps 13 and still having this issue. it will either be a black screen with the loading symbol in movement. or load the first frame and show in the progress bar that it's loading but will never play.

I dont want to get rid of Firefox but after 2 different laptops having the same issue i dont know what else to do. I can't understand how it seems im the only one having this issue?...

I tried both blocking flash and disabling flash and both do no good. It's not just youtube but ANY sort of video playback ... i had this issue with my Toshiba laptop too .. i am now using a new dell xps 13 and still having this issue. it will either be a black screen with the loading symbol in movement. or load the first frame and show in the progress bar that it's loading but will never play. I dont want to get rid of Firefox but after 2 different laptops having the same issue i dont know what else to do. I can't understand how it seems im the only one having this issue?...

Question owner

wait a minute .. i just noticed something under "view page info" ...notice how that line is greyed out?? and it's video??... what is that all about??

wait a minute .. i just noticed something under "view page info" ...notice how that line is greyed out?? and it's video??... what is that all about??
jscher2000
  • Top 10 Contributor
8703 solutions 71122 answers

Thanks for the screen shot. I think gray italics mean not cached, and therefore not possible to save through this dialog, but I haven't researched it.

The mediasource: protocol at the beginning of the URL indicates YouTube is triggering a recent feature of Firefox. I don't know whether it is used on any other sites that are giving you problems. You could try disabling the mediasource feature to try to force YouTube to use a more conventional technology to see whether that helps. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste media and pause while the list is filtered

(3) Double-click the media.mediasource.enabled preference to switch it from true to false. Or, if it was already set to false, try double-clicking it to switch it back to true.

Reload the YouTube page to test (I used Ctrl+Shift+r to bypass cache). Any difference?

Thanks for the screen shot. I think gray italics mean not cached, and therefore not possible to save through this dialog, but I haven't researched it. The mediasource: protocol at the beginning of the URL indicates YouTube is triggering a recent feature of Firefox. I don't know whether it is used on any other sites that are giving you problems. You could try disabling the mediasource feature to try to force YouTube to use a more conventional technology to see whether that helps. Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''media''' and pause while the list is filtered (3) Double-click the '''media.mediasource.enabled''' preference to switch it from true to false. Or, if it was already set to false, try double-clicking it to switch it back to true. Reload the YouTube page to test (I used Ctrl+Shift+r to bypass cache). Any difference?