X
Tap here to go to the mobile version of the site.

Support Forum

Web pages won't fit into browser withour having to scroll < or >

Posted

Time and time again. I have tried increasing the resolution, I have tried decreasing font size, no pages on the we fit my browser window without having to scroll left or right to view the whole page. Its damned frustrating. How do I make Firefox fit the whole page?

Time and time again. I have tried increasing the resolution, I have tried decreasing font size, no pages on the we fit my browser window without having to scroll left or right to view the whole page. Its damned frustrating. How do I make Firefox fit the whole page?

Chosen solution

I think solved it. Open about:config Click on: extensions.browser.zoom.fitZoom.maximum set the value to 100 instead of the default value of 150. It seems to make the default zoom 80% of full zoom on every page including new tabs.

I will try it out for the next couple of days and report back.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Foxit Reader Plug-In For Firefox and Netscape
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • Plug-in for Workspace utilities
  • Shockwave Flash 17.0 r0
  • 5.1.40416.0
  • Unity Player 4.6.3f1
  • VLC media player Web Plugin
  • Plug-in for Workspace Webmail
  • Yahoo Application State Plugin version 1.0.0.7

Application

  • Firefox 38.0.5
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.5/WINNT/en-US/

Extensions

  • Social Privacy 1.0 (sp2@sp.com) (Inactive)
  • WBE Paste 1.3 (wbepaste@starfield) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Standard VGA Graphics Adapter
  • adapterDescription2:
  • adapterDeviceID: 0x2582
  • adapterDeviceID2:
  • adapterDrivers: vga framebuf vga256 vga64k
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 300d103c
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.17292
  • driverDate: 6-21-2006
  • driverDate2:
  • driverVersion: 6.1.7600.16385
  • driverVersion2:
  • failures: [u'[GFX1-]: Disabling WARP on builtin vga driver']
  • indices: [0]
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedDriver']
  • numTotalWindows: 1
  • webglRendererMessage: [u'blockedDriver']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
guigs 1072 solutions 11697 answers

Hello, Have you tried Firefox's zoom feature? This will help increase the size of web pages.

  • To make things bigger, press Ctrl and + at the same time.
  • To make things smaller, press Ctrl and - at the same time.
  • To reset the size back to normal, press Ctrl and 0 at the same time.

You can also use the NoSquint. add-on to change the default zoom level for all websites at once. After setting your global zoom level, you can still fine-tune the zoom on individual sites.

Using NoSquint:

  1. After installing NoSquint, make sure you have the Add-on Bar displayed:
    • Right-click the new tab button ("+") or a blank area of the tab bar to the right of it and choose Add-on Bar from the shortcut menu.
  2. Click the % on the Add-on Bar to call up site preferences, then click the Global Settings button, then the Zooming tab.
    • You can experiment with sizes larger than 125%, but it's not recommended that you go higher than 150% unless you have a large high-resolution monitor.

If there are particular sites that still present a problem, feel free to post their URLs.

Please let us know if this helped you!

Thank you.

Hello, Have you tried [[Font size and zoom - increase the size of web pages|Firefox's zoom feature]]? This will help increase the size of web pages. * To make things bigger, press '''Ctrl''' and '''&#43''' at the same time. * To make things smaller, press '''Ctrl''' and '''-''' at the same time. * To reset the size back to normal, press '''Ctrl''' and '''0''' at the same time. You can also use the [https://addons.mozilla.org/en-US/firefox/addon/2592/ NoSquint]. add-on to change the default zoom level for all websites at once. After setting your global zoom level, you can still fine-tune the zoom on individual sites. '''Using NoSquint:''' #After installing NoSquint, make sure you have the Add-on Bar displayed: #*Right-click the new tab button ("+") or a blank area of the tab bar to the right of it and choose Add-on Bar from the shortcut menu. #Click the % on the Add-on Bar to call up site preferences, then click the Global Settings button, then the Zooming tab. #*You can experiment with sizes larger than 125%, but it's not recommended that you go higher than 150% unless you have a large high-resolution monitor. If there are particular sites that still present a problem, feel free to post their URLs. Please let us know if this helped you! Thank you.
cor-el
  • Top 10 Contributor
  • Moderator
17425 solutions 157457 answers

Try to set layout.css.devPixelsPerPx to 1.0 (default is -1) on the about:config page. If necessary adjust its value in 0.1 or 0.05 steps (1.1 or 0.9) until icons or text looks right.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can look at the Default FullZoom Level or NoScript extension to set a default font size and page zoom on web pages.

Try to set layout.css.devPixelsPerPx to 1.0 (default is -1) on the <b>about:config</b> page. If necessary adjust its value in 0.1 or 0.05 steps (1.1 or 0.9) until icons or text looks right. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config You can look at the Default FullZoom Level or NoScript extension to set a default font size and page zoom on web pages. *Default FullZoom Level: https://addons.mozilla.org/firefox/addon/default-fullzoom-level/ *NoSquint: https://addons.mozilla.org/firefox/addon/nosquint/

Question owner

Well the second answer about the "default zoom" sort of helped. But let me explain further. The problem I am running into is that pages show up too big. Pressing a CNTRL - until the page view is 75% makes it viewable. But I have to do this with EVERY window and every tab. Its annoying. Is there anyway to set the default zoom to 75% and keep it there?

Well the second answer about the "default zoom" sort of helped. But let me explain further. The problem I am running into is that pages show up too big. Pressing a CNTRL - until the page view is 75% makes it viewable. But I have to do this with EVERY window and every tab. Its annoying. Is there anyway to set the default zoom to 75% and keep it there?
cor-el
  • Top 10 Contributor
  • Moderator
17425 solutions 157457 answers

Are the dimensions of the Firefox user interface correct and is only the browsing area affected?

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB
Are the dimensions of the Firefox user interface correct and is only the browsing area affected? Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem *Use a compressed image type like PNG or JPG to save the screenshot *Make sure that you do not exceed the maximum size of 1 MB

Question owner

Notice how the text and images go off screen to the right? Thats the default size. If I ctrl- twice or 3 times to 75%, in the next picture, twice to 80%, the whole page comes into view. The tool bar seems ok, its just the web pages I believe.

Notice how the text and images go off screen to the right? Thats the default size. If I ctrl- twice or 3 times to 75%, in the next picture, twice to 80%, the whole page comes into view. The tool bar seems ok, its just the web pages I believe.

Modified by gamesmedic

jscher2000
  • Top 10 Contributor
8643 solutions 70728 answers

Helpful Reply

gamesmedic said

The problem I am running into is that pages show up too big. Pressing a CNTRL - until the page view is 75% makes it viewable. But I have to do this with EVERY window and every tab. Its annoying. Is there anyway to set the default zoom to 75% and keep it there?

Both the Default FullZoom extension and the NoSquint extension let you set a reduced zoom level as your default or global level. For example, you could try 80%. This will apply to every site where Firefox hasn't already stored a preferred zoom level.

''gamesmedic [[#answer-743462|said]]'' <blockquote> The problem I am running into is that pages show up too big. Pressing a CNTRL - until the page view is 75% makes it viewable. But I have to do this with EVERY window and every tab. Its annoying. Is there anyway to set the default zoom to 75% and keep it there? </blockquote> Both the Default FullZoom extension and the NoSquint extension let you set a reduced zoom level as your default or global level. For example, you could try 80%. This will apply to every site where Firefox hasn't already stored a preferred zoom level.

Question owner

I installed the addon, Still every new page that opens goes to the default zoom of 100%.

I installed the addon, Still every new page that opens goes to the default zoom of 100%.
jscher2000
  • Top 10 Contributor
8643 solutions 70728 answers

Which add-on did you select? I think by default they start at 100% zoom, so you need to go into their Options to change that to the zoom level you want.

For many extensions, you can find an Options button on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then find the extension on the right side and click its Options button. (If there is no options button, there may be a new toolbar button to control the add-on.)

Which add-on did you select? I think by default they start at 100% zoom, so you need to go into their Options to change that to the zoom level you want. For many extensions, you can find an Options button on the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then find the extension on the right side and click its Options button. (If there is no options button, there may be a new toolbar button to control the add-on.)

Chosen Solution

I think solved it. Open about:config Click on: extensions.browser.zoom.fitZoom.maximum set the value to 100 instead of the default value of 150. It seems to make the default zoom 80% of full zoom on every page including new tabs.

I will try it out for the next couple of days and report back.

I think solved it. Open about:config Click on: '''extensions.browser.zoom.fitZoom.maximum''' set the value to '''100''' instead of the default value of '''150'''. It seems to make the default zoom 80% of full zoom on every page including new tabs. I will try it out for the next couple of days and report back.

Question owner

What you said, and what I did resulted in the same outcome. But your way might seem easier to most people.

What you said, and what I did resulted in the same outcome. But your way might seem easier to most people.