X
Tap here to go to the mobile version of the site.

Support Forum

I can't get those auto play videos to stop playing automatically, help.

Posted

I have Shockwave Flash set to ask to activate and I have media.autoplay set to false and they still keep playing.

I have Shockwave Flash set to ask to activate and I have media.autoplay set to false and they still keep playing.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.11
  • LogMeIn, Inc. Remote Access Components
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealTimes Download Plugin
  • Shockwave Flash 18.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.4.144
  • 5.1.40416.0
  • VLC media player Web Plugin
  • Yahoo Application State Plugin version 1.0.0.7
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; rv:38.0) Gecko/20100101 Firefox/38.0

More Information

jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

Helpful Reply

If you aren't getting asked to approve Flash on the site, then the site probably isn't using Flash. If you want to approve some Flash videos and not others, you need an add-on to extend the feature, for example: https://addons.mozilla.org/firefox/addon/click-to-play-per-element/

The media.autoplay.enabled preference "works" for videos that use the native HTML5 video player. The reason I put "works" in quotes is that many sites have discovered a trivial workaround: use a script to send a play command to the media to start it. Since it was stopped initially, that is not considered to be an autoplay.

It looks like Firefox 41 will finally block that trick; the code change was checked in on June 5th. Sometimes code changes can be moved up to a closer release, but I don't know whether that is possible in this case (it's definitely too late for Firefox 39). Anyway, this should be solved in less than 4 months...

Until then, as a workaround, you could try an extension. I looked at a few on the Add-ons site and the reviews on their effectiveness was very mixed, so at this point, I don't have any recommendations. If it's really maddening, you could take a look there.

If you aren't getting asked to approve Flash on the site, then the site probably isn't using Flash. If you want to approve some Flash videos and not others, you need an add-on to extend the feature, for example: https://addons.mozilla.org/firefox/addon/click-to-play-per-element/ The '''media.autoplay.enabled''' preference "works" for videos that use the native HTML5 video player. The reason I put "works" in quotes is that many sites have discovered a trivial workaround: use a script to send a play command to the media to start it. Since it was stopped initially, that is not considered to be an autoplay. It looks like Firefox 41 will finally block that trick; the code change was checked in on June 5th. Sometimes code changes can be moved up to a closer release, but I don't know whether that is possible in this case (it's definitely too late for Firefox 39). Anyway, this should be solved in less than 4 months... Until then, as a workaround, you could try an extension. I looked at a few on [https://addons.mozilla.org/firefox/ the Add-ons site] and the reviews on their effectiveness was very mixed, so at this point, I don't have any recommendations. If it's really maddening, you could take a look there.
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Helpful Reply

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

'''[https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block]''' {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it