X
Tap here to go to the mobile version of the site.

Support Forum

Close minimize buttons disappear after viewing YouTube full-screen videos

Posted

HEY! Are you going to fix this problem? It's been nearly a month and no solutions!? It's a really big pain and I will just use another browser if you aren't going to fix it. Please send an update SOON.

HEY! Are you going to fix this problem? It's been nearly a month and no solutions!? It's a really big pain and I will just use another browser if you aren't going to fix it. Please send an update SOON.

Chosen solution

It's strange you have this problem because other Mac users have been complaining about a different full screen problem on YouTube, which is that they wanted the browser to stay in full screen but only exit full screen for the video.

Either way, assuming YouTube is serving you the HTML5 player instead of the Flash player -- you can confirm by right-clicking / Ctrl+clicking the player and checking the last line of the short context menu -- you can force the use of the Flash plugin with an extension (YouTube Flash Video Player). Going to or exiting from full screen in the Flash player should not affect your Firefox window one way or the other.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.06
  • Amazon MP3 Downloader Plugin 1.0.17
  • Simple plug-in that handles Citrix connection files
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0
  • WebEx64 General Plugin Container Version 205
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:38.0) Gecko/20100101 Firefox/38.0

More Information

guigs 1072 solutions 11697 answers

Please update your plugins to the latest version. Check to make sure you are up to date:

If you see any issues also see:

In the "Customize menu" did you try to enable the title bar as well (Title Bar button on the bottom left)?

Please update your plugins to the latest version. Check to make sure you are up to date: *[https://www.mozilla.org/en-US/plugincheck/] If you see any issues also see: *[[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] In the "Customize menu" did you try to enable the title bar as well (Title Bar button on the bottom left)?

Modified by guigs

jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Chosen Solution

It's strange you have this problem because other Mac users have been complaining about a different full screen problem on YouTube, which is that they wanted the browser to stay in full screen but only exit full screen for the video.

Either way, assuming YouTube is serving you the HTML5 player instead of the Flash player -- you can confirm by right-clicking / Ctrl+clicking the player and checking the last line of the short context menu -- you can force the use of the Flash plugin with an extension (YouTube Flash Video Player). Going to or exiting from full screen in the Flash player should not affect your Firefox window one way or the other.

It's strange you have this problem because other Mac users have been complaining about a different full screen problem on YouTube, which is that they wanted the browser to stay in full screen but only exit full screen for the video. Either way, assuming YouTube is serving you the HTML5 player instead of the Flash player -- you can confirm by right-clicking / Ctrl+clicking the player and checking the last line of the short context menu -- you can force the use of the Flash plugin with an extension ([https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/ YouTube Flash Video Player]). Going to or exiting from full screen in the Flash player should not affect your Firefox window one way or the other.