X
Tap here to go to the mobile version of the site.

Support Forum

How do I stop the search options page from defaulting to Yahoo when I select Google as the default?

Posted

I set Google as the default, remove every other search engine from the search options page including the generic search with magnifying glass sign, and every time I open Firefox, everything is back as it was before the changes. This is extremely frustrating! I have tried the answers here as well as any answers I could understand in a search, and nothing works. Supposedly this was a problem with version 34 and fixed after that, but I am using 38.0.5! Solving this should not be as difficult as it is!

I am running Vista Ultimate (32 bit).

I set Google as the default, remove every other search engine from the search options page including the generic search with magnifying glass sign, and every time I open Firefox, everything is back as it was before the changes. This is extremely frustrating! I have tried the answers here as well as any answers I could understand in a search, and nothing works. Supposedly this was a problem with version 34 and fixed after that, but I am using 38.0.5! Solving this should not be as difficult as it is! I am running Vista Ultimate (32 bit).

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Shockwave Flash 17.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:38.0) Gecko/20100101 Firefox/38.0

More Information

FredMcD
  • Top 10 Contributor
4307 solutions 60484 answers

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove Yahoo Anything. Now do the same in the computers Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.


Bookmark and use this; Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.


Settings Guard for Firefox {web link} Detects and resets changes to settings that are frequently done by add-ons and application installers.

Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac:<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Remove Yahoo Anything. Now do the same in the computers Programs Folder. '''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the "Applications" folder. '''Linux:''' Check your user manual. ---------------------------------- Bookmark and use this; '''[https://addons.mozilla.org/en-US/firefox/addon/searchreset/ Mozilla Search Reset]''' {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page. ---------------- '''[https://addons.mozilla.org/en-US/firefox/addon/settings-guard Settings Guard for Firefox]''' {web link} Detects and resets changes to settings that are frequently done by add-ons and application installers.

Question owner

Fred - finally had to reload Firefox, so I tried your fix. It didn't work.

Fred - finally had to reload Firefox, so I tried your fix. It didn't work.
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

A generic search with a magnifying glass? That sounds odd. I wouldn't bother removing search plugins the next time, just change the default at the top.


There are several possible explanations for this annoying situation.

(1) Please see our support article, particularly the section on a possible, optional, user.js file in your settings (profile) folder: How to fix preferences that won't save. By default, Windows hides the .js extension, so if you see a file named user with a type of JScript, that's most likely the user.js file. Or to make it easier, set Windows to show all file extensions using the steps in this article: http://windows.microsoft.com/en-us/wi.../show-hide-file-name-extensions.

(2) If you use Advanced SystemCare, or another security/privacy/utility program that prevents unwanted changes to browser settings (sometimes called home page protection), try disabling that until you have Firefox working properly. Otherwise, the program will keep undoing your changes.

(3) Investigate possible malware, or at least a bad add-on. Here's my suggested procedure for tracking down and cleaning up bad add-ons. I know it seems long, but it's not that bad.

(A) Open the Windows Control Panel, Uninstall a Program. After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Be suspicious of everything you do not recognize/remember, as malware often uses important or innocent sounding names to discourage you from removing it. Take out as much trash as possible here.

(B) Open Firefox's Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
  • in the Windows "Run" dialog, type or paste
    firefox.exe "about:addons"

In the left column, click Plugins. Set nonessential and unrecognized plugins to "Never Activate".

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions. Bear in mind that all extensions are optional; none ship with Firefox.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

(C) You can search for remaining issues with the scanning/cleaning tools listed in our support article: Troubleshoot Firefox issues caused by malware. These on-demand scanners are free and take considerable time to run. If they finish quickly and especially if they require payment, you may have a serious infection. I suggest the specialized forums listed in the article in that case.

Success?

A generic search with a magnifying glass? That sounds odd. I wouldn't bother removing search plugins the next time, just change the default at the top. ---- There are several possible explanations for this annoying situation. (1) Please see our support article, particularly the section on a possible, optional, user.js file in your settings (profile) folder: [[How to fix preferences that won't save]]. ''By default, Windows hides the .js extension, so if you see a file named user with a type of JScript, that's most likely the user.js file. Or to make it easier, set Windows to show all file extensions using the steps in this article: [http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions].'' (2) If you use Advanced SystemCare, or another security/privacy/utility program that prevents unwanted changes to browser settings (sometimes called home page protection), try disabling that until you have Firefox working properly. Otherwise, the program will keep undoing your changes. (3) Investigate possible malware, or at least a bad add-on. Here's my suggested procedure for tracking down and cleaning up bad add-ons. I know it seems long, but it's not that bad. (A) Open the Windows '''Control Panel''', Uninstall a Program. After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. ''Be suspicious of everything you do not recognize/remember, as malware often uses important or innocent sounding names to discourage you from removing it.'' Take out as much trash as possible here. (B) Open Firefox's '''Add-ons page''' using either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons * in the Windows "Run" dialog, type or paste <br><code>firefox.exe "about:addons"</code> In the left column, click '''Plugins'''. Set nonessential and unrecognized plugins to "Never Activate". In the left column, click '''Extensions'''. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions. ''Bear in mind that all extensions are optional; none ship with Firefox.'' Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step. Any improvement? (C) You can search for remaining issues with the '''scanning/cleaning tools''' listed in our support article: [[Troubleshoot Firefox issues caused by malware]]. These on-demand scanners are free and take considerable time to run. If they finish quickly and especially if they require payment, you may have a serious infection. I suggest the specialized forums listed in the article in that case. Success?