X
Tap here to go to the mobile version of the site.

Support Forum

extensions toolbar cannot be deactivated

Posted

Good morning,

In Iceweasel 38.01 I cannot permanently deactivate the extensions toolbar. There is not a single button on it and the option from the context-menu operates normally. But the toolbar reappears each time upon starting up the browser. I cannot locate a second configuration- or customization option, nor the pertinent help-text, if there is one, which allowed me to permanently get rid of the useless toolbar.

Thank you for any hints.

Good morning, In Iceweasel 38.01 I cannot permanently deactivate the extensions toolbar. There is not a single button on it and the option from the context-menu operates normally. But the toolbar reappears each time upon starting up the browser. I cannot locate a second configuration- or customization option, nor the pertinent help-text, if there is one, which allowed me to permanently get rid of the useless toolbar. Thank you for any hints.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0 Iceweasel/38.0.1

More Information

guigs 1072 solutions 11697 answers

It is possible to Refresh Firefox - reset add-ons and settings, however you may find more help in the iceweasal/ Debian forums.

It is possible to [[Refresh Firefox - reset add-ons and settings]], however you may find more help in the iceweasal/ Debian forums.
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159854 answers

Is this toolbar present here?

  • "3-bar" Firefox menu button > Customize > Show/Hide Toolbars
  • View > Toolbars
    Tap the Alt key or press F10 to show the Menu Bar
  • Right-click empty toolbar area

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB
Is this toolbar present here? *"3-bar" Firefox menu button > Customize > Show/Hide Toolbars *View > Toolbars<br>Tap the Alt key or press F10 to show the Menu Bar *Right-click empty toolbar area Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem *Use a compressed image type like PNG or JPG to save the screenshot *Make sure that you do not exceed the maximum size of 1 MB

Question owner

guigs2 said

It is possible to Refresh Firefox - reset add-ons and settings, however you may find more help in the iceweasal/ Debian forums.

This worked for the moment after the refresh. As after restart the browser-window is configured not any differently than before, I have to ask, if a profile-setting should be taken into consideration for the reset-procedure..?

''guigs2 [[#answer-741390|said]]'' <blockquote> It is possible to [[Refresh Firefox - reset add-ons and settings]], however you may find more help in the iceweasal/ Debian forums. </blockquote> This worked for the moment after the refresh. As after restart the browser-window is configured not any differently than before, I have to ask, if a profile-setting should be taken into consideration for the reset-procedure..?

Question owner

cor-el said

Is this toolbar present here?
  • "3-bar" Firefox menu button > Customize > Show/Hide Toolbars

No.

  • View > Toolbars

Yes. This menu identical to the lower part of the context-menu.

  • Right-click empty toolbar area

Yes. See my original message, above.

Can you attach a screenshot?

Click the URLs for bigger images : http://pix.toile-libre.org/?img=1434437834.png
http://pix.toile-libre.org/?img=1434437991.png

''cor-el [[#answer-741455|said]]'' <blockquote> Is this toolbar present here? *"3-bar" Firefox menu button > Customize > Show/Hide Toolbars </blockquote> No. <blockquote> *View > Toolbars </blockquote> Yes. This menu identical to the lower part of the context-menu. <blockquote> *Right-click empty toolbar area </blockquote> Yes. See my original message, above. <blockquote> Can you attach a screenshot? </blockquote> Click the URLs for bigger images : http://pix.toile-libre.org/?img=1434437834.png<img src='http://pix.toile-libre.org/upload/thumb/1434437834.png' /> <br/> http://pix.toile-libre.org/?img=1434437991.png<img src='http://pix.toile-libre.org/upload/thumb/1434437991.png' />

Question owner

Missed a third screen shot. Here it is.

Missed a third screen shot. Here it is.
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159854 answers

You can't hide that toolbar via the View > Toolbars menu?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
You can't hide that toolbar via the View > Toolbars menu? Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

cor-el said

You can't hide that toolbar via the View > Toolbars menu?

Yes I can and always could. But upon restarting the browser, the empty extension bar is always there.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

In Safe Mode, the extension bar is not displayed and does also not appear neither in the view-, nor in the context-menu.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance

Did that. The extension toolbar is still showing, each time, that I start the browser, irrespective of the state that I left it in (extension bar disabled or not) or the fact that I quit the browser in safe mode.

  • Do NOT click the Reset button on the Safe Mode start window

Iceweasel may be different from the ordinary Firefox release in that it does not even show a Reset button on that dialog.

Sorry. The extension bar is still taking up space while being completely useless. But I can live with that for the time.

''cor-el [[#answer-742043|said]]'' <blockquote> You can't hide that toolbar via the View > Toolbars menu? </blockquote> Yes I can and always could. But upon restarting the browser, the empty extension bar is always there. <blockquote> Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. </blockquote> In Safe Mode, the extension bar is not displayed and does also not appear neither in the view-, nor in the context-menu. <blockquote> *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance </blockquote> Did that. The extension toolbar is still showing, each time, that I start the browser, irrespective of the state that I left it in (extension bar disabled or not) or the fact that I quit the browser in safe mode. <blockquote> *Do NOT click the Reset button on the Safe Mode start window </blockquote> Iceweasel may be different from the ordinary Firefox release in that it does not even show a Reset button on that dialog. Sorry. The extension bar is still taking up space while being completely useless. But I can live with that for the time.

Question owner

Also, I forgot to add, that by disabling extensions one by one and restarting with the extensions toolbar disabled, it is showing again anyway. I cannot identify a single extension which would be responsible for this misbehavior.

Also, I forgot to add, that by disabling extensions one by one and restarting with the extensions toolbar disabled, it is showing again anyway. I cannot identify a single extension which would be responsible for this misbehavior.
guigs 1072 solutions 11697 answers

It also looks like this was a past work around, however I am not an expert in the iceweasel builds:

It also looks like this was a past work around, however I am not an expert in the iceweasel builds: *[http://forums.debian.net/viewtopic.php?f=6&t=89806]