Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

i need firefox 32, it is the only version that k of c bots will work on now

  • 1 reply
  • 2 have this problem
  • 11 views
  • Last reply by Seburo

more options

i play kingdom of camalot on facebook. on the game we use greasemonkey and bots. ff 32 is the only version that works correctly. i am trying to find a site that has it available. i already have it, but i have other players that are in need of it

All Replies (1)

more options

Hi

It is strongly recommended that you use the latest version of Firefox, not only for security issues but also for stability and performance improvements.

If you really must use an older version of Firefox, you can download it from this site.