Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

.pdf files in new tab appear as a white page. I't doesn't show pdf's

  • 10 replies
  • 3 have this problem
  • 82 views
  • Last reply by jscher2000

more options

what should I do? help pls :=)

All Replies (10)

more options

Please update your plugins to the latest version. Check to make sure you are up to date:

If you see any issues also see:

Next, in your profile delete the "mimetype" file to reset what Firefox does with applications.

Does this happen many different pdfs? If not, can you please provide an example, this can be passed to the pdf.js team to test.

more options

guigs2 said

Please update your plugins to the latest version. Check to make sure you are up to date: If you see any issues also see: Next, in your profile delete the "mimetype" file to reset what Firefox does with applications. Does this happen many different pdfs? If not, can you please provide an example, this can be passed to the pdf.js team to test.

I could only update java and adobe flash player

don't even have an adobe reader or foxit reader plugin if thats what I need

It happens with every pdf

idk where the mimetype thing is (whats it for anyway and where is it)

thanks for replying so much :)

more options

What is Firefox set to for PDFs? You can check that here:

"3-bar" menu button (or Tools menu) > Options > Applications

This list takes several moments to load. In the search box above the list, type or paste pdf and pause while Firefox filters the list.

What do you have on the right side next to "Portable Document Format (PDF)"?


Your "More System Details" lists a plugin named "Soda PDF 3D Reader" which I do not recognize. Does that sound like something you installed to read PDFs? If it doesn't work, you could disable its browser integration feature. See:

more options

jscher2000 said

What is Firefox set to for PDFs? You can check that here: "3-bar" menu button (or Tools menu) > Options > Applications This list takes several moments to load. In the search box above the list, type or paste pdf and pause while Firefox filters the list. What do you have on the right side next to "Portable Document Format (PDF)"?

Your "More System Details" lists a plugin named "Soda PDF 3D Reader" which I do not recognize. Does that sound like something you installed to read PDFs? If it doesn't work, you could disable its browser integration feature. See:

says "preview in firefox" and the icon is the unknown icon type, i can change preview to use foxit reader

I downloaded soda pdf for .cbr files, comic reading

more options

Thank you for the additional information.

Firefox's built-in PDF viewer ("Preview in Firefox") should not show a blank page (incorrect perhaps, but not completely blank). It's possible that the document is not loading for some reason or possibly the viewer is being broken by an add-on.

Does it work to change to a different viewer?

more options

jscher2000 said

Thank you for the additional information. Firefox's built-in PDF viewer ("Preview in Firefox") should not show a blank page (incorrect perhaps, but not completely blank). It's possible that the document is not loading for some reason or possibly the viewer is being broken by an add-on. Does it work to change to a different viewer?

Thank YOU both for helping :)

when I change "Preview in firefox" to "use foxit reader" it starts downloading the file instead of showing it in firefox, i want to see it in ff :(

Modified by projectfear22

more options

Does the Soda 3D PDF plugin appear as an option in the application settings? If so, and you try that, does it work?

Also, are you avoiding Adobe Reader? It includes a plugin to view PDFs in the browser. If you want to try it, you can get version 11 from this page (the new DC version has a very different interface, so if you are used to older versions, 11 probably is an easier transition): http://get.adobe.com/reader/enterprise/

more options

jscher2000 said

Does the Soda 3D PDF plugin appear as an option in the application settings? If so, and you try that, does it work? Also, are you avoiding Adobe Reader? It includes a plugin to view PDFs in the browser. If you want to try it, you can get version 11 from this page (the new DC version has a very different interface, so if you are used to older versions, 11 probably is an easier transition): http://get.adobe.com/reader/enterprise/

Nope only foxit, though maybe it would appear if I chosed use other but I want firefox to mainly preview it on it's own and use foxit when I download it, when I put it on Foxit, it doesn't preview the file but downloads it, which then can't be opened automatically cause I've moved Foxit onto D disk so firefox can't find it lol (what to do about this?)

how can I make preview in firefox work without reinstalling or restarting options?

more options

jscher2000 said

Does the Soda 3D PDF plugin appear as an option in the application settings? If so, and you try that, does it work? Also, are you avoiding Adobe Reader? It includes a plugin to view PDFs in the browser. If you want to try it, you can get version 11 from this page (the new DC version has a very different interface, so if you are used to older versions, 11 probably is an easier transition): http://get.adobe.com/reader/enterprise/

also yes I'm avoiding adobe as Foxit has a simpler interface, looks prettier, has more options, uses less CPU or RAM and it doesn't get "text block errors", with "text block" I mean a cube, when I used Adobe and printed something it ended up being cubes instead of text

more options

Does "Preview in Firefox" work in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. Here's how to test:

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Then try some PDFs. To exit Safe Mode and return to normal, exit out of Firefox and start it up without holding down the Shift key.

More info: Troubleshoot Firefox issues using Safe Mode.