Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Adobe Flash Will Not Install on Firefox - How Do I Fix This?

  • 12 replies
  • 1 has this problem
  • 81 views
  • Last reply by jenetm

more options

Hi - I have installed, deleted and reinstalled Adobe Flash at least 15 times. Everything goes fine. The install completes as normal. Then I go into the Firefox browser to check for the plugin and there's nothing. I have used the installer from the Adobe page and one from a link shared here in this forum from someone else having the same issue. Nothing worked. I'm on Windows. I have IE installed as well but I don't use it. I shouldn't have to switch over to IE whenever I need Flash. It defeats the purpose. Does anyone have any idea what is going on or how to fix it?

All Replies (12)

more options

IE uses a different version of Flash than Firefox uses. You need the Plugin version for Firefox.

You can download the latest Flash Plugin version from here: Select Windows - Plugin-based browsers - the EXE version. https://www.adobe.com/products/flashplayer/distribution3.html

more options

I wasn't using the IE Flash installer. I've been using the Firefox installer. I was only pointing out the until this issue is resolved, I have to switch over to IE for any site requiring Flash.

more options

the-edmeister said

IE uses a different version of Flash than Firefox uses. You need the Plugin version for Firefox. You can download the latest Flash Plugin version from here: Select Windows - Plugin-based browsers - the EXE version. https://www.adobe.com/products/flashplayer/distribution3.html

I wasn't using the IE Flash installer. I've been using the Firefox installer. I was only pointing out the until this issue is resolved, I have to switch over to IE for any site requiring Flash.

more options

On the Add-ons page, Plugins section, could "Shockwave Flash" be grayed out toward the bottom?

If it's not there either:

Check for the Physical Presence of the Plugin DLL

On 64-bit Windows 7 that is here:

C:\Windows\SysWOW64\Macromed\Flash

and the file would be named NPSWF32_17_0_0_188.dll (unless there is a newer version with something different instead of 188).

If the file is there... and exiting and starting Firefox back up does not discover it...

One possible reason for an installed plugin not to appear on the Add-ons page is if Firefox has been set NOT to scan the registry for plugins. Another is that Firefox's settings file storing plugin data has become corrupted. Here are the steps to check those possibilities:

Confirm that Firefox is scanning the registry for plugins

Firefox finds the Flash plugin from a registry entry. Some users have the scanning turned off for some reason. Here's how to check and fix that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste scan and pause while the list is filtered

(3) If plugin.scan.plid.all is not set to its default value of true, double-click it to toggle it back to the default.

If you changed this setting, exit and restart Firefox to trigger another scan.

If you check the Add-ons page, Plugins section again, can you find "Shockwave Flash" there?

If Firefox is set to scan but still does not find Flash and list it on the Add-ons page...

Remove Firefox's plugin registry file

Sometimes the pluginreg.dat file becomes corrupted. You can remove it and have Firefox re-scan for plugins.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button to launch a new Windows Explorer window showing your settings files.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename pluginreg.dat to something like pluginreg.old

Start Firefox back up again. (If you want to restore your previous non-private session, use History > Restore Previous Session.)

When you return to the Add-ons page, is "Shockwave Flash" finally there?

more options

jenetm said

I wasn't using the IE Flash installer. I've been using the Firefox installer. I was only pointing out the until this issue is resolved, I have to switch over to IE for any site requiring Flash.

There is no Firefox installer version of Flash. It is the plugin based browser version as was linked to.

Make sure Firefox is closed when installing Flash player.

Also Plugins including Flash, Java and such are not actually installed in Firefox like Extensions and complete themes are. The Plugins are installed on system and Firefox finds and makes use of them. This is why you can only deactivate/activate and no uninstall in Plugins panel of Addons Manager.

Modified by James

more options

jscher2000 said

On the Add-ons page, Plugins section, could "Shockwave Flash" be grayed out toward the bottom? If it's not there either: Check for the Physical Presence of the Plugin DLL On 64-bit Windows 7 that is here: C:\Windows\SysWOW64\Macromed\Flash and the file would be named NPSWF32_17_0_0_188.dll (unless there is a newer version with something different instead of 188). If the file is there... and exiting and starting Firefox back up does not discover it... One possible reason for an installed plugin not to appear on the Add-ons page is if Firefox has been set NOT to scan the registry for plugins. Another is that Firefox's settings file storing plugin data has become corrupted. Here are the steps to check those possibilities: Confirm that Firefox is scanning the registry for plugins Firefox finds the Flash plugin from a registry entry. Some users have the scanning turned off for some reason. Here's how to check and fix that: (1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful. (2) In the filter box, type or paste scan and pause while the list is filtered (3) If plugin.scan.plid.all is not set to its default value of true, double-click it to toggle it back to the default. If you changed this setting, exit and restart Firefox to trigger another scan. If you check the Add-ons page, Plugins section again, can you find "Shockwave Flash" there? If Firefox is set to scan but still does not find Flash and list it on the Add-ons page... Remove Firefox's plugin registry file Sometimes the pluginreg.dat file becomes corrupted. You can remove it and have Firefox re-scan for plugins. Open your current Firefox settings (AKA Firefox profile) folder using either
  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter
In the first table on the page, click the "Show Folder" button to launch a new Windows Explorer window showing your settings files. Leaving that window open, switch back to Firefox and Exit, either:
  • "3-bar" menu button > "power" button
  • File menu > Exit
Pause while Firefox finishes its cleanup, then rename pluginreg.dat to something like pluginreg.old Start Firefox back up again. (If you want to restore your previous non-private session, use History > Restore Previous Session.) When you return to the Add-ons page, is "Shockwave Flash" finally there?

Thanks jscher2000. I followed this troubleshooting checklist you provided. Shockwave is showing as a plugin. I set it to be always active. The files are there on the C drive and the registry is set to detect. Still not working. I had a problem with slow running scripts a couple of weeks ago. I disabled all the plugins and cleared everything then enabled them again. I suspect I missed something but I have no idea what. Your checklist didn't solve the problem but I really appreciate the thoroughness and that you provided assistance that went beyond basic 101 type stuff that most everyone already knows. I'll keep trying.

more options

jenetm said

Shockwave is showing as a plugin. I set it to be always active. The files are there on the C drive and the registry is set to detect. Still not working.

Just to clarify, we know you have the Shockwave for Director plugin listed in your "More System Details" from when you posted, but is the Add-ons page showing the Shockwave Flash plugin now, or is that one still missing?

If it is there and set to "Always Activate" then you would expect it to fire up on Adobe's "about Flash" page where Flash is used to detect your specific Flash version number: https://www.adobe.com/software/flash/about/ (example screen shot attached). Does that work?

more options
If it is there and set to "Always Activate" then you would expect it to fire up on Adobe's "about Flash" page where Flash is used to detect your specific Flash version number: https://www.adobe.com/software/flash/about/ (example screen shot attached). Does that work?

The box in your screen shot that is circled in red is black/empty when I go to the Adobe "about Flash" page. The plugin does show on the add-ons page though.

added leading <blockquote> tag ~J99

Modified by John99

more options

Do other plugins work? For example, trailers on Apple's site use QuickTime: http://trailers.apple.com/trailers/wb/batkidbegins/

more options

jscher2000 said

Do other plugins work? For example, trailers on Apple's site use QuickTime: http://trailers.apple.com/trailers/wb/batkidbegins/

Yep. I could view the trailer with no problem. Sidenote: I enjoyed that trailer! :-)

more options

The Batkid story was big local news here...

So I'm not sure what is special about Flash that it won't run.

Have you tried ruling out your extensions as the culprit by testing in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?


In some cases, random problems can be caused by a glitch in Firefox's program folder. To address that:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(1) Download a fresh installer for Firefox 38.0.1 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox (if applicable).

(3) Rename the program folder:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Does a cleanly reinstalled Firefox search Bing normally??

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
more options

jscher2000 said

The Batkid story was big local news here... So I'm not sure what is special about Flash that it won't run. Have you tried ruling out your extensions as the culprit by testing in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode. If Firefox is not running: Hold down the Shift key when starting Firefox. If Firefox is running: You can restart Firefox in Safe Mode using either:
  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled
and OK the restart. Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh). Any difference?

In some cases, random problems can be caused by a glitch in Firefox's program folder. To address that:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(1) Download a fresh installer for Firefox 38.0.1 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox (if applicable).

(3) Rename the program folder:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Does a cleanly reinstalled Firefox search Bing normally??

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

Hi Jscher2000 - I've been having major problems with Firefox off and on for the last month. It started with an Firefox update and everything went downhill form there. I did a complete clean and reinstall when all of the happened.

I really appreciate your help and your willingness to try to help resolve this issue. I'm probably going to uninstall and go back to IE. I'm really bummed because IE runs so slowly and it's not super stable but I'm burned out on spending all of time troubleshooting Firefox problems these days. Thanks again for your time and suggestions.