X
Tap here to go to the mobile version of the site.

Support Forum

Upgraded Firefox does not display pages correctly including Mozilla

Posted

I upgraded firefox and now have 3 critically issues.

1. Does not display most pages correctly see screenshot attached. Had to go on Chrome just to get in support. 2. Tells me every site I visit is unsecure once I say I will take the risk site is just text like screenshot 3. I no longer have firebug which I need immediately.

Please help! If you could send me the old version of firefox for MAC OS 10.10 that should work for now!

I upgraded firefox and now have 3 critically issues. 1. Does not display most pages correctly see screenshot attached. Had to go on Chrome just to get in support. 2. Tells me every site I visit is unsecure once I say I will take the risk site is just text like screenshot 3. I no longer have firebug which I need immediately. Please help! If you could send me the old version of firefox for MAC OS 10.10 that should work for now!

Chosen solution

So when you are viewing the page for this site: if you click the padlock icon in the address bar (or the gray ! warning icon), click More Information, then View Certificate, what is listed in the "Issued by" section and on the details tab under hierarchy? I have attached a screen shot for comparison.


Do have an Old Firefox Data folder on your desktop? If so, and if the settings folder inside it was updated recently, you might have used the Refresh feature during your update. This can happen when Firefox says it is starting slowly and you can speed it up by restoring some default settings. This would explain losing extensions and possibly other changes.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.81 Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
4272 solutions 59922 answers

There are several things this could be. Try these in order;

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can


There are several things this could be. Try these in order; Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' '''https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently''' https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can -------------------------------------

Question owner

Hi Fred,

I have always had that above clicked, so that does not seem to be the issue. It is surprising that firefox would require me to ok the certificate for mozilla or any site for that matter unless it has been hacked. I will add another screenshot of the certificate issue. I really want to get this fixed.

Hi Fred, I have always had that above clicked, so that does not seem to be the issue. It is surprising that firefox would require me to ok the certificate for mozilla or any site for that matter unless it has been hacked. I will add another screenshot of the certificate issue. I really want to get this fixed.
jscher2000
  • Top 10 Contributor
8797 solutions 71970 answers

Chosen Solution

So when you are viewing the page for this site: if you click the padlock icon in the address bar (or the gray ! warning icon), click More Information, then View Certificate, what is listed in the "Issued by" section and on the details tab under hierarchy? I have attached a screen shot for comparison.


Do have an Old Firefox Data folder on your desktop? If so, and if the settings folder inside it was updated recently, you might have used the Refresh feature during your update. This can happen when Firefox says it is starting slowly and you can speed it up by restoring some default settings. This would explain losing extensions and possibly other changes.

So when you are viewing the page for this site: if you click the padlock icon in the address bar (or the gray ! warning icon), click More Information, then View Certificate, what is listed in the "Issued by" section and on the details tab under hierarchy? I have attached a screen shot for comparison. ---- Do have an Old Firefox Data folder on your desktop? If so, and if the settings folder inside it was updated recently, you might have used the Refresh feature during your update. This can happen when Firefox says it is starting slowly and you can speed it up by restoring some default settings. This would explain losing extensions and possibly other changes.
cor-el
  • Top 10 Contributor
  • Moderator
17586 solutions 159090 answers

You can check the date and time and time zone in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

We have seen reports that the time as set via an internet based time service was so much out of sync that an error occurs, so if that is the case with you this service or try to switch to another time service.

You can check the date and time and time zone in the clock on your computer: (double) click the clock icon on the Windows Taskbar. *https://support.mozilla.org/kb/Secure+Connection+Failed We have seen reports that the time as set via an internet based time service was so much out of sync that an error occurs, so if that is the case with you this service or try to switch to another time service.

Helpful Reply

jscher2000 said

So when you are viewing the page for this site: if you click the padlock icon in the address bar (or the gray ! warning icon), click More Information, then View Certificate, what is listed in the "Issued by" section and on the details tab under hierarchy? I have attached a screen shot for comparison.

Do have an Old Firefox Data folder on your desktop? If so, and if the settings folder inside it was updated recently, you might have used the Refresh feature during your update. This can happen when Firefox says it is starting slowly and you can speed it up by restoring some default settings. This would explain losing extensions and possibly other changes.

Attached is a screenshot of what I have. I will disable avast and see if that could be causing the issue.

''jscher2000 [[#answer-734713|said]]'' <blockquote> So when you are viewing the page for this site: if you click the padlock icon in the address bar (or the gray ! warning icon), click More Information, then View Certificate, what is listed in the "Issued by" section and on the details tab under hierarchy? I have attached a screen shot for comparison. ---- Do have an Old Firefox Data folder on your desktop? If so, and if the settings folder inside it was updated recently, you might have used the Refresh feature during your update. This can happen when Firefox says it is starting slowly and you can speed it up by restoring some default settings. This would explain losing extensions and possibly other changes. </blockquote> Attached is a screenshot of what I have. I will disable avast and see if that could be causing the issue.

Question owner

THANK YOU!! It was the Avast not sure why but when I disabled the shield everything is working perfectly.

THANK YOU!! It was the Avast not sure why but when I disabled the shield everything is working perfectly.
jscher2000
  • Top 10 Contributor
8797 solutions 71970 answers

I'm sure there is a way to set up your Firefox to work with the avast! web shield. Normally it involves importing their certificate into the Authorities tab of Firefox's Certificate Manager. But... if you don't need avast! filtering your connections, then you're done.

I'm sure there is a way to set up your Firefox to work with the avast! web shield. Normally it involves importing their certificate into the Authorities tab of Firefox's Certificate Manager. But... if you don't need avast! filtering your connections, then you're done.