Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF freezes all of a sudden...on just one site that I use daily

  • 3 replies
  • 3 have this problem
  • 131 views
  • Last reply by FredMcD

more options

Hi all,

I use this page for years to get news on China (http://www.chinadaily.com.cn/china/society.html) It's obviously legit. Since two days ago when the page loads the CPU usage goes to 50-60% and stays there and FF starts to freeze, becoming unusable.

Interesting point: I just loaded the site on IE 8 with no problems. Some script they are using doesn't jive with FF it seems.

Thanks for any suggestions.

Chosen solution

I checked your link and had no problem.

Security Issue: Update your Flash Player Version 17.0.0.188
https://www.adobe.com/products/flashplayer/distribution3.html

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

I checked your link and had no problem.

Security Issue: Update your Flash Player Version 17.0.0.188
https://www.adobe.com/products/flashplayer/distribution3.html

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

more options

Thank you Fred. I didn't realize it was so simple. It seems clearing the cache and cookies solved the problem.

more options

Glad to help. Safe Surfing.