X
Tap here to go to the mobile version of the site.

Support Forum

How to remove yahoo search default from Firefox 38.0.1 (Macintosh)

Posted

How do I remove the automatic reset of Firefox to the awful yahoo search engine? I want Google as default search engine. Here is what I have already tried: a. Choosing Google over yahoo and then deleting the yahoo from preferences: Firefox always springs back to yahoo. b. Dowloading the "Google default" app. This worked on earlier versions of Firefox, before V 38.0.1. But it appears that the commercial interests behind Firefox have now circumvented this, as well, because the "Google default" app now no longer works. c. Erasing, and then re-installing the "Google default" app. No improvement.

If there is no way to deal with this, then I'm dumping FF and switching to Google Chrome.

How do I remove the automatic reset of Firefox to the awful yahoo search engine? I want Google as default search engine. Here is what I have already tried: a. Choosing Google over yahoo and then deleting the yahoo from preferences: Firefox always springs back to yahoo. b. Dowloading the "Google default" app. This worked on earlier versions of Firefox, before V 38.0.1. But it appears that the commercial interests behind Firefox have now circumvented this, as well, because the "Google default" app now no longer works. c. Erasing, and then re-installing the "Google default" app. No improvement. If there is no way to deal with this, then I'm dumping FF and switching to Google Chrome.

Chosen solution

Hello, I am suspicious of some of your extensions, so please Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

If the problem is caused by an extension, once it has been removed/disabled, you may need to run SearchReset to revert your settings.

Troubleshoot Firefox issues caused by malware may also be helpful.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Read this answer in context 9

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.13
  • Plugin to display and edit chemical structures.
  • Provides information about the default web browser
  • Version 5.41.0.0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Juniper Networks Safari Extensions
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 17.0 r0
  • WebEx64 General Plugin Container Version 205
  • iPhoto6

Application

  • Firefox 38.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.1/Darwin/en-US/

Extensions

  • Adblock Plus 2.6.9 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Boomerang for GMail 1.2.4 ({65e41d20-f092-41b7-bb83-c6e8a9ab0f57})
  • DBankPlugin 1.1.0.3 (HighSpeedDownload@dbank.com)
  • Default Search Engine 3.3 (defaultSE@42sites.org)
  • DuckDuckGo Plus 0.4.6 (jid1-ZAdIEUB7XOzOJw@jetpack)
  • Gmail™ Notifier Plus 0.1.6 (jid1-sqmEAwSoa3FZPc@jetpack)
  • Google search link fix 1.4.9 (jid0-XWJxt5VvCXkKzQK99PhZqAn7Xbg@jetpack)
  • Searchme 2.5 (searchme@mybrowserbar.com)
  • PriceBlink 4.2 (info@priceblink.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 126
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: ATI Technologies Inc. -- AMD Radeon HD 6750M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Scribe 725 solutions 3456 answers

Chosen Solution

Hello, I am suspicious of some of your extensions, so please Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

If the problem is caused by an extension, once it has been removed/disabled, you may need to run SearchReset to revert your settings.

Troubleshoot Firefox issues caused by malware may also be helpful.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Hello, I am suspicious of some of your extensions, so please '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx If the problem is caused by an extension, once it has been removed/disabled, you may need to run [https://addons.mozilla.org/en-US/firefox/addon/searchreset/ SearchReset] to revert your settings. [[Troubleshoot Firefox issues caused by malware]] may also be helpful. When you figure out what's causing your issues, please let us know. It might help others with the same problem.
FredMcD
  • Top 10 Contributor
4184 solutions 58423 answers

I agree with the above actions.

I agree with the above actions.

Helpful Reply

Hi - here is what happened. There are two different ways around the yahoo scurrage:

A. Over the past 2 or 3 days, the download version of the North American version FF V 38.0.1 has been modified to include an App, titled "Default Search Engine 3.3". So, click on "Tools", then "Add-ons". Then adjust this Add-on to (e.g.) Google. I have re-started the browser, and the search engine choice seems to hold.

B. Mozilla/Firefox has signed some sort of deal with yahoo to promote yahoo search engine. This only applies to the North American edition of FF. For example, the German one does not have this gimmick. It stands to reason the the UK English version can also be made "yahoo-free".

If you chose solution "B", then you may find it necessary to manually load in the local versions of any other search engines which you find necessary, e.g. amazon or whatever.

Since someone at Mozilla had obviously adjusted FF V 38.0.1 to circumvent the "Google Default" search engine, I am however concerned that something similar will happen WRT the "Default Search Engine 3.3" App. And so before updating to any future versions beyond FF V 38.0.1, I would suggest keeping a back-up installer for V 38.0.1.

Hi - here is what happened. There are two different ways around the yahoo scurrage: A. Over the past 2 or 3 days, the download version of the North American version FF V 38.0.1 has been modified to include an App, titled "Default Search Engine 3.3". So, click on "Tools", then "Add-ons". Then adjust this Add-on to (e.g.) Google. I have re-started the browser, and the search engine choice seems to hold. B. Mozilla/Firefox has signed some sort of deal with yahoo to promote yahoo search engine. This only applies to the North American edition of FF. For example, the German one does not have this gimmick. It stands to reason the the UK English version can also be made "yahoo-free". If you chose solution "B", then you may find it necessary to manually load in the local versions of any other search engines which you find necessary, e.g. amazon or whatever. Since someone at Mozilla had obviously adjusted FF V 38.0.1 to circumvent the "Google Default" search engine, I am however concerned that something similar will happen WRT the "Default Search Engine 3.3" App. And so before updating to any future versions beyond FF V 38.0.1, I would suggest keeping a back-up installer for V 38.0.1.
FredMcD
  • Top 10 Contributor
4184 solutions 58423 answers

I beg to differ. While Default Search Engine {web link} is listed in Mozilla's Add-ons web site, it is not downloaded with Firefox. I am in Connecticut, and my add-ons do not include that one.

You may have installed it but forgot.

I beg to differ. While [https://addons.mozilla.org/en-US/firefox/addon/default-search/ Default Search Engine] {web link} is listed in Mozilla's Add-ons web site, it is not downloaded with Firefox. I am in Connecticut, and my add-ons do not include that one. You may have installed it but forgot.

Question owner

You are possibly correct. Are you running V 38.0.1? Main thing is that this App seems to be fulfilling its intended function - at least for now.

You are possibly correct. Are you running V 38.0.1? Main thing is that this App seems to be fulfilling its intended function - at least for now.