X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Firefox keeps defaulting to Yahoo! as my search engine, no matter how many times I change it to Google

Posted

I even tried disabling every search engine but Google. I am using Firefox 38.0.1 on a Mac with Yosemite.

I even tried disabling every search engine but Google. I am using Firefox 38.0.1 on a Mac with Yosemite.

Additional System Details

Installed Plug-ins

  • Provides information about the default web browser
  • Plug-in for Workspace
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0
  • Trovi Search Plugin 1_0_0

Application

  • Firefox 38.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.1/Darwin/en-US/

Extensions

  • Ebay Shopping Assistant by Spigot 2.2 ({A92BC493-FA5B-40a5-AFC8-6672926C9544})
  • Searchme 2.5 (searchme@mybrowserbar.com)
  • Slick Savings 3.7 ({84977DE9-1026-4508-B9A7-9116BDAAB098})
  • WBE Paste 1.3 (wbepaste@starfield) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x1626
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 6
  • numTotalWindows: 6
  • webglRenderer: Intel -- Intel(R) HD Graphics 6000
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8695 solutions 71066 answers

I noticed you have some Spigot extensions, which are notorious redirectors. This may indicate you installed something "free" from the internet which bundled in these annoying add-ons. Welcome to the world of Windows users!!

As the first step, remove or disable the extensions on the Add-ons page. Either:

  • Command+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, remove or disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

That should restore control of your default search engine and stop the "missing page" redirects, but there might be some other settings to clean up. Please update us on your progress.

I noticed you have some Spigot extensions, which are notorious redirectors. This may indicate you installed something "free" from the internet which bundled in these annoying add-ons. Welcome to the world of Windows users!! As the first step, remove or disable the extensions on the Add-ons page. Either: * Command+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then, if in doubt, remove or disable. Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step. That should restore control of your default search engine and stop the "missing page" redirects, but there might be some other settings to clean up. Please update us on your progress.
JonnieBean 0 solutions 7 answers

I also have this problem, my search engine keeps defaulting to Amazon despite the fact that remove Amazon from my list of search engines daily. The only thing that came up when I looked at extensions was a disabled extension for an HP web printer.

Bonnie

I also have this problem, my search engine keeps defaulting to Amazon despite the fact that remove Amazon from my list of search engines daily. The only thing that came up when I looked at extensions was a disabled extension for an HP web printer. Bonnie
JonnieBean 0 solutions 7 answers

I am using an HP lap top, running Windows 7, that was completely rebuilt about a month ago.

I am using an HP lap top, running Windows 7, that was completely rebuilt about a month ago.
jscher2000
  • Top 10 Contributor
8695 solutions 71066 answers

Hi Bonnie, do you mean that when you go into the Search Options, the default search engine setting at the top of that section has been switched to Amazon? Or is the problem that when you use either the address bar or the search bar or both, Firefox uses Amazon instead of the default search engine that you set? The more detail you can provide about that, the better.

If the change occurs when you shut down Firefox and start it up again, please see the following article for various suggestions and things to investigate: How to fix preferences that won't save. Also consider whether you use Advanced SystemCare or any other programs that roll back browser settings changes (sometimes called homepage protection).

Hi Bonnie, do you mean that when you go into the Search Options, the default search engine setting at the top of that section has been switched to Amazon? Or is the problem that when you use either the address bar or the search bar or both, Firefox uses Amazon instead of the default search engine that you set? The more detail you can provide about that, the better. If the change occurs when you shut down Firefox and start it up again, please see the following article for various suggestions and things to investigate: [[How to fix preferences that won't save]]. Also consider whether you use Advanced SystemCare or any other programs that roll back browser settings changes (sometimes called homepage protection).
FredMcD
  • Top 10 Contributor
4246 solutions 59405 answers

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove Yahoo Anything. Now do the same in the computers Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.


After the problem is fixed, Bookmark and use this; Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.

Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac:<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Remove Yahoo '''Anything.''' Now do the same in the computers Programs Folder. '''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the "Applications" folder. '''Linux:''' Check your user manual. ------------------ After the problem is fixed, Bookmark and use this; Download the '''[https://addons.mozilla.org/en-US/firefox/addon/searchreset/ Mozilla Search Reset]''' {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.

Modified by FredMcD

the-edmeister
  • Top 25 Contributor
  • Moderator
5399 solutions 40149 answers

I'm gonna lock this thread which was started for the older Firefox 35 version over 3 months ago.

The current Firefox 40 has a major change to how search engines are handled vs Firefox 35.

JonnieBean said

I also have this problem, my search engine keeps defaulting to Amazon despite the fact that remove Amazon from my list of search engines daily. The only thing that came up when I looked at extensions was a disabled extension for an HP web printer. Bonnie

Sorry for any inconvenience, but please start a new thread here: https://support.mozilla.org/en-US/questions/new

I want to make sure of which version of Firefox your question pertains to - the current Firefox 40 or ??

''I'm gonna lock this thread which was started for the older Firefox 35 version over 3 months ago.'' The current Firefox 40 has a major change to how search engines are handled vs Firefox 35. JonnieBean [[#answer-777359|said]]'' <blockquote> I also have this problem, my search engine keeps defaulting to Amazon despite the fact that remove Amazon from my list of search engines daily. The only thing that came up when I looked at extensions was a disabled extension for an HP web printer. Bonnie </blockquote> Sorry for any inconvenience, but please start a new thread here: https://support.mozilla.org/en-US/questions/new I want to make sure of which version of Firefox your question pertains to - the current Firefox 40 or ??