Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox has started closing itself when opening one particular website

  • 13 replies
  • 1 has this problem
  • 19 views
  • Last reply by jscher2000

more options

This morning I tried to open a website that I use regularly to remotely wake my work PC. It has a password prompt but Firefox knows the password so I don't see that come up. This morning when I try and open the website Firefox simply closes. No crash report is generated. When I re-open I get asked if I want to start in Safe Mode or Refresh Firefox. Neither make any difference, same thing happens.

The address opens fine in Chrome and Explorer.

Whats going on!?

All Replies (13)

more options

Hello,,

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from mozilla.org (or choose the download for your operating system and language from this page) and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (or open the Firefox menu New Fx Menu and click the close button Close 29 ).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING: Do not use a third party uninstaller as part of this process. Doing so could permanently delete your Firefox profile data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be easily recovered unless they have been backed up to an external device! See Back up and restore information in Firefox profiles.

Please report back to say if this helped you!

Thank you.

more options

How are you doing this? A) open the site, then start the other computer? b) sending a "wake up" signal?

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

more options

Thanks for replies guys. Tried your suggestions Fred, didn't work. I still can't open the site. I can't be bothered to reinstall at this point, so I'm going to leave the other option and I'll just use chrome to load the site. Weird issue. Thanks anyway

more options

What is the web address? No Personal Information Please.

more options

You can check for issues caused by plugins and try to set all plugins to "Ask to Activate" on the "Firefox/Tools > Add-ons > Plugins" page.

more options

The absence of the Mozilla Crash Reporter often indicates a device driver problem, e.g., display, audio, etc., or a BEX/DEP security-related issue.

Safe Mode generally works around display driver issues, and deactivates extensions, but plugins remain a potential culprit.

If you decide to revisit the question:

  • Windows might have something in its event logs for these crashes
  • You can set plugins you won't need for 24 hours to "Never Activate" on the Add-ons page to see whether that makes any difference
more options

The web address is www.wakemypc.nottingham.ac.uk

Tried Safe Mode and disabling all plug-ins, still no joy.

The other bit of background that might be relevant, particularly given jscher's comment, is that not so long ago I cloned the OS drive to transfer it to a larger SSD. When I did that I some problems with permissions - for instance Steam wouldnt run on the cloned install unless I set it to run as administrator every time.

The only other thing I can think of is that in the past the wake service installed a driver on my home machine I think, which seemed to not do anything more than open the Remote Desktop application when you clicked the link on the wakemypc website. The service no longer includes that driver, but its possible that something is still lurking in the registry from when I cloned it. I don't know what that driver was called though so can't search for it.

As I said though, Chrome opens the link OK so its annoying but I can live with it!

Modified by battles_atlas

more options

I tried you link, and I got; Server not found
Firefox can't find the server at www.wakemypc.nottingham.ac.uk.

I did a web search and found this; http://www.bing.com/search?q=wakemypc

Please check your link information. Try to open the sites main page.

more options

You cannot get very far without a login: https://wakemypc.nottingham.ac.uk/user/WakeSearch.aspx

more options

Yes, that works. No crashes or anything.

more options

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.


The site uses:

  • Connection Encrypted (TLS_RSA_WITH_AES_128_CBC_SHA, 128 bit keys, TLS 1.0)
more options

No joy again, told it to forget website, still auto-closes

more options

I think the problem is somehow related to the extra software it requires in order to implement remote access. Maybe it has become corrupted or changes in Firefox have created a compatibility problem. Considering that we can't actually test the configuration you have, you may need to check with the University's IS for insight.

http://www.nottingham.ac.uk/is/computer/wakemypc.aspx