Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After upgrading to 38.01, unable to scroll certain web pages.

  • 5 replies
  • 18 have this problem
  • 1 view
  • Last reply by jscher2000

more options

I am running Windows Vista. This just started occurring after the upgrade. Not all pages impede scrolling. Help! I am technically unsophisticated.

Thanks

Chosen solution

Are you getting a pop-up style or dialog style window with no menu or toolbar either? In that case:

Firefox 38 has a glitch with this combination of circumstances:

(1) You are viewing a page in a private browsing window (2) Tabbed browsing is turned off (3) You click a link coded with target="_blank", which launches the link in a new window

The new window opens without menus, toolbar, scroll bars, etc.

Work on this bug is in process, but I don't know if the fix will be available in the next few weeks. These are the currently known workarounds so you can keep using private browsing windows -- any one of them will work around the bug:

(1) Use tabbed browsing (this is a checkbox under Options > General > "Open new windows in a new tab instead");

(2) Shift+click links to open them in a new window with the standard features; or

(3) Change a bunch of hidden settings as explained below -- this will not require you to make any changes to how you use Firefox, but you might occasionally need to enlarge some small pop-up windows that were sized for a window with no toolbars displayed.


For #3, here are the steps:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste feat and pause while the list is filtered

(C) For every preference that starts with dom.disable_window_open_feature. if it is not "true", double-click it to switch it to true.

You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows.


Is that relevant or do you have a different issue?

Read this answer in context 👍 3

All Replies (5)

more options

Chosen Solution

Are you getting a pop-up style or dialog style window with no menu or toolbar either? In that case:

Firefox 38 has a glitch with this combination of circumstances:

(1) You are viewing a page in a private browsing window (2) Tabbed browsing is turned off (3) You click a link coded with target="_blank", which launches the link in a new window

The new window opens without menus, toolbar, scroll bars, etc.

Work on this bug is in process, but I don't know if the fix will be available in the next few weeks. These are the currently known workarounds so you can keep using private browsing windows -- any one of them will work around the bug:

(1) Use tabbed browsing (this is a checkbox under Options > General > "Open new windows in a new tab instead");

(2) Shift+click links to open them in a new window with the standard features; or

(3) Change a bunch of hidden settings as explained below -- this will not require you to make any changes to how you use Firefox, but you might occasionally need to enlarge some small pop-up windows that were sized for a window with no toolbars displayed.


For #3, here are the steps:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste feat and pause while the list is filtered

(C) For every preference that starts with dom.disable_window_open_feature. if it is not "true", double-click it to switch it to true.

You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows.


Is that relevant or do you have a different issue?

more options

The "Shift-enter" on a link works great. Thanks for the instruction.

I hope that Firefox is going to give us the "option" to open all links in new windows - like all previous versions of Firefox did.

Thanks!

more options

Firefox never had an option to open ALL links in a new window. Were you using the Tab Mix Plus or another extension before that might have offered that option?

more options

Actually, Firefox did.

I do not like using tabs and have never done so while using Firefox until the issue we discussed above started with FF v.38.

Prior to v.38, in Options, I believe there was a box to select to open new links in a new window - or there was a box to uncheck to open new links in a new tab. Either way, all links have opened for me in a new window - and I hope that FF corrects whatever glitch that no longer permits this.

Is there a way to reload v.37 until FF is updated?

Thanks for all your help!

Modified by SteveCad

more options

Hi Steve, there still is an option to divert new windows to tabs, which you can disable. The "General" and "Tabs" panels have been consolidated in Firefox 38 with the switch to the page-based preference editor:

"3-bar" menu button (or Tools menu) > Options > General

Uncheck "Open new windows in a new tab instead"

But most links are not coded to launch a new window and instead load into the same window (tab). That is the part I meant was not built into Firefox: the option to force ALL links, whether targeted to a new window or not, to a new window or tab.