X
Tap here to go to the mobile version of the site.

Support Forum

Firefox extremely slow. Refresh did not resolve the problem.

Posted

Firefox is extremely slow. Doing a refresh did not resolve the issue . Have also restarted my laptop. Seems to be after the 38.0.1 update.

Firefox is extremely slow. Doing a refresh did not resolve the issue . Have also restarted my laptop. Seems to be after the 38.0.1 update.

Additional System Details

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.10
  • Citrix Online App Detector Plugin
  • Google Update
  • DigitalPersona Logins support
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • np-mswmp
  • Shockwave Flash 17.0 r0
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5324 solutions 23508 answers

hello, could you go to the firefox menu ≡ > help ? > troubleshooting information, copy the contents of that page and paste them here into a reply on the forum? this might give us a clue what is going on...

hello, could you go to the firefox ''menu ≡ > help ? > troubleshooting information'', copy the contents of that page and paste them here into a reply on the forum? this might give us a clue what is going on...
ideato 893 solutions 6250 answers

Hello elvynaa, philipp

probably the hardware acceleration is the problem, try disabling graphics hardware acceleration, and see if that is the cause of the issue.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Open Firefox Options tab as follows, click the menu button New Fx Menu and select Options .
  2. In the Firefox Options tab, click Advanced, then select General.
  3. In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  4. Now, restart Firefox and see if the problems persist.

Thank you.

Hello elvynaa, philipp probably the hardware acceleration is the problem, try '''disabling graphics hardware acceleration''', and see if that is the cause of the issue. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: #Open Firefox ''Options'' tab as follows, click the menu button [[Image:New Fx Menu]] and select ''Options'' . #In the Firefox Options tab, click ''Advanced'', then select ''General''. #In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. #Now, restart Firefox and see if the problems persist. Thank you.