X
Tap here to go to the mobile version of the site.

Support Forum

How can I allow the Imtranslation extension to access my clipboard?

Posted

I do a lot of cut / paste in Imtranslator. I am using the free version of Imtranslator 8.11. Being able to use the clipboard with Imtranslator would make my life a lot easier

I do a lot of cut / paste in Imtranslator. I am using the free version of Imtranslator 8.11. Being able to use the clipboard with Imtranslator would make my life a lot easier

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.11
  • Citrix Online App Detector Plugin
  • Google Update
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Shockwave Flash 17.0 r0
  • VLC media player Web Plugin
  • Yahoo Application State Plugin version 1.0.0.7

Application

  • Firefox 38.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.1/WINNT/en-US/

Extensions

  • Blur (Formerly DoNotTrackMe) 4.5.1334 (donottrackplus@abine.com)
  • ClixAddon 0.84 (jid1-wKRSK9TpFpr9Hw@jetpack)
  • DVDVideoSoft YouTube MP3 and Video Download 4.6.0.1126 ({B64D9B05-48E1-4CEB-BF58-E0643994E900})
  • ImTranslator 8.11 ({9AA46F4F-4DC7-4c06-97AF-5035170634FE})
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF})
  • MEGA 2.0.221 (firefox@mega.co.nz)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 5570
  • adapterDescription2:
  • adapterDeviceID: 0x68d9
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 22931787
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17292
  • driverDate: 11-20-2014
  • driverDate2:
  • driverVersion: 14.501.1003.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 3
  • numTotalWindows: 3
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 5570 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4248 solutions 59413 answers

I use Quick Translator {web link} The most lightweight and easiest translator. Translate between more than 50 languages with one click or a hot key. Translate from one word to a whole page.

This can manual or auto copy to the clipboard.

I use '''[https://addons.mozilla.org/en-US/firefox/addon/quick-translator/ Quick Translator]''' {web link} The most lightweight and easiest translator. Translate between more than 50 languages with one click or a hot key. Translate from one word to a whole page. This can manual or auto copy to the clipboard.

Question owner

Very nice extension, but it will not work for me. I actually cut and paste between Skype and ImTranslator. I like it because it gives me 4 different translations and with the back translation feature I can pick the mist accurate one.

When I try to use the clipboard it says "Your browser does not allow access to your computer's clipboard. Instead, please use Ctrl-C for Copy, Ctrl-X for Cut and Ctrl-V for Paste, or use Edit menu above the browser toolbar." which does not work either.

Very nice extension, but it will not work for me. I actually cut and paste between Skype and ImTranslator. I like it because it gives me 4 different translations and with the back translation feature I can pick the mist accurate one. When I try to use the clipboard it says "Your browser does not allow access to your computer's clipboard. Instead, please use Ctrl-C for Copy, Ctrl-X for Cut and Ctrl-V for Paste, or use Edit menu above the browser toolbar." which does not work either.

Modified by MrOlder

jscher2000
  • Top 10 Contributor
8695 solutions 71076 answers

Usually the keyboard shortcuts work fine, or the right-click menu items... Occasionally a site will use a style rule or script that blocks these actions, but usually they figure it out and fix it quickly...

Could you provide a link to the page where these features do not work?

Usually the keyboard shortcuts work fine, or the right-click menu items... Occasionally a site will use a style rule or script that blocks these actions, but usually they figure it out and fix it quickly... Could you provide a link to the page where these features do not work?

Question owner

I am lousy at explaining. the best way is to have you try it. Add the ImTranslator extension for Firefox @ http://imtranslator.net/ff-plugin.asp (it is very easy to remove when you are done.) Then try and use the copy, paste, cut icons right above "Original Text". Just open a .txt file and try to copy and paste etc... Thanks

I am lousy at explaining. the best way is to have you try it. Add the ImTranslator extension for Firefox @ http://imtranslator.net/ff-plugin.asp (it is very easy to remove when you are done.) Then try and use the copy, paste, cut icons right above "Original Text". Just open a .txt file and try to copy and paste etc... Thanks
FredMcD
  • Top 10 Contributor
4248 solutions 59413 answers

Don't know if this will help;

RightToClick {web link} Stops javascript annoyances such as forbidden right click, forbidden text selection or cascading dialog boxes.

Don't know if this will help; '''[https://addons.mozilla.org/en-US/firefox/addon/righttoclick/ RightToClick]''' {web link} Stops javascript annoyances such as forbidden right click, forbidden text selection or cascading dialog boxes.
jscher2000
  • Top 10 Contributor
8695 solutions 71076 answers

I clicked the toolbar button and a small window opened to this page: http://translate.imtranslator.net/1/?v=8.12&op=y&adet=1&a_s=0&ad=0&ab=0&at=0&gon=0&adi=0&dir=ja/en&loc=en&prvd=promt&btl=700&btt=10&text=

I copied some text from Notepad and pasted it into the top box using Ctrl+v. Chose a language, clicked Translate, it worked. Nothing strange.


Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

I clicked the toolbar button and a small window opened to this page: http://translate.imtranslator.net/1/?v=8.12&op=y&adet=1&a_s=0&ad=0&ab=0&at=0&gon=0&adi=0&dir=ja/en&loc=en&prvd=promt&btl=700&btt=10&text= I copied some text from Notepad and pasted it into the top box using Ctrl+v. Chose a language, clicked Translate, it worked. Nothing strange. ---- Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any difference?