X
Tap here to go to the mobile version of the site.

Support Forum

Whenever I try to do anything (scroll, click on a link) a message come up at the top saying Mozilla Firefox (Not Responding).

Posted

Other people had this question but there were not any answers. When it says Mozilla Firefox (Not Responding), which is whenever I try to do anything, it eventually goes away. I uninstalled Firefox and then installed it again thinking that would help, but it's still doing it. I use my computer for work and really don't have time for this to happen whenever I click a link. Please help!!

Other people had this question but there were not any answers. When it says Mozilla Firefox (Not Responding), which is whenever I try to do anything, it eventually goes away. I uninstalled Firefox and then installed it again thinking that would help, but it's still doing it. I use my computer for work and really don't have time for this to happen whenever I click a link. Please help!!

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.5.5"
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • McAfee MSS+ NPAPI Plugin
  • Picasa plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 17.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.7.148
  • 5.1.30514.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:37.0) Gecko/20100101 Firefox/37.0

More Information

Scribe 732 solutions 3483 answers

Hi, this can happen if Firefox doesn't have enough CPU or RAM memory, which may be because something else is using a lot of resources on your PC. Try opening the Task Manager, Ctrl + Shift + Esc > Performance tab to have a look. Also in the applications tab, see if anything other than Firefox is running, if so, and you aren't using it, select it and End Task.

If nothing is obvious there, Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Hi, this can happen if Firefox doesn't have enough CPU or RAM memory, which may be because something else is using a lot of resources on your PC. Try opening the Task Manager, Ctrl + Shift + Esc > Performance tab to have a look. Also in the applications tab, see if anything other than Firefox is running, if so, and you aren't using it, select it and End Task. If nothing is obvious there, '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.
cor-el
  • Top 10 Contributor
  • Moderator
17566 solutions 158879 answers

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration
guigs 1072 solutions 11697 answers

Helpful Reply

If you try Firefox Safe Mode, it will disable hardware acceleration and add ons temporarily and you can see if these are contributing to the issue. If it was indeed hardware acceleration see the update below.

Just as an update, after investigation of general hardware acceleration issues there is an update going out today that should resolve this. The new version will be 38.0.5RC. Thank you for your patience, please do report back if there are any further issues.

If you try Firefox Safe Mode, it will disable hardware acceleration and add ons temporarily and you can see if these are contributing to the issue. If it was indeed hardware acceleration see the update below. Just as an update, after investigation of general hardware acceleration issues there is an update going out today that should resolve this. The new version will be 38.0.5RC. Thank you for your patience, please do report back if there are any further issues.