X
Tap here to go to the mobile version of the site.

Support Forum

Mozilla nagging to install 37.0.2 - does this fix slow start-up?

Posted

Hi, Anyone know if 37.0.2 fixes the slow start problem? Firefox keeps nagging me to update but as a rule I resist updates due to problems with my add-ons. Many times I have had to go to the old version site and mess around because Mozilla refuse to provide a roll-back when things often go wrong after the update. I re-installed Ver 37 a while ago and I'm not looking to change anything other than the slow start-up problem that people are complaining about currently. If this problem is fixed then I will risk loosing some of my add-ons. It's so bad I used Internet Explorer recently because Firefox refused to start... YES you read correctly... Internet Explorer! I soon shut it down when I had got the info I needed and then closed the five instances of Firefox that opened while I was using Explorer. If anyone can confirm the latest update fixes this problem I would be most grateful for the info Regards to all

Hi, Anyone know if 37.0.2 fixes the slow start problem? Firefox keeps nagging me to update but as a rule I resist updates due to problems with my add-ons. Many times I have had to go to the old version site and mess around because Mozilla refuse to provide a roll-back when things often go wrong after the update. I re-installed Ver 37 a while ago and I'm not looking to change anything other than the slow start-up problem that people are complaining about currently. If this problem is fixed then I will risk loosing some of my add-ons. It's so bad I used Internet Explorer recently because Firefox refused to start... YES you read correctly... Internet Explorer! I soon shut it down when I had got the info I needed and then closed the five instances of Firefox that opened while I was using Explorer. If anyone can confirm the latest update fixes this problem I would be most grateful for the info Regards to all

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Content Blocker Extension
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Online Banking Extension
  • Shockwave Flash 17.0 r0
  • VLC media player Web Plugin 2.1.3
  • Virtual Keyboard

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:37.0) Gecko/20100101 Firefox/37.0

More Information

user633449 1539 solutions 10745 answers

Helpful Reply

You will not lose any add-ons if you update to 37.0.2, and yes there are several performance, stability and security fixes in the update so you should do it.

You will not lose any add-ons if you update to 37.0.2, and yes there are several performance, stability and security fixes in the update so you should do it.
cor-el
  • Top 10 Contributor
  • Moderator
17692 solutions 160067 answers

Helpful Reply

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.


You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration ---- *https://www.mozilla.org/en-US/firefox/37.0.2/releasenotes/ *https://www.mozilla.org/security/known-vulnerabilities/firefox.html

Question owner

Tyler Downer said

You will not lose any add-ons if you update to 37.0.2, and yes there are several performance, stability and security fixes in the update so you should do it.

I did the update and retained all the add-ins this time as you said. Thanks for that advice. Unfortunately the slow or unresponsive start, especially from links in other apps still remains. Thanks for your attention, much appreciated.

''Tyler Downer [[#answer-725671|said]]'' <blockquote> You will not lose any add-ons if you update to 37.0.2, and yes there are several performance, stability and security fixes in the update so you should do it. </blockquote> I did the update and retained all the add-ins this time as you said. Thanks for that advice. Unfortunately the slow or unresponsive start, especially from links in other apps still remains. Thanks for your attention, much appreciated.

Question owner

cor-el said

You can try to disable hardware acceleration in Firefox.
  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"
You need to close and restart Firefox after toggling this setting.

Hi co-rel Tried this but it does not appear to be the problem. It is the slow unresponsive start-up that makes me click a few times without Firefox launching then moments later I get multiple browsers opening. Thanks for your help, much appreciated

''cor-el [[#answer-725883|said]]'' <blockquote> You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration ---- *https://www.mozilla.org/en-US/firefox/37.0.2/releasenotes/ *https://www.mozilla.org/security/known-vulnerabilities/firefox.html </blockquote> Hi co-rel Tried this but it does not appear to be the problem. It is the slow unresponsive start-up that makes me click a few times without Firefox launching then moments later I get multiple browsers opening. Thanks for your help, much appreciated
user293 39 solutions 279 answers

If you start firefox in safe mode, does it start faster?

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35
If you start firefox in safe mode, does it start faster? '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]]
cor-el
  • Top 10 Contributor
  • Moderator
17692 solutions 160067 answers

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

Question owner

user293 said

If you start firefox in safe mode, does it start faster? If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:
  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
If Firefox is not running, you can start Firefox in Safe Mode as follows:
  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
When the Firefox Safe Mode window appears, select "Start in Safe Mode".
SafeMode-Fx35

Hi user293, Yes, it's like the old Firefox, it comes up immediately. I guess this most likely means it's add-ins that are delaying the start? Thanks for your help.

''user293 [[#answer-726388|said]]'' <blockquote> If you start firefox in safe mode, does it start faster? '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] </blockquote> Hi user293, Yes, it's like the old Firefox, it comes up immediately. I guess this most likely means it's add-ins that are delaying the start? Thanks for your help.

Question owner

cor-el said

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test.

Hi cor-el, I will have to borrow a keyboard to do this because I have a wireless mouse and keyboard that does not allow me to use F8 until the OS is already running. Just discovered that Firefox starts normally in Safe Mode so I wonder if it's some add-in that's causing the delay. Thanks for your assistance, much appreciated Regards

''cor-el [[#answer-726402|said]]'' <blockquote> Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ </blockquote> Hi cor-el, I will have to borrow a keyboard to do this because I have a wireless mouse and keyboard that does not allow me to use F8 until the OS is already running. Just discovered that Firefox starts normally in Safe Mode so I wonder if it's some add-in that's causing the delay. Thanks for your assistance, much appreciated Regards

Question owner

Hi Folks, Just trying to stop add-ins but I do not know how this is done. If I set them to "Never Activate" or "Ask To Activate" they just switch back on again. I hava a load of add-ins that I did not realise had been loaded. I would also ask if it's possible to stop things being loaded without my knowledge? Regards

Hi Folks, Just trying to stop add-ins but I do not know how this is done. If I set them to "Never Activate" or "Ask To Activate" they just switch back on again. I hava a load of add-ins that I did not realise had been loaded. I would also ask if it's possible to stop things being loaded without my knowledge? Regards
user293 39 solutions 279 answers

To find out which add-on is causing the problem:

  • go to "about:addons" in the address bar.
  • choose the "extensions" tab.
  • choose an extension, and click "disable".
  • start firefox again. Is it still slow?
  • repeat until you find the addon that is causing the problem.
To find out which add-on is causing the problem: * go to "about:addons" in the address bar. * choose the "extensions" tab. * choose an extension, and click "disable". * start firefox again. Is it still slow? * repeat until you find the addon that is causing the problem.

Question owner

user293 said

To find out which add-on is causing the problem:
  • go to "about:addons" in the address bar.
  • choose the "extensions" tab.
  • choose an extension, and click "disable".
  • start firefox again. Is it still slow?
  • repeat until you find the addon that is causing the problem.

Did that immediately, although Ionly have three add-ons, made no difference. It's the plugins that I have loads of, and most I did not load and would not wish to load anyway. I cannot deactivate these to do test, they just re-activate immediately. Regards

''user293 [[#answer-726614|said]]'' <blockquote> To find out which add-on is causing the problem: * go to "about:addons" in the address bar. * choose the "extensions" tab. * choose an extension, and click "disable". * start firefox again. Is it still slow? * repeat until you find the addon that is causing the problem. </blockquote> Did that immediately, although Ionly have three add-ons, made no difference. It's the plugins that I have loads of, and most I did not load and would not wish to load anyway. I cannot deactivate these to do test, they just re-activate immediately. Regards
cor-el
  • Top 10 Contributor
  • Moderator
17692 solutions 160067 answers

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration