X
Tap here to go to the mobile version of the site.

Support Forum

v37.0.2 how to remove automatic "New Tab" appearing?

Posted

hello

since upgrading to v37.0.2, the new tab with blank (nothing on it) is appearing.

i would like to stop the "new tab" being opened/apearing when i start fx, and it seems to randomly appear (not sure what triggers it). I would only like to have newTab feature, when i click the + mark.

Is this possible?

thankyou

hello since upgrading to v37.0.2, the new tab with blank (nothing on it) is appearing. i would like to stop the "new tab" being opened/apearing when i start fx, and it seems to randomly appear (not sure what triggers it). I would only like to have newTab feature, when i click the + mark. Is this possible? thankyou
Attached screenshots

Modified by NeedHelp

Chosen solution

cor-el, I worked this one out.

an old tab addon that I had disabled (tab util) had the feature to close the blank tab automatically. So to me it appeared no blank tab was being shown.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Provides information about the default web browser
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 17.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:37.0) Gecko/20100101 Firefox/37.0

More Information

Scribe 725 solutions 3456 answers

Hi, this should help you set the start and home page - How to set the home page

Also, type about:config into the address bar, press Enter, accept the warning, scroll down to browser.newtab.url and make sure 'Value' is set to about:newtab (right click to change it if necessary, taking care not to alter anything else) - that determines what you see when you click on '+.'

You may also want to turn on or off etc., the new tab page: more info here - Customize the New Tab page.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

Hi, this should help you set the start and home page - [[How to set the home page]] Also, type '''about:config''' into the address bar, press Enter, accept the warning, scroll down to '''browser.newtab.url''' and make sure 'Value' is set to '''about:newtab''' (right click to change it if necessary, taking care not to alter anything else) - that determines what you see when you click on '+.' You may also want to turn on or off etc., the new tab page: more info here - [[New Tab Page - show, hide and customize top sites]]. If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

Question owner

thankyou Scribe_uk for taking the time to reply. Sadly i had already checked that config value + read the wiki.

it is something else going on here.

key is: since upgrading to v37.0.2, the new tab with blank (nothing on it) is appearing. Like nothing. Blank.

This blank tab (but labelled new tab) is shown just before + please see screenshot 1


But when I click + The correct newtab is appearing (e.g. with 6 webpage "rectangle icons" that i have pinned) please see screenshot 2

hope i am making more sense now.

thankyou Scribe_uk for taking the time to reply. Sadly i had already checked that config value + read the wiki. it is something else going on here. key is: since upgrading to v37.0.2, the new tab with blank (nothing on it) is appearing. Like nothing. Blank. This blank tab (but labelled new tab) is shown just before + please see screenshot 1 But when I click + The correct newtab is appearing (e.g. with 6 webpage "rectangle icons" that i have pinned) please see screenshot 2 hope i am making more sense now.

Modified by NeedHelp

cor-el
  • Top 10 Contributor
  • Moderator
17413 solutions 157283 answers

If you open a new window then this window opens with the home page(s). If you start Firefox then you get the page(s) as specified in the startup setting.

You can set the startup (home) page to about:newtab if you want to start with this page.

  • Tools > Options > General > Startup: Home page

Firefox supports multiple home pages separated by '|' (pipe) symbols.

You can also start Firefox with the about:newtab page by creating a copy of the current Firefox desktop shortcut and add a space and -url about:newtab to the target field.

If you open a new window then this window opens with the home page(s). If you start Firefox then you get the page(s) as specified in the startup setting. You can set the startup (home) page to about:newtab if you want to start with this page. *Tools > Options > General > Startup: Home page Firefox supports multiple home pages separated by '|' (pipe) symbols. *https://support.mozilla.org/kb/How+to+set+the+home+page You can also start Firefox with the about:newtab page by creating a copy of the current Firefox desktop shortcut and add a space and <b>-url about:newtab</b> to the target field. *https://developer.mozilla.org/Command_Line_Options

Question owner

Cor-el, thankyou most helpful How do I have Fx start, with creating NO new tab, labelled new tab with blank page?

My current setting under Preferences/General When Fx Starts

show my windows and tabs from last time

Home page about:blank


I have all the desired pinned tabs that open on start.

Cor-el, thankyou most helpful How do I have Fx start, with creating NO new tab, labelled new tab with blank page? My current setting under Preferences/General When Fx Starts show my windows and tabs from last time Home page about:blank I have all the desired pinned tabs that open on start.

Modified by NeedHelp

Question owner

In trying to fix this problem, I have now managed to create another problem.

Before i started playing and testing, every time I would click on a ink in my "pinned tabs) pinned as apps, the link would automatically open in a new unpinned tab. I would not need to right click to force "open in a new tab".

Now it has stopped doing this. So when I click on the links that use to behave as above, they now update the "pinned tab". Not what I want.

What do I do to fix this? As I cannot remember what ive changed and what i have not as I was trying so many things.

In trying to fix this problem, I have now managed to create another problem. Before i started playing and testing, every time I would click on a ink in my "pinned tabs) pinned as apps, the link would automatically open in a new unpinned tab. I would not need to right click to force "open in a new tab". Now it has stopped doing this. So when I click on the links that use to behave as above, they now update the "pinned tab". Not what I want. What do I do to fix this? As I cannot remember what ive changed and what i have not as I was trying so many things.
cor-el
  • Top 10 Contributor
  • Moderator
17413 solutions 157283 answers

Firefox will open one normal tab when started and all normal tabs were closed, but should select a pinned tab if you close Firefox with a pinned tab selected.

Firefox will open one normal tab when started and all normal tabs were closed, but should select a pinned tab if you close Firefox with a pinned tab selected.

Question owner

hello cor-el, sadly it isnt. Again on login today, a new tab (but blank). it does make sense, although it is not what i desire. it makes sense as the preference setting clearly says about:blank

So now this simple task has turned out to be more frustrating as its been a few days now and still not resolved.

So is it easier, if we remove all "new tab" features and I just wont use the new feature, newTAB (one with the 6 pinned icons)? e.g. > new tab on login is determined by your preference setting >thru using FX new tab (but with the 6 icons pinned) do appear.. not sure why, but they do

Please help me to remove it all, I dont want to see this new tab again. I dont need this new tab at all really. I use URL or Search bar to start from.

I had it like this before v37.0.2 and its gone all wrong now.

hello cor-el, sadly it isnt. Again on login today, a new tab (but blank). it does make sense, although it is not what i desire. it makes sense as the preference setting clearly says about:blank So now this simple task has turned out to be more frustrating as its been a few days now and still not resolved. So is it easier, if we remove all "new tab" features and I just wont use the new feature, newTAB (one with the 6 pinned icons)? e.g. > new tab on login is determined by your preference setting >thru using FX new tab (but with the 6 icons pinned) do appear.. not sure why, but they do Please help me to remove it all, I dont want to see this new tab again. I dont need this new tab at all really. I use URL or Search bar to start from. I had it like this before v37.0.2 and its gone all wrong now.
cor-el
  • Top 10 Contributor
  • Moderator
17413 solutions 157283 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

Hello Cor-el. i think somehow the point is being missed. Sorry if I am being unclear. We know how the blank new tab is being created on start. It is being created due to the setting about:blank in preferences.

It is just not what I want. I would like Fx NOT to create new blank tab but only load with my pinned tab.

it did this before v37.0.2 with exactly the same extensions installed. Only thing different is now we have turned OFF hardware accelearation due to another open issue (FredMcD advised to turn it off)

It is also creating a new tab in another spot. But I cannot work out yet what is triggered yet.

thankyou

Hello Cor-el. i think somehow the point is being missed. Sorry if I am being unclear. We know how the blank new tab is being created on start. It is being created due to the setting about:blank in preferences. It is just not what I want. I would like Fx NOT to create new blank tab but only load with my pinned tab. it did this before v37.0.2 with exactly the same extensions installed. Only thing different is now we have turned OFF hardware accelearation due to another open issue (FredMcD advised to turn it off) It is also creating a new tab in another spot. But I cannot work out yet what is triggered yet. thankyou

Modified by NeedHelp

cor-el
  • Top 10 Contributor
  • Moderator
17413 solutions 157283 answers

Helpful Reply

That is not possible as I wrote above. You can't start Firefox with only pinned tabs showing. There will always be at least one normal (not pinned) tab.

That is not possible as I wrote above. You can't start Firefox with only pinned tabs showing. There will always be at least one normal (not pinned) tab.

Question owner

okay, Thankyou Cor-el for trying to help me. I must be loosing it. I really appreciate all your lovely help.

okay, Thankyou Cor-el for trying to help me. I must be loosing it. I really appreciate all your lovely help.
cor-el
  • Top 10 Contributor
  • Moderator
17413 solutions 157283 answers

You're welcome.

You can have only pinned tabs while Firefox is running by closing all normal tabs, but Firefox insists on opening at least one normal tab when you start Firefox and had only pinned tabs the previous time you closed Firefox.

You're welcome. You can have only pinned tabs while Firefox is running by closing all normal tabs, but Firefox insists on opening at least one normal tab when you start Firefox and had only pinned tabs the previous time you closed Firefox.

Chosen Solution

cor-el, I worked this one out.

an old tab addon that I had disabled (tab util) had the feature to close the blank tab automatically. So to me it appeared no blank tab was being shown.

cor-el, I worked this one out. an old tab addon that I had disabled ('''tab util''') had the feature to close the blank tab automatically. So to me it appeared no blank tab was being shown.

Modified by NeedHelp