X
Tap here to go to the mobile version of the site.

Support Forum

Firefox Blocking Cookies

Posted

When visiting www.cheathappens.com I am forced to log in every time, which it has never been that way. Then upon log in, every time l click a link on the site I am logged out. The admins of this site say that something is blocking their cookies. I am set up to receive cookies, and have tried totally removing AdBlock Plus, and still no luck. Some users told me they use AdBlock Plus and are not having this issue, as was the case for myself up until about the last couple of months. Any ideas?

When visiting www.cheathappens.com I am forced to log in every time, which it has never been that way. Then upon log in, every time l click a link on the site I am logged out. The admins of this site say that something is blocking their cookies. I am set up to receive cookies, and have tried totally removing AdBlock Plus, and still no luck. Some users told me they use AdBlock Plus and are not having this issue, as was the case for myself up until about the last couple of months. Any ideas?

Chosen solution

Issue resolved. It was my antivirus, ESET NOD32. I had to add Cheathappens to the allowed URL addresses under advanced settings. Never had this issue with ESET before, so I never thought of looking there. Thanks to everyone for the help.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Battlelog Game Launcher (2.6.2)
  • Foxit Reader Plug-In For Firefox and Netscape
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.40.2 for Mozilla browsers
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17523 solutions 158446 answers

This issue can be caused by corrupted cookies or cookies that are blocked.

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

If clearing cookies didn't help then it is possible that the cookies.sqlite file that stores the cookies got corrupted.

  • Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.
This issue can be caused by corrupted cookies or cookies that are blocked. *check the permissions on the about:permissions page and in "Tools > Page Info > Permissions" *https://support.mozilla.org/kb/fix-login-issues-on-websites-require-passwords Clear the cache and remove cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" If clearing cookies didn't help then it is possible that the cookies.sqlite file that stores the cookies got corrupted. *Rename (or delete) <b>cookies.sqlite</b> (cookies.sqlite.old) and delete other present cookies files like <b>cookies.sqlite-journal</b> in the Firefox profile folder in case the file cookies.sqlite got corrupted. *http://kb.mozillazine.org/Cookies *https://support.mozilla.org/kb/Deleting+cookies

Question owner

Still not working. Any other ideas?

Still not working. Any other ideas?
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

Some websites are sensitive to your network connection details and will require your password if they change. Sometimes this can be caused by the "Autodetect" proxy setting.

Could you check here:

"3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button

The default of "Use system proxy settings" should piggyback on your IE/Windows "LAN" settings, but you also could try "No proxy" to see whether that makes any difference.

Some websites are sensitive to your network connection details and will require your password if they change. Sometimes this can be caused by the "Autodetect" proxy setting. Could you check here: "3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button The default of "Use system proxy settings" should piggyback on your IE/Windows "LAN" settings, but you also could try "No proxy" to see whether that makes any difference.
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

Also, to rule out other extensions as a possible culprit, could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Also, to rule out other extensions as a possible culprit, could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?

Question owner

Starting in safe mode seemed to have temporarily resolved the issue, but I am unsure which extensions could be the problem. I have the following extensions:

  • Internet Download Manager
  • Adblock Plus 2.6.9
  • Adblock Plus Pop-up Addon 0.9.2
  • Classic Theme Restorer 1.3.1.1

None of these have caused any issue before.

Starting in safe mode seemed to have temporarily resolved the issue, but I am unsure which extensions could be the problem. I have the following extensions: * Internet Download Manager *Adblock Plus 2.6.9 *Adblock Plus Pop-up Addon 0.9.2 *Classic Theme Restorer 1.3.1.1 None of these have caused any issue before.
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

The only one that seems remotely likely to be blocking website content is Adblock Plus, but I have not heard that it affects cookies. I think it has a feature to block it from affecting one particular website. If you try that, does it make any difference?

The only one that seems remotely likely to be blocking website content is Adblock Plus, but I have not heard that it affects cookies. I think it has a feature to block it from affecting one particular website. If you try that, does it make any difference?

Question owner

I have tried completely removing Adblock Plus, and it does not resolve the issue.

I have tried completely removing Adblock Plus, and it does not resolve the issue.
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

If you disable the other 3 extensions in "normal" mode (from the Add-ons page) does that resolve the issue? Safe Mode changes some other settings, so let's try that to see whether it actually is caused by extensions.

You can open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then on the right side you can disable all of them.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any effect on the site's ability to keep you logged in?

If you disable the other 3 extensions in "normal" mode (from the Add-ons page) does that resolve the issue? Safe Mode changes some other settings, so let's try that to see whether it actually is caused by extensions. You can open the Add-ons page using either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then on the right side you can disable all of them. Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step. Any effect on the site's ability to keep you logged in?

Question owner

Disabling the extensions does not help, so obviously it is something else. I tried it in safe mode for about 5-10 minutes and everything was fine. So far I have only noticed this issue on this one website.

Disabling the extensions does not help, so obviously it is something else. I tried it in safe mode for about 5-10 minutes and everything was fine. So far I have only noticed this issue on this one website.
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

It's really hard to think of how other things disabled in Firefox's Safe Mode could be affecting cookies. Those include:

  • Hardware acceleration of graphics
  • JavaScript compilers (to improve performance running large scripts)
  • Certain appearance customizations (optional userChrome.css, userContent.css files)

It's fairly easy to disable hardware acceleration to test that:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This takes effect the next time you exit Firefox and start it up again. Any difference??


Disabling the compilers requires a visit to the about:config preferences editor. I haven't looked this up for a while, so hopefully another volunteer knows them off the top of her/his head.

It's really hard to think of how other things disabled in Firefox's Safe Mode could be affecting cookies. Those include: * Hardware acceleration of graphics * JavaScript compilers (to improve performance running large scripts) * Certain appearance customizations (optional userChrome.css, userContent.css files) ---- It's fairly easy to disable hardware acceleration to test that: "3-bar" menu button (or Tools menu) > Options > Advanced On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available" This takes effect the next time you exit Firefox and start it up again. Any difference?? ---- Disabling the compilers requires a visit to the about:config preferences editor. I haven't looked this up for a while, so hopefully another volunteer knows them off the top of her/his head.
cor-el
  • Top 10 Contributor
  • Moderator
17523 solutions 158446 answers

You can also check that you do not run Firefox in permanent Private Browsing mode (Never remember history).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

You can also check that you do not run Firefox in permanent Private Browsing mode (Never remember history). *https://support.mozilla.org/kb/Private+Browsing *Tools > Options > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use Private Browsing mode" ----- You can check for problems with preferences. Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences You can use this button to go to the currently used Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) ----- You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page. Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of the involved files. It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Question owner

No luck. I am now completely clueless as to what is causing this. This is the only site effected that I am aware of.

No luck. I am now completely clueless as to what is causing this. This is the only site effected that I am aware of.
cor-el
  • Top 10 Contributor
  • Moderator
17523 solutions 158446 answers

You can check if DOM Storage is enabled.

You can check if DOM Storage is enabled. *http://kb.mozillazine.org/dom.storage.enabled

Question owner

I have tried everything as well as a clean install. Does anyone else have any ideas? I have researched this until I am blue in the face. Any help is appreciated.

I have tried everything as well as a clean install. Does anyone else have any ideas? I have researched this until I am blue in the face. Any help is appreciated.
cor-el
  • Top 10 Contributor
  • Moderator
17523 solutions 158446 answers

Helpful Reply

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

Chosen Solution

Issue resolved. It was my antivirus, ESET NOD32. I had to add Cheathappens to the allowed URL addresses under advanced settings. Never had this issue with ESET before, so I never thought of looking there. Thanks to everyone for the help.

Issue resolved. It was my antivirus, ESET NOD32. I had to add Cheathappens to the allowed URL addresses under advanced settings. Never had this issue with ESET before, so I never thought of looking there. Thanks to everyone for the help.
cor-el
  • Top 10 Contributor
  • Moderator
17523 solutions 158446 answers

You're welcome.

Thanks for reporting back on how you solved it.

You're welcome. Thanks for reporting back on how you solved it.