X
Tap here to go to the mobile version of the site.

Support Forum

Firefox slows to a crawl after awhile (WAS: Will a Firefox refresh preserve the ORDER of bookmarks toolbar items?)

Posted

EDIT: Based on a reply that seems to have solved the FF slowdown that was behind my original, more specific question, I have changed the question accordingly.

I am having a problem with Firefox slowing to a crawl, and then sometimes locking up completely, after I use it for awhile. I have tried all the various fixes suggested, and nothing short of a restart helps. So I'm finally ready to consider doing a refresh to see if that helps. I am resigned to the fact that after a refresh I would have to reinstall and reconfigure all my add-ons, plus re-do many other preferences -- a major project.

I read that one of the things preserved in a refresh is Bookmarks. But would that also include the ORDER of the items in the Bookmarks Toolbar? Or do I need to make a visual record before the refresh and then manually resort the Toolbar's bookmarks afterward?

EDIT: Based on a reply that seems to have solved the FF slowdown that was behind my original, more specific question, I have changed the question accordingly. I am having a problem with Firefox slowing to a crawl, and then sometimes locking up completely, after I use it for awhile. I have tried all the various fixes suggested, and nothing short of a restart helps. So I'm finally ready to consider doing a refresh to see if that helps. I am resigned to the fact that after a refresh I would have to reinstall and reconfigure all my add-ons, plus re-do many other preferences -- a major project. I read that one of the things preserved in a refresh is Bookmarks. But would that also include the ORDER of the items in the Bookmarks Toolbar? Or do I need to make a visual record before the refresh and then manually resort the Toolbar's bookmarks afterward?

Modified by Rick216

FredMcD
  • Top 10 Contributor
4314 solutions 60573 answers

These add-ons can be a great help by backing up and restoring Firefox

FEBE (Firefox Environment Backup Extension) {web link} FEBE allows you to quickly and easily backup your Firefox extensions, history, passwords, and more. In fact, it goes beyond just backing up -- It will actually rebuild your saved files individually into installable .xpi files. It will also make backup of files that you choose.

OPIE {web link} Import/Export extension preferences

These add-ons can be a great help by backing up and restoring Firefox '''[https://addons.mozilla.org/en-US/firefox/addon/febe/ FEBE (Firefox Environment Backup Extension)]''' {web link} FEBE allows you to quickly and easily backup your Firefox extensions, history, passwords, and more. In fact, it goes beyond just backing up -- It will actually rebuild your saved files individually into installable .xpi files. It will also make backup of files that you choose. '''[https://addons.mozilla.org/en-US/firefox/addon/opie/ OPIE]''' {web link} Import/Export extension preferences

Modified by FredMcD

FredMcD
  • Top 10 Contributor
4314 solutions 60573 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there?

Question owner

Thanks for the tip on those extensions. Looks like they might prove *very* helpful.

When I restart in safe mode I don't encounter the slowdown. Based on that I've experimented on and off for several months with incrementally re-enabling my 20-or-so addons, but thus far haven't identified any clear "culprits." I do know that things slow down *faster* with the Adobe Flash plugin set to "always activate," but it eventually starts slowing down even with Flash off.

Funny thing is, when I had the same "symptoms" about five months ago, simply updating to the latest version of FF remedied it. Unfortunately that hasn't helped lately,

BTW, I have another *less* powerful pc (also Windows 7) with a very similar (though not 100% identical) FF setup that has no slowdown issues. One thing I have considered trying is backing up my profile on this pc, creating a new profile, and then copying everything over from the other pc's profile. I did something like that successfully awhile back.

Thanks for the tip on those extensions. Looks like they might prove *very* helpful. When I restart in safe mode I don't encounter the slowdown. Based on that I've experimented on and off for several months with incrementally re-enabling my 20-or-so addons, but thus far haven't identified any clear "culprits." I do know that things slow down *faster* with the Adobe Flash plugin set to "always activate," but it eventually starts slowing down even with Flash off. Funny thing is, when I had the same "symptoms" about five months ago, simply updating to the latest version of FF remedied it. Unfortunately that hasn't helped lately, BTW, I have another *less* powerful pc (also Windows 7) with a very similar (though not 100% identical) FF setup that has no slowdown issues. One thing I have considered trying is backing up my profile on this pc, creating a new profile, and then copying everything over from the other pc's profile. I did something like that successfully awhile back.

Modified by Rick216

cor-el
  • Top 10 Contributor
  • Moderator
17694 solutions 160088 answers

Helpful Reply

You can save a copy of the compressed .jsonlz4 backups in the bookmarkbackups folder to have a backup of the bookmarks as they appear in the Bookmarks Manager (Library).

You can save a copy of the compressed .jsonlz4 backups in the bookmarkbackups folder to have a backup of the bookmarks as they appear in the Bookmarks Manager (Library). *https://support.mozilla.org/kb/restore-bookmarks-from-backup-or-move-them
FredMcD
  • Top 10 Contributor
4314 solutions 60573 answers

Helpful Reply

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:


Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting''' ------------------------------ '''[https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block]''' {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it
FredMcD
  • Top 10 Contributor
4314 solutions 60573 answers

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective

Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac:<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable a few add-ons, then '''Restart Firefox.''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective

Question owner

Fred McD -

Thanks for the additional suggestions. While cor-el answered the specific question I asked, I obviously appreciate the help in trying to solve the underlying issue that led to my question, and will try your suggestions (I had already tried a couple of them).

Fred McD - Thanks for the additional suggestions. While cor-el answered the specific question I asked, I obviously appreciate the help in trying to solve the underlying issue that led to my question, and will try your suggestions (I had already tried a couple of them).
cor-el
  • Top 10 Contributor
  • Moderator
17694 solutions 160088 answers

When you reset Firefox then a new profile is created and some personal data (bookmarks, history, cookies, passwords, form data) is automatically imported and the current profile folder will be moved to the desktop to an "Old Firefox Data" folder. Installed extensions and other customizations (toolbars, prefs) that you have made are lost and need to be redone.

Another possibly is to use the Profile Manager to create a new profile.

That way you can always switch back to for previous profile.

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

When you reset Firefox then a new profile is created and some personal data (bookmarks, history, cookies, passwords, form data) is automatically imported and the current profile folder will be moved to the desktop to an "Old Firefox Data" folder. Installed extensions and other customizations (toolbars, prefs) that you have made are lost and need to be redone. Another possibly is to use the Profile Manager to create a new profile. *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles That way you can always switch back to for previous profile. If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Question owner

FredMcD said

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

While cor-el answered my original, more specific question and provided additional helpful information, the advice above seems to have solved the key underlying issue of FF slowing to a crawl.

Specifically: Sure enough, it appears disabling the Norton Toolbar in extensions has solved the problem. Funny thing is, I could have sworn I tried this before, but maybe not. Making it even stranger is that over five years it apparently never created any problems until four or five months ago; and that I only had limited functionality enabled in it (namely site safety ratings in search results); and that it still isn't creating problems in my other computer (although I haven't been using that computer as much). Probably NOT coincidentally, FF RAM usage now seems to be topping out out about 1.2gb instead of routinely climbing to about 2.2gb over a 2-4 hour period, as it was doing before I deactivated the Norton toolbar.

Thanks.

''FredMcD [[#answer-723410|said]]'' <blockquote> Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' </blockquote> While cor-el answered my original, more specific question and provided additional helpful information, the advice above seems to have solved the key underlying issue of FF slowing to a crawl. Specifically: Sure enough, it appears disabling the Norton Toolbar in extensions has solved the problem. Funny thing is, I could have sworn I tried this before, but maybe not. Making it even stranger is that over five years it apparently never created any problems until four or five months ago; and that I only had limited functionality enabled in it (namely site safety ratings in search results); and that it still isn't creating problems in my other computer (although I haven't been using that computer as much). Probably NOT coincidentally, FF RAM usage now seems to be topping out out about 1.2gb instead of routinely climbing to about 2.2gb over a 2-4 hour period, as it was doing before I deactivated the Norton toolbar. Thanks.

Modified by Rick216

FredMcD
  • Top 10 Contributor
4314 solutions 60573 answers

https://support.mozilla.org/en-US/questions/1048938 Firefox takes two minutes plus to load, apparent clash with Norton Internet Security

Norton showed where to exclude things from Autoprotect Open Norton Administrative Settings. Under Performance Monitoring, find Program Exclusions. To its far right, press the Configure + link.

You will have to add each program one at a time from the Mozilla Firefox and Mozilla Maintenance Service<Windows> folders..

https://support.mozilla.org/en-US/questions/1048938 Firefox takes two minutes plus to load, apparent clash with Norton Internet Security Norton showed where to exclude things from Autoprotect Open '''Norton Administrative Settings.''' Under '''Performance Monitoring, ''' find '''Program Exclusions. ''' To its far right, press the '''Configure +''' link. You will have to add each program one at a time from the '''Mozilla Firefox''' and '''Mozilla Maintenance Service'''<Windows> folders..

Question owner

FredMcD said

https://support.mozilla.org/en-US/questions/1048938 Firefox takes two minutes plus to load, apparent clash with Norton Internet Security Norton showed where to exclude things from Autoprotect Open Norton Administrative Settings. Under Performance Monitoring, find Program Exclusions. To its far right, press the Configure + link. You will have to add each program one at a time from the Mozilla Firefox and Mozilla Maintenance Service<Windows> folders..

Just disabling the extension seems to have completely fixed everything for me, but I'll keep this in mind should additional problems surface. BTW, my Norton interface is different. I have Norton Internet Security (v 21.7.0.11) and in that the exclusions area you refer to is accessed by going to Settings -> Items to Exclude from AutoProtect -> Configure.

The specific problem(s) created by using current Norton Toolbar extension with FF 27.0.1 seem to vary by user. For me it's the slowdowns described, and an apparent memory leak. For people on the thread you refer to it's extremely slow FF startup. For others, on the Norton Forums thread linked to below, it's FF crashing when it is closed:

https://community.norton.com/en/forums/norton-360-toolbar-crashing-firefox-close

''FredMcD [[#answer-723869|said]]'' <blockquote> https://support.mozilla.org/en-US/questions/1048938 Firefox takes two minutes plus to load, apparent clash with Norton Internet Security Norton showed where to exclude things from Autoprotect Open '''Norton Administrative Settings.''' Under '''Performance Monitoring, ''' find '''Program Exclusions. ''' To its far right, press the '''Configure +''' link. You will have to add each program one at a time from the '''Mozilla Firefox''' and '''Mozilla Maintenance Service'''<Windows> folders.. </blockquote> Just disabling the extension seems to have completely fixed everything for me, but I'll keep this in mind should additional problems surface. BTW, my Norton interface is different. I have Norton Internet Security (v 21.7.0.11) and in that the exclusions area you refer to is accessed by going to Settings -> Items to Exclude from AutoProtect -> Configure. The specific problem(s) created by using current Norton Toolbar extension with FF 27.0.1 seem to vary by user. For me it's the slowdowns described, and an apparent memory leak. For people on the thread you refer to it's extremely slow FF startup. For others, on the Norton Forums thread linked to below, it's FF crashing when it is closed: https://community.norton.com/en/forums/norton-360-toolbar-crashing-firefox-close

Modified by Rick216

FredMcD
  • Top 10 Contributor
4314 solutions 60573 answers

If you think you need more help or answers, contact Norton Support thru your Norton program. Good luck.

If you think you need more help or answers, contact Norton Support thru your Norton program. Good luck.