Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disable automatic zooming based on horizontal window size

more options

Firefox has suddenly started a very obnoxious behavior - every single website I visit is now "autozooming" based on the horizontal space available in the browser. For instance, on sites with predetermined horizontal space and then "background" buffer space on the sides, Firefox will automatically zoom the page to fill out those sides. This is completely unwanted behavior and I have no idea what I did to cause it (as far as I can tell, I didn't do anything). How can I stop it?

Firefox has suddenly started a very obnoxious behavior - every single website I visit is now "autozooming" based on the horizontal space available in the browser. For instance, on sites with predetermined horizontal space and then "background" buffer space on the sides, Firefox will automatically zoom the page to fill out those sides. This is completely unwanted behavior and I have no idea what I did to cause it (as far as I can tell, I didn't do anything). How can I stop it?

All Replies (1)

more options

That does not sound like a built-in feature... To quickly ascertain whether an extension could be doing it, could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?