Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

How can i SLOW [not speed] scrolling speed in Windows FF?

  • 18 replies
  • 5 have this problem
  • 153 views
  • Last reply by ameame

more options

How can i SLOW [not speed] scrolling speed in Windows FF?

All Replies (18)

more options

Maybe the "smooth scrolling" is disable in your Firefox. To activate it, go in the Options, Advanced tab, General tab and tick the box "Use smooth scrolling". Otherwise, it's a Windows setting: go in the Control Panel, Mouse, Wheel tab and change the number of lines at a time.

more options

I have a trackball, thus have no wheel to adjust in Windows Control Panel. And i already have "use smooth scrolling" on.

more options
more options

Re the Gecko link- it's long and complicated [[if there's advice in there for general trackball users, it's well-hidden] and i don't have a Gecko mouse. I'm puzzled why you posted this link

more options

The article provides description of what you can do with some of the prefs that deal with scrolling. I'm not sure if I understand what you want to achieve.

Do you want to decrease the scroll amount because currently scrolling is too fast?

more options

Do i want to decrease the scroll amount? Probably, but i don't really know, or care. I care about the result: slower [and adequately smooth] scrolling.

"What i can do with some of the prefs"? Sorry that information is far too theoretical to be actually doable. In my [lengthy and painful] experience, even direct/concrete tutorials rarely work, and this theoretical stuff is entirely useless.

Hope that doesn't sound snarky and/or ungrateful, as do appreciate your helpfulness [it just doesn't help!  :) ]

more options

How do you currently experience scrolling and how you like it to see change?

From what you write it seems that scrolling isn't smoothly.


You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.


Try to increase the value of the general.smoothScroll.mouseWheel.durationMaxMS pref on the about:config page a higher value like 1000 to see if that makes a difference with smooth scrolling enabled.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Modified by cor-el

more options

I simply added the note on smoothness because i didn't want to give that up in the process of gaining slower scrolling. I didn't mean to derail the discussion into this topic. I hope we can return to the original topic.

more options

I'm still not sure what you want to change to what you currently see.

Can you describe that with more details?

Does Firefox scroll too fast when you rotate the trackball?

The delta_multiplier prefs are internally floats of type double and are converted to an integer for storing in a pref by multiplying them with 100 and are acting as percentages of the default scroll amount (i.e. 100 -> 1). Set the mousewheel.default.delta_multiplier_y pref to 33 to change the scroll behavior from 3 lines to 1 if you want to scroll slower or to a value higher that 100 if you want to scroll faster (y prefs are for vertical movement and x prefs for horizontal movement). Note that the delta_multiplier prefs can have negative values to reverse the action (can be useful for zooming with Ctrl hold down).

  • mousewheel.with_control.delta_multiplier_y = -100

Modified by cor-el

more options

I have an old Logitech marble mouse. When i press my spacebar or keyboard arrow key, [all] pages scroll too fast. Same thing when i use a normal mouse. [It's probably normal, i'm just oversensitive is all.]. There's nothing more to say! It's that simple.

more options

Pardon- maybe i should've added, since i don't scroll with my mouse at all, all this delta_modifier stuff is entirely irrelevant.

more options

The mouse and the trackball use the same mouse events to scroll, so you can reduce the the mousewheel.default.delta_multiplier_y pref to a lower value to see how that works for you.

For scrolling with the keyboard you can consider to set this pref to 1 (default is 3).

  • toolkit.scrollbox.verticalScrollDistance
more options

Didn't work. Hey look- i really appreciate your efforts but this is going nowhere. Let's end it here, unless you have some blinding revelation... Thanks again.

more options

I found a fix! I had Yet Another Smooth Scroller extension installed but didn't change its settings. When i went into keyboard options and adjusted step-size [first slider at top] to far left [7], I attained nirvana.  :)

While i'm here i wanted to say something, because i love Firefox... I've watched its market share slide over the years to its present miserable 26%. It's not that Chrome is that good, it's that Firefox is that flaky. Why? Because the geniuses at Mozilla rely on extension writer to provide functionality. And most of those coders can't keep up with continual revisions, so their extensions break, and people start to look over the fence... I hate to say it, but Mozilla is following in Opera's footsteps, sigh.

more options

I'm not very familiar with trackballs, but I'll add a comment regarding the keyboard part.

ameame said

When i press my spacebar or keyboard arrow key, [all] pages scroll too fast.

On my Firefox, the spacebar skips down a screenful at a time, like the PgDn key. When that repeats, it's certainly going to cover a lot of ground, and a lot faster than the down arrow key. But pressing the spacebar a few times can be efficient if you don't hold it down continuously.

The distance covered by the up and down arrow keys can be modified using a different preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste scroll and pause while the list is filtered

(3) Scroll all the way down to toolkit.scrollbox.verticalScrollDistance which usually has a default value of 3

  • If the preference is bolded and user set to a value higher than 3, use right-click > Reset to set it back to 3 and test how that works for you (test on a normal web page, not the about:config page)
  • To reduce the number of lines below 3, double-click to edit and type a smaller number and then you can test that (test on a normal web page and not the about:config page)

Does that help at all?

Note: I assume you are not using "Caret Browsing" which moves the cursor through the text of the document when you press the up and down arrow keys. The results can be somewhat unpredictable depending on the layout of the page. If you want to test that feature, you can turn it on and off by pressing the F7 function key.

more options

I didn't see your reply until after I posted. You might not need that extension now that you know where to find the hidden internal settings...

more options

If you use an extension that deals with scrolling then the extension may override internal settings in Firefox by their own setting. That might explain why modifying the prefs that I mentioned above didn't work for you.

more options

To one and all: like most computer technology the fatal flaw with this issue was its ludicrous complexity. The nerd mindset [Mozilla for one] sees right thru the need for simplicity [it's for wimps is something i've heard], and, to be fair, it's a lot harder to make something simple and usable too. Most humans see a thread like this and run away screaming; it's why computers are to this generation what mothers-in-law were to the last.

At any rate, with Smooth Scroller turned off, and the moderators about:config interventions implemented, my arrow key triggers very slow scrolling but normal spacebar and PageUp scrolling.

Me, i'm tip-toe-ing away while the tip-toe-ing is good. I just hope this thread helps the next poor soul with this issue [too slow or too fast scrolling]