X
Tap here to go to the mobile version of the site.

Support Forum

Firefox slow on new Windows install/Flash player crashes, how to fix?

Posted

On my new windows install I found Firefox to be very slow compared to how it was before the my new Windows install. Opening most webpages takes way longer than it should, i excluded my internet connection being the problem as i always get 100/100 Mbps (speedtest) results.

I already : -reinstalled Flashplayer, wich didnt solve the problem. -Did a Firefox refresh (as in: https://support.mozilla.org/en-US/kb/firefox-health-report-says-your-browser-is-slow ) -Tried setting the ipv6 boolean (network.dns.disableIPv6) in about:config to true. -Disabling plugins (user installed ones) -Clearing flashplayer cache -Reinstall videocard driver

I'm at a loss what could possibly be the problem, hopefully someone else has an idea how to solve this problem.

Thanks in advance

On my new windows install I found Firefox to be very slow compared to how it was before the my new Windows install. Opening most webpages takes way longer than it should, i excluded my internet connection being the problem as i always get 100/100 Mbps (speedtest) results. I already : -reinstalled Flashplayer, wich didnt solve the problem. -Did a Firefox refresh (as in: https://support.mozilla.org/en-US/kb/firefox-health-report-says-your-browser-is-slow ) -Tried setting the ipv6 boolean (network.dns.disableIPv6) in about:config to true. -Disabling plugins (user installed ones) -Clearing flashplayer cache -Reinstall videocard driver I'm at a loss what could possibly be the problem, hopefully someone else has an idea how to solve this problem. Thanks in advance

Additional System Details

Installed Plug-ins

  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 17.0 r0
  • Plugin for Wacom tablets.

Application

  • Firefox 37.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
  • Support URL: https://support.mozilla.org/1/firefox/37.0.2/WINNT/en-US/

Extensions

  • BetterTTV 6.8.3 (firefox@betterttv.net)
  • Greasemonkey 3.1 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Reddit Enhancement Suite 4.5.4.1-signed (jid1-xUfzOsOFlzSOXg@jetpack)
  • uBlock 0.9.1.0 ({2b10c1c8-a11f-4bad-fe9c-1c11e82cac42})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 780
  • adapterDescription2:
  • adapterDeviceID: 0x1004
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 3072
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 2-5-2015
  • driverDate2:
  • driverVersion: 9.18.13.4752
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 780 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: Yes
Mark Schmidt 66 solutions 362 answers

Some problems with Flash can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

Some problems with Flash can be resolved by disabling hardware acceleration in your Flash Player settings. (See [[Flash Plugin - Keep it up to date and troubleshoot problems|this article]] for more information on using the Flash plugin in Firefox). To disable hardware acceleration in Flash Player: #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. Does this solve the problem? Let us know.

Question owner

Already tried that and it sadly didn't help me one bit! It's getting to the point that every page is taking way longer than usual to load. There are no proxy settings, nor vpn. so those are not the issue either

Already tried that and it sadly didn't help me one bit! It's getting to the point that every page is taking way longer than usual to load. There are no proxy settings, nor vpn. so those are not the issue either
jscher2000
  • Top 10 Contributor
8695 solutions 71076 answers

Do you ever see messages that scripts are running slowly with Stop/Continue options?

Another common troubleshooting step for Flash on Windows Vista and newer is to disable the plugin's protected mode feature. That feature has security benefits, but seems to have compatibility issues on some systems. There is a new hidden setting for this:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste flash and pause while the list is filtered

(C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true.

This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.

Before that preference was added, the way to disable protected mode was by creating or editing a settings file. The following pages/posts provide different approaches for that if it turns out to be necessary (if Flash EXE processes continue to show up in the Windows Task Manager, Processes tab, even after changing the Firefox preference):

Flash needs to completely unload from memory (exiting and starting Firefox up again might help) before this takes effect.

Any improvement?

Do you ever see messages that scripts are running slowly with Stop/Continue options? Another common troubleshooting step for Flash on Windows Vista and newer is to disable the plugin's protected mode feature. That feature has security benefits, but seems to have compatibility issues on some systems. There is a new hidden setting for this: (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste '''flash''' and pause while the list is filtered (C) Double-click the '''dom.ipc.plugins.flash.disable-protected-mode''' preference to switch its value from false to true. This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox. Before that preference was added, the way to disable protected mode was by creating or editing a settings file. The following pages/posts provide different approaches for that if it turns out to be necessary (if Flash EXE processes continue to show up in the Windows Task Manager, Processes tab, even after changing the Firefox preference): * Adobe support article under the heading "Last Resort": [http://forums.adobe.com/message/4468493#TemporaryWorkaround Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?] * Manual steps: https://support.mozilla.org/questions/968190?page=5#answer-509209 * Batch file to automate the manual steps: https://support.mozilla.org/questions/982093#answer-518078 (alternate version of Carm's batch file with a few changes by me: [https://onedrive.live.com/?cid=f7d304d92388737d&id=F7D304D92388737D!336&ithint=file,.bat&authkey=!AP2FXW2Y_3BXZyo]) Flash needs to completely unload from memory (exiting and starting Firefox up again might help) before this takes effect. Any improvement?

Question owner

jscher2100, while I appreciate the effort. I tried all that (did not mention that in my main post, my bad!). but to no effect. Pages are still loading very slow and i'm still able to crash flash in a heartbeat by just rightclicking (yes safemode/protectedmode = off)

jscher2100, while I appreciate the effort. I tried all that (did not mention that in my main post, my bad!). but to no effect. Pages are still loading very slow and i'm still able to crash flash in a heartbeat by just rightclicking (yes safemode/protectedmode = off)
jscher2000
  • Top 10 Contributor
8695 solutions 71076 answers

You probably also have seen this article, but just in case: Quick fixes if your Firefox slows down.

Have you tested in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any faster or less crashy?


When Firefox crashes, it usually records information about what was happening at that moment. You often will see the Mozilla Crash Reporter dialog come up. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the last section of the support article "Firefox crashes - Troubleshoot, prevent and get help fixing crashes" for steps to get those crash IDs, and then post some of the recent ones here.

You probably also have seen this article, but just in case: [[Firefox is slow - How to make it faster]]. Have you tested in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any faster or less crashy? ---- When Firefox crashes, it usually records information about what was happening at that moment. You often will see the Mozilla Crash Reporter dialog come up. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the last section of the support article "[[Firefox Crashes]]" for steps to get those crash IDs, and then post some of the recent ones here.
jscher2000
  • Top 10 Contributor
8695 solutions 71076 answers

If you open a page that should normally load quickly, like Google search results, you can watch for slow requests using Firefox's Web Console.

To open the console, press Ctrl+Shift+k or use the Developer menu.

Along its top bar, click Network. Then reload the page and watch the timings. If you click a row, the console usually will show a more detailed breakdown of how the time was consumed. Not sure whether this will lead to any insights.

If you open a page that should normally load quickly, like Google search results, you can watch for slow requests using Firefox's Web Console. To open the console, press Ctrl+Shift+k or use the Developer menu. Along its top bar, click Network. Then reload the page and watch the timings. If you click a row, the console usually will show a more detailed breakdown of how the time was consumed. Not sure whether this will lead to any insights.
cor-el
  • Top 10 Contributor
  • Moderator
17479 solutions 157962 answers

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/