Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Option to 'Warn me when websites...try to reload' doesn't work?

  • 4 replies
  • 2 have this problem
  • 6 views
  • Last reply by cor-el

more options

Firefox 37.0.1 (and all of my previous installations) for MacOS X 10.7.5.

I would have thought such a simple case of javascript reload was covered. For example, drudgereport.com still annoyingly reloads every few minutes due to this in its header:

var timer = setInterval("autoRefresh()", 1000 * 50 * 3); function autoRefresh(){self.location.reload(true);}

Would this not qualify as a bonefide browser bug?

Firefox 37.0.1 (and all of my previous installations) for MacOS X 10.7.5. I would have thought such a simple case of javascript reload was covered. For example, drudgereport.com still annoyingly reloads every few minutes due to this in its header: var timer = setInterval("autoRefresh()", 1000 * 50 * 3); function autoRefresh(){self.location.reload(true);} Would this not qualify as a bonefide browser bug?

Chosen solution

The setting in "Options/Preferences > Advanced > General" doesn't work when JavaScript is used to refresh a web page like the drudgereport website is using.

A possible workaround is to use a bookmarklet to disable this 'feature'. You need to use the bookmarklet each you (re)load the web page.

javascript:clearInterval(timer);void(autoRefresh=null);

The setting in "Options/Preferences > Advanced > General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting.

See also:

Read this answer in context 👍 1

All Replies (4)

more options

kencute is clearly a spammer. Anyone else?

more options

Chosen Solution

The setting in "Options/Preferences > Advanced > General" doesn't work when JavaScript is used to refresh a web page like the drudgereport website is using.

A possible workaround is to use a bookmarklet to disable this 'feature'. You need to use the bookmarklet each you (re)load the web page.

javascript:clearInterval(timer);void(autoRefresh=null);

The setting in "Options/Preferences > Advanced > General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting.

See also:

Modified by cor-el

more options

Nicely elegant solution.

This works a charm, though it'd be better as a single step (load page and stop reload as one bookmark). I've tried variants of:

javascript:location='http://drudgereport.com';clearInterval(timer);void(autoRefresh=null);

...to no avail. Is this possible?

more options

No, that won't work because the JavaScript needs to run when the page has finished loading and that won't happen if you change the location. You would have to use GreaseMonkey or Scriptish to achieve that and run the script on page load.