Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

Adobe Reader for Vista Shows Vulnerable, but THERE IS NOT THE VERSIN THAT MOZILLA SAYS T UPDATE TO? Where is it????

  • 1 reply
  • 2 have this problem
  • 8 views
  • Last reply by jscher2000

more options

Mozilla keeps telling us we need to update to Adobe Reader version 11.0.10.32. Nowhere in the Adobe site is there such a version. Have looked, have contacted, so will Mozilla PLEASE TELL US WHERE? Additionally, this is being sent from my Vista OS, and Adobe has no Version 11 for Vista. SO neither my XP PRO systems not my Vista Systems will update to the Version Mozilla shows in the Add-ons Plugin Manager pages.

All Replies (1)

more options

Adobe doesn't support Reader/Acrobat XI on Vista. Who knows why... as long as Help > Check for Updates in Reader/Acrobat says you are up-to-date, trust that information.

Also, please see my reply in your other thread: https://support.mozilla.org/questions/1057975#answer-719224