Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Adobe Reader is current. Firefox 37 says it is not. Can't updtae to the Mozilla listed version 11.0.10.32

  • 6 replies
  • 3 have this problem
  • 17 views
  • Last reply by James

more options

As stated above, Adobe Reader has been updated to version 11.0.10. The last and only version currently available on their site. Firefox version 37.0.1 is the latest Firefox. All week when checking for plugin status updates, it show Adobe Reader is vulnerable. I have followed the link three different days, downloaded and installed and it still comes back as being vulnerable. And still only shows up as Adobe Version 11.0.10. IT WON"T UPDATE TO 11.0.10.32. How? Where? is that version? And why after updating 3 times does it keep coming back as vulnerable? Scratching my head, so I have no more hair. Am using XP PRO SP3, Firefox latest. All other addons the latest.

All Replies (6)

more options

Sometimes the version numbers on the plugin checker site are messed up...

Could you try this:

(1) Go into Adobe Reader and use Help > Check for Updates. Sometimes a minor interim update isn't available for download by itself on Adobe's site, so this should take care of that issue if there is one.

(2) Check Firefox's Add-ons page to see the version listed there. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Then on the right side, find Adobe Acrobat 11.0.10.?? (where ?? is your current sub-version number).

If you don't see 11.0.10.32 there, you might need to exit Firefox and start it up again to prompt a re-read of what's on your system. If that doesn't work, there are more drastic measures we could try.

more options

Whenever I can't install or download from the Mozilla site, I will always use the native Adobe Update link from within Adobe. Still does not answer why Adobbe HAS NO UPDATE VERSION 11.0.10.32 LISTED ON THERE SITE FOR ANY OS, Vista or XP Pro.

more options

On the Add-ons Manager Page, Adobe Acrobat shows Version 11.0.10.32 installed, with the "Ask to Activate" checked instead of the "Always" Activate. Will try that change and rescan.

more options

Just tried a rescan in Vista after changing to "Always Activate" for Adobe Acrobat, and still scans as being vulnerable,. Click the link for Adobe, input the Correct OS, Language and it still will NOT SHOW the Mozilla Listed version.

more options

Do you have XP or Vista??

FrankIncensed said

On the Add-ons Manager Page, Adobe Acrobat shows Version 11.0.10.32 installed...

The plugin checker site appears to be broken. You have the latest version for Windows as far as I know and as far as Adobe is concerned.

Modified by jscher2000

more options

With WinXP users, the issue is Not with the Plugin check so much but due to you using the old Windows XP.

For WinXP the last version was 11.0.8 while for Windows 7 and 8 it is 11.0.10 and DC version.

For Vista they only list 10.1.4

http://get.adobe.com/reader/otherversions/

Modified by James