Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot bypass certificate warning for self-signed cert

  • 3 replies
  • 1 has this problem
  • 1 view
  • Last reply by amloessb

more options

We have an internal application that uses a self-signed cert which I have accessed using Firefox before. Today when I tried to log in to the app, I received the attached error message from Firefox, but there is no option to ignore the warning and continue. I can still bypass the cert just fine in Chrome and log in (also attached).

How can I bypass this secure connection failure and continue to the site?

We have an internal application that uses a self-signed cert which I have accessed using Firefox before. Today when I tried to log in to the app, I received the attached error message from Firefox, but there is no option to ignore the warning and continue. I can still bypass the cert just fine in Chrome and log in (also attached). How can I bypass this secure connection failure and continue to the site?
Attached screenshots

All Replies (3)

more options

Forgot to mention this, but I already tried deleting the stored certificate by following the steps in [1], but the same error message results.

[1] https://support.mozilla.org/en-US/questions/1012728#answer-616338

more options

The website may try to fallback to TLS 1.0 in a way that is no longer allowed in current releases or may be using a deprecated cipher suite.

You can open the about:config page via the location/address bar and use its search bar to locate this pref:

  • security.tls.insecure_fallback_hosts

You can double-click the line to modify the pref and add the full domain (TEXT) to this pref. If there are already websites (domains) in this list then add a comma and the new domain (no spaces). You should only see domains separated by a comma in the value column.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You may still have issues because the certificate seems to be expired.

If this helps then you can contact this website and ask them to look into this.


more options

Thanks for the suggestion. I have tried setting security.tls.insecure_fallback_hosts to "us-crashp-wp1" and "us-crashp-wp1:4285" (as well as the FQDN, with and without the port number), but I am still receiving the same error message.