X
Tap here to go to the mobile version of the site.

Support Forum

When I close Firefox, it leaves an open instance each time in Processes. This eats up memory. I've disabled all add-ons, and it still does it.

Posted

Over the course of the day, I can have 15-20 instances running in the background and they can range from as low as 3K in memory to upwards of 500000K. This makes my computer super laggy, and I have to go in and manually shut down each one. I've disabled every single add-on and plug in, and tried uninstalling and re-installing Firefox to no avail. I'm at the point where if I can't get this fixed, I'll just have to switch to another browser because this is a huge time suck. If you have any ideas, I'd appreciate it. Thanks.

Over the course of the day, I can have 15-20 instances running in the background and they can range from as low as 3K in memory to upwards of 500000K. This makes my computer super laggy, and I have to go in and manually shut down each one. I've disabled every single add-on and plug in, and tried uninstalling and re-installing Firefox to no avail. I'm at the point where if I can't get this fixed, I'll just have to switch to another browser because this is a huge time suck. If you have any ideas, I'd appreciate it. Thanks.

Additional System Details

Application

  • Firefox 36.0.4
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
  • Support URL: https://support.mozilla.org/1/firefox/36.0.4/WINNT/en-US/

Extensions

  • Dashlane 3.2.4.78888 ({442718d9-475e-452a-b3e1-fb1ee16b8e9f})
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Google Translator for Firefox 2.1.0.3m (translator@zoli.bod) (Inactive)
  • Open Bookmarks in New Tab 0.1.2012122901 (openbookmarkintab@piro.sakura.ne.jp) (Inactive)
  • Screengrab (fix version) 0.98.06c ({02450914-cdd9-410f-b1da-db004e18c671}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA Quadro NVS 420
  • adapterDescription2:
  • adapterDeviceID: 0x06f8
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterSubsysID: 057e10de
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 1-18-2013
  • driverDate2:
  • driverVersion: 9.18.13.1106
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA Quadro NVS 420 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

http://kb.mozillazine.org/Firefox.exe_always_open


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

'''http://kb.mozillazine.org/Firefox.exe_always_open''' ------------------------------ Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there?
cor-el
  • Top 10 Contributor
  • Moderator
17536 solutions 158573 answers

Use "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit) to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

If you use "Clear history when Firefox closes" then try to disable this feature.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history": [] "Clear history when Firefox closes"
Use "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit) to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar. If you use "Clear history when Firefox closes" then try to disable this feature. *Tools > Options > Privacy > Firefox will: "Use custom settings for history": [] "Clear history when Firefox closes"