Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My Firefox is lagging extremely.

  • 6 replies
  • 4 have this problem
  • 16 views
  • Last reply by cor-el

more options

Since a few weeks my Firefox is lagging extremely on virtually all websites. That's for scrolling up and down (first no reaction, then it jumps an uncontrolled distance) as well as watching videos for example on youtube. I have no issues using Chrome - loads faster and scrolls and plays videos smoothly, so it doesn't seem to be my laptop.

I refreshed - didn't work. Deleted and reinstalled - didn't work. Finally I disabled all add-ons and plugins - didn't work.

I'd hate to move to Chrome, but if I can't fix it I don't have a choice. At the moment Firefox is unusable.

Thank you in advance for your help.

All Replies (6)

more options

This may help;

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it


Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

more options

Thannks for your reply Fred McD.

Unfortunately your trick didn't work.

I updated my graphics drivers yesterday which helps a little but far from solves the problem.

Any other suggestions?

more options
more options

Thanks again for your reply.

None of the links helped me unfortunately. I did realize though that firefox routinely uses over 50% of my Memory though. I checked the support page for ff using too much RAM but that didn't help either.

Any further suggestions?

more options

Is this on all pages? many, a few?

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

If there is a problem with scrolling on web pages then try to disable smooth scrolling.

  • Tools > Options > Advanced > General: Browsing: "Use smooth scrolling"

Did you try Firefox Safe Mode?


Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.