Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Icons in tabs and web pages get "smudged" and displayed wrong

  • 3 replies
  • 17 have this problem
  • 1104 views
  • Last reply by FredMcD

more options

After update to 37.0.1 Firefox has major problems with display of icons in the tabs on the web page as well as icons on the web page itself. They get mixed up, completely mis-formatted, and smudged. Some examples in pictures... It is pretty much impossible to know any more which page is open based on tabs, since often wrong icons and page titles are displayed for the page open.

This was not a problem with previous Firefox versions and also does not happen with other browsers.

Attached screenshots

Chosen solution

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.


Separate Issue; Your System Details shows;

Installed Plug-ins

Adobe PDF Plug-In For Firefox and Netscape 11.0.10 Adobe PDF Plug-In For Firefox and Netscape 15.7.20033

Having more than one version of a program may cause issues.

Read this answer in context 👍 4

All Replies (3)

more options

Chosen Solution

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.


Separate Issue; Your System Details shows;

Installed Plug-ins

Adobe PDF Plug-In For Firefox and Netscape 11.0.10 Adobe PDF Plug-In For Firefox and Netscape 15.7.20033

Having more than one version of a program may cause issues.

more options

The hardware acceleration was the problem... weird that it did not have any effect before 37.0.1. Thank you!

more options

That was very good work. Well Done. Please flag your last post as Solved Problem so other will know.