Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

SPAMCOP DOES NOT WORK WITH FIREFOX 37

  • 1 reply
  • 1 has this problem
  • 1 view
  • Last reply by jscher2000

more options

When I copy the e-mail Message header and message into SPAMCOP and Press " Process Spam, SPAMCOP returns with the message: " No source IP address found, cannot proceed.". However, if use use INTERNET EXPLORER 9 to report to SPAMCOP, it works fine!!!

All Replies (1)

more options

Hmm, I don't have a login for this site: https://www.spamcop.net/

Did this problem just start after you updated to Firefox 37 or was it happening in Firefox 36?

Would you be interested in checking Firefox's Browser Console for any error messages that appear when loading the page or submitting the headers? If so, I suggest this order:

(1) Open the Browser Console using either:

  • Ctrl+Shift+j
  • Developer menu

(2) Click the Clear button at the top to discard previous messages

(3) Leaving that window open, reload the SpamCop page with the form you want to use

(4) Check the console for errors (you usually can ignore style warnings and general messages). Anything?

(5) Leaving the console open, switch back to SpamCopy and paste the headers, then check for any new errors in the console as a result of that action

(6) Finally, submit the headers and then check the browser console again for any new errors


In the absence of hands-on experience or error messages, some general advice:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?


Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference in how the site works?