X
Tap here to go to the mobile version of the site.

Support Forum

How to unblock a website from using an plugin when plugin's activation set as "Ask to activate"?

Posted

Hello all,

In desperate attempts of not using Flash anymore, I set its activation setting to "Ask to activate". Then I went on a website (that uses Flash) and Firefox prompted me whether or not I allow that said website to use Flash. I did not want to allow this site to use it at that time so I first clicked the cross to close the question. But it popped again and I then answered "Maintain the blocking" (or whatever it might be in English).

However, I now want to use Flash on this website while keeping the "Ask to activate" setting. But the prompt does not show anymore even after restarting Firefox. So the question is how one can revert this? How to allow a website again to use a plugin after the user said no?

Many thanks in advance.

Roadkiller

Hello all, In desperate attempts of not using Flash anymore, I set its activation setting to "Ask to activate". Then I went on a website (that uses Flash) and Firefox prompted me whether or not I allow that said website to use Flash. I did not want to allow this site to use it at that time so I first clicked the cross to close the question. But it popped again and I then answered "Maintain the blocking" (or whatever it might be in English). However, I now want to use Flash on this website while keeping the "Ask to activate" setting. But the prompt does not show anymore even after restarting Firefox. So the question is how one can revert this? How to allow a website again to use a plugin after the user said no? Many thanks in advance. Roadkiller

Chosen solution

When you click "Continue Blocking" Firefox adds an entry to the site permissions database (permissions.sqlite) to not bother you with the infobar any more. The notification icon should still appear in the address bar.

You might also check the Permissions panel of the Page Info dialog. You can call that up using any of these:

  • right-click and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or globe icon to the left of the site address > More Information > Permissions

There should be a section listing plugin permissions on the site where you can find "Adobe Flash" and if it is set to Block, change it back to "Use default".

If that doesn't restore the infobar, and you can't live without it, there are three less than ideal ways to clear that permission setting:

(1) Use the "Forget About This Site" feature to clear ALL data for the site: site permissions, cookies, bookmarks, history, everything. If you right-click any entry in history for the site, "Forget About This Site" is on the right-click context menu.

(2) Completely delete the site permissions database (but this removes things like cookie blocks, popup permissions, etc. for all sites). I don't recommend this.

(3) Use an extension that allows you to edit the site permissions database (somewhat involved, see: https://support.mozilla.org/questions/1011980#answer-606947).

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 17.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.7.157

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0

More Information

jscher2000
  • Top 10 Contributor
8765 solutions 71703 answers

Does the plugin notification icon appear in the address bar? It looks like a small Lego block. That is the all-purpose plugin permission icon that should always be present even when no infobar appears and even when a poster in front of a video hides the activation link there.

Does the plugin notification icon appear in the address bar? It looks like a small Lego block. That is the all-purpose plugin permission icon that should always be present even when no infobar appears and even when a poster in front of a video hides the activation link there.

Question owner

jscher2000 said

Does the plugin notification icon appear in the address bar? It looks like a small Lego block. That is the all-purpose plugin permission icon that should always be present even when no infobar appears and even when a poster in front of a video hides the activation link there.

Well, it is actually not there on the website I said to block Flash. And I know what icon you are talking about, it is there for website I allowed to use Flash.

''jscher2000 [[#answer-711545|said]]'' <blockquote> Does the plugin notification icon appear in the address bar? It looks like a small Lego block. That is the all-purpose plugin permission icon that should always be present even when no infobar appears and even when a poster in front of a video hides the activation link there. </blockquote> Well, it is actually not there on the website I said to block Flash. And I know what icon you are talking about, it is there for website I allowed to use Flash.

Question owner

jscher2000 said

Does the plugin notification icon appear in the address bar? It looks like a small Lego block. That is the all-purpose plugin permission icon that should always be present even when no infobar appears and even when a poster in front of a video hides the activation link there.

Well, I answered a bit too fast. After further experimentations, I was able to make the icon appears. I do not know exactly how that website handle Flash but at first, I was prompted immediately if I wanted to allow or block Flash on that website and now I have to force it to display Flash content (to pop an object node in the HTML tree probably) to let Firefox shows the Lego block icon.

But still how to workaround that problem if there is no way to force the website to use Flash?

''jscher2000 [[#answer-711545|said]]'' <blockquote> Does the plugin notification icon appear in the address bar? It looks like a small Lego block. That is the all-purpose plugin permission icon that should always be present even when no infobar appears and even when a poster in front of a video hides the activation link there. </blockquote> Well, I answered a bit too fast. After further experimentations, I was able to make the icon appears. I do not know exactly how that website handle Flash but at first, I was prompted immediately if I wanted to allow or block Flash on that website and now I have to force it to display Flash content (to pop an object node in the HTML tree probably) to let Firefox shows the Lego block icon. But still how to workaround that problem if there is no way to force the website to use Flash?
jscher2000
  • Top 10 Contributor
8765 solutions 71703 answers

Chosen Solution

When you click "Continue Blocking" Firefox adds an entry to the site permissions database (permissions.sqlite) to not bother you with the infobar any more. The notification icon should still appear in the address bar.

You might also check the Permissions panel of the Page Info dialog. You can call that up using any of these:

  • right-click and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or globe icon to the left of the site address > More Information > Permissions

There should be a section listing plugin permissions on the site where you can find "Adobe Flash" and if it is set to Block, change it back to "Use default".

If that doesn't restore the infobar, and you can't live without it, there are three less than ideal ways to clear that permission setting:

(1) Use the "Forget About This Site" feature to clear ALL data for the site: site permissions, cookies, bookmarks, history, everything. If you right-click any entry in history for the site, "Forget About This Site" is on the right-click context menu.

(2) Completely delete the site permissions database (but this removes things like cookie blocks, popup permissions, etc. for all sites). I don't recommend this.

(3) Use an extension that allows you to edit the site permissions database (somewhat involved, see: https://support.mozilla.org/questions/1011980#answer-606947).

When you click "Continue Blocking" Firefox adds an entry to the site permissions database (permissions.sqlite) to not bother you with the infobar any more. The notification icon should still appear in the address bar. You might also check the Permissions panel of the Page Info dialog. You can call that up using any of these: * right-click and choose View Page Info > Permissions * (menu bar) Tools menu > Page Info > Permissions * click the padlock or globe icon to the left of the site address > More Information > Permissions There should be a section listing plugin permissions on the site where you can find "Adobe Flash" and if it is set to Block, change it back to "Use default". If that doesn't restore the infobar, and you can't live without it, there are three less than ideal ways to clear that permission setting: (1) Use the "Forget About This Site" feature to clear ALL data for the site: site permissions, cookies, bookmarks, history, everything. If you right-click any entry in history for the site, "Forget About This Site" is on the right-click context menu. (2) Completely delete the site permissions database (but this removes things like cookie blocks, popup permissions, etc. for all sites). I don't recommend this. (3) Use an extension that allows you to edit the site permissions database (somewhat involved, see: [https://support.mozilla.org/questions/1011980#answer-606947]).

Question owner

Thank you very much. I completely forgot this panel. I set your post as answering the question. Have a nice day.

Thank you very much. I completely forgot this panel. I set your post as answering the question. Have a nice day.