Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox: Flickering when scrolling - need help with clean 'new' install

  • 6 replies
  • 2 have this problem
  • 21 views
  • Last reply by philipp

more options

Screen is flickering when scrolling (IE does not). I tried disabling add-ons and tried safe mode - neither helped. Running Win 7 Pro 64bit. Uninstalled via 'Programs and Features'. Download and reinstalled Firefox. Now it shows all my previous settings: menu bar, bookmarks bar, etc. Question: how did it get that stuff back if it 'cleanly' uninstalled? Question: how do I know it didn't pick up it's old 'bad habit' from the previous settings? I am an experienced PC user but not Firefox expert. Looking for help lest I have to ditch Firefox completely...

Modified by JRS40

All Replies (6)

more options

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Open Firefox Options window (Preferences on Mac or Linux) as follows:
    • In Firefox 29.0 and above, click the menu button New Fx Menu and select Options for Windows or Preferences on Mac or Linux.
    • In Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  2. In the Firefox Options (or Preferences) window, click the Advanced tab, then select General.
  3. In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  4. Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options

Been there, done that -> no change. Thanks for your suggeestion.

more options

I would think that Firefox stores a lot of its data either in appdata > mozilla > firefox or in the cloud some info on your specs would be useful aswell please.

Modified by J0sh0nat0r

more options

Tried uninstall, then delete local appdata folder (emptied recycle bin), re-installed -> same thing so perhaps setting stored in cloud. Not sure how to wipe out that source. What specs you looking for?

more options

Tried again: uninstalled Mozilla; did a search via Windows Explorer and deleted all traces of Mozilla other than in IE history; reinstalled -> this time it looked clean (no traces of my old settings) but screen still flickers when scrolling. Problem appeared after the last recent 'upgrade'. Hey Mozilla, WHAT UP?

more options

please try updating your intel graphics driver to the latest version (this should be the right link for your configuration): https://downloadcenter.intel.com/download/24785/Intel-Iris-and-HD-Graphics-Driver-for-Windows-7-8-8-1-64-bit