X
Tap here to go to the mobile version of the site.

Support Forum

Audio clips on my website download instead of stream. Does not happen in Explorer.

Posted

I have audio clips on my personal artist website which I have just discovered are downloading instead of streaming. This has never happened in all the years I've had the site until now. In Explorer the clips stream as normal.

I have audio clips on my personal artist website which I have just discovered are downloading instead of streaming. This has never happened in all the years I've had the site until now. In Explorer the clips stream as normal.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • Google Updater pluginhttp://pack.google.com/
  • Next Generation Java Plug-in 11.40.2 for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Shockwave Flash 11.3 r300
  • Shockwave Flash 11.2 r202
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • iTunes Detector Plug-in

Application

  • Firefox 36.0.1
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:36.0) Gecko/20100101 Firefox/36.0
  • Support URL: https://support.mozilla.org/1/firefox/36.0.1/WINNT/en-US/

Extensions

  • Bitdefender Wallet 2.0 (bdwteff@bitdefender.com) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 6150
  • adapterDescription2:
  • adapterDeviceID: 0x0240
  • adapterDeviceID2:
  • adapterDrivers: nv4_disp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 1-31-2013
  • driverDate2:
  • driverVersion: 6.14.13.783
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 6150 Direct3D9 vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8705 solutions 71139 answers

There are many ways to code audio clips in a website. In order to comment on why yours is doing what it's doing, could you post a link to a page demonstrating the problem?

There are many ways to code audio clips in a website. In order to comment on why yours is doing what it's doing, could you post a link to a page demonstrating the problem?
jscher2000
  • Top 10 Contributor
8705 solutions 71139 answers

Your "More System Details" shows three versions of the Flash player plugin, which may cause some confusion for Firefox:

  • Shockwave Flash 11.3 r300
  • Shockwave Flash 11.2 r202
  • Shockwave Flash 16.0 r0

If you are having issues with Flash, you might want to run Adobe's uninstaller and then reinstall Flash from scratch.

Your "More System Details" shows three versions of the Flash player plugin, which may cause some confusion for Firefox: * Shockwave Flash 11.3 r300 * Shockwave Flash 11.2 r202 * Shockwave Flash 16.0 r0 If you are having issues with Flash, you might want to run Adobe's uninstaller and then reinstall Flash from scratch. * Uninstaller: https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html * Standard Flash installer: http://get.adobe.com/flashplayer/ * Full/offline Flash installers: http://www.adobe.com/special/products/flashplayer/fp_distribution3.html

Question owner

Here is the requested link. http://www.stevepower.us/Music.htm

Normally if you click on any song title it should launch your media player and begin to play. This is what it used to do in any browser but now with Firefox it simply downloads the file without playing it.

I tried the uninstall reinstall as suggested but that didn't work. I had the latest version of Flash installed recently. The two older versions you mentioned only were shown in the add-ons list and they were disabled.

Here is the requested link. http://www.stevepower.us/Music.htm Normally if you click on any song title it should launch your media player and begin to play. This is what it used to do in any browser but now with Firefox it simply downloads the file without playing it. I tried the uninstall reinstall as suggested but that didn't work. I had the latest version of Flash installed recently. The two older versions you mentioned only were shown in the add-ons list and they were disabled.
jscher2000
  • Top 10 Contributor
8705 solutions 71139 answers

What happens for me is that the QuickTime plugin loads full screen to play the mp3, replacing the page.

The server is sending the content type audio/x-mpeg with the media, which in my Firefox is handled by QuickTime. It's possible that users with other plugins may have the music play in that plugin. It's up to their browser.


Could you check your Application preferences here:

"3-bar" menu button (or Tools menu) > Options > Applications

The list may take several seconds to load.

In the search box above the list try typing mp and pause to let Firefox filter the list. Do you have any entry with (audio/x-mpeg) after the description? That's most likely the one relevant to these files.

What happens for me is that the QuickTime plugin loads full screen to play the mp3, replacing the page. The server is sending the content type '''audio/x-mpeg''' with the media, which in my Firefox is handled by QuickTime. It's possible that users with other plugins may have the music play in that plugin. It's up to their browser. ---- Could you check your Application preferences here: "3-bar" menu button (or Tools menu) > Options > Applications The list may take several seconds to load. In the search box above the list try typing '''mp''' and pause to let Firefox filter the list. Do you have any entry with (audio/x-mpeg) after the description? That's most likely the one relevant to these files.
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158018 answers

Note that Firefox also can play such a MP3 file via the built-in HTML5 media player, but doesn't do this because of the audio/x-mpeg content type instead of audio/mpeg.

Note that Firefox also can play such a MP3 file via the built-in HTML5 media player, but doesn't do this because of the audio/x-mpeg content type instead of audio/mpeg. *https://developer.mozilla.org/Media_formats_supported_by_the_audio_and_video_elements
littlesonny 0 solutions 2 answers

There is nothing in the Application list with audio/x-mpeg. I'm not quite sure what that means. All of the audio files in question are simply .mp3 files and have played on Firefox for years with no problems. I have not knowingly changed anything.

There is nothing in the Application list with audio/x-mpeg. I'm not quite sure what that means. All of the audio files in question are simply .mp3 files and have played on Firefox for years with no problems. I have not knowingly changed anything.
jscher2000
  • Top 10 Contributor
8705 solutions 71139 answers

Web servers always send a content-type header with a file, and Firefox uses that information to determine how to handle the content. Firefox does not look at the file extension.

With those MP3s, the server is indicating the type audio/x-mpeg instead of the more common audio/mpeg. This is a setting that usually is controlled by your web host, but it is usually possible to override it and send a different type by creating a .htaccess file in the folder where the MP3s are hosted.


In case this is a change in Firefox rather than a change on your server, it might be due to a corrupted entry in the file that stores download settings. You could try removing that file and allowing Firefox to create a new one. here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old.

Start Firefox back up again. On your next access to an MP3 on your server, I would expect Firefox to ask you what you want to do with it instead of taking any action automatically.

Web servers always send a content-type header with a file, and Firefox uses that information to determine how to handle the content. Firefox does not look at the file extension. With those MP3s, the server is indicating the type audio/x-mpeg instead of the more common audio/mpeg. This is a setting that usually is controlled by your web host, but it is usually possible to override it and send a different type by creating a .htaccess file in the folder where the MP3s are hosted. ---- In case this is a change in Firefox rather than a change on your server, it might be due to a corrupted entry in the file that stores download settings. You could try removing that file and allowing Firefox to create a new one. here's how: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then rename '''mimeTypes.rdf''' to something like mimeTypes.old. Start Firefox back up again. On your next access to an MP3 on your server, I would expect Firefox to ask you what you want to do with it instead of taking any action automatically.
littlesonny 0 solutions 2 answers

Tried renaming the mimetypes as suggested. Firefox does now ask what to do before playing allowing the file to be played on WMP but it downloads the file at the same time so I have to go into the folder it's saved in a delete each time. Rather a pain. Any other suggestions?

Tried renaming the mimetypes as suggested. Firefox does now ask what to do before playing allowing the file to be played on WMP but it downloads the file at the same time so I have to go into the folder it's saved in a delete each time. Rather a pain. Any other suggestions?
jscher2000
  • Top 10 Contributor
8705 solutions 71139 answers

Hi littlesonny, usually if you choose the Open choice in the Open/Save/Cancel dialog, Firefox saves the file to the Windows temp folder. I'm not sure what determines the lifespan of files in that folder. Is that where you are finding it, or in your Downloads or another folder?

Hi littlesonny, usually if you choose the Open choice in the Open/Save/Cancel dialog, Firefox saves the file to the Windows temp folder. I'm not sure what determines the lifespan of files in that folder. Is that where you are finding it, or in your Downloads or another folder?