X
Tap here to go to the mobile version of the site.

Support Forum

mozilla crash reporter - many crashes

Posted

Hello

For last two weeks I always get crash reporter when I run FF 36. When I'm on 35 I have no problems, after update or new install of 36 I get crash reporter again. I also tried version 37 and I also get crash reporter.

I realy do not know what to do. I uninstall in reinstall FF many times, I removed old profile in roaming folder but I still get crash report.

Here are few of my reports:

bp-ff5e26aa-e58c-4707-b825-03ede2150319 bp-e86c86b7-069b-4697-9972-fafd12150319 bp-57ec3001-66a2-4af1-808e-72cae2150318 bp-464d6159-29d8-4464-8778-e9d002150318 bp-1695b3bc-d3a2-43a6-b777-092d72150318 bp-2a5e9004-73a1-49f7-803a-0b03b2150318

Please help me find what is wrong.

Thank you

Kind regards

Hello For last two weeks I always get crash reporter when I run FF 36. When I'm on 35 I have no problems, after update or new install of 36 I get crash reporter again. I also tried version 37 and I also get crash reporter. I realy do not know what to do. I uninstall in reinstall FF many times, I removed old profile in roaming folder but I still get crash report. Here are few of my reports: bp-ff5e26aa-e58c-4707-b825-03ede2150319 bp-e86c86b7-069b-4697-9972-fafd12150319 bp-57ec3001-66a2-4af1-808e-72cae2150318 bp-464d6159-29d8-4464-8778-e9d002150318 bp-1695b3bc-d3a2-43a6-b777-092d72150318 bp-2a5e9004-73a1-49f7-803a-0b03b2150318 Please help me find what is wrong. Thank you Kind regards

Modified by gregorv

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Shockwave Flash 16.0 r0

Application

  • Firefox 36.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:36.0) Gecko/20100101 Firefox/36.0
  • Support URL: https://support.mozilla.org/1/firefox/36.0.1/WINNT/sl/

Extensions

  • Adobe Acrobat - Create PDF 2.0 (web2pdfextension@web2pdf.adobedotcom) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0102
  • adapterDeviceID2:
  • adapterDrivers: igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 307017aa
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.1.7601.18245
  • driverDate: 12-12-2012
  • driverDate2:
  • driverVersion: 9.17.10.2932
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

The crash reports show;

Signature XPCJSRuntime Nothing else listed.


Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

The crash reports show; Signature XPCJSRuntime Nothing else listed. ----------------------------- '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems?

Question owner

Hello

Thank you for your kind answer.

I follow your procedure but unfortunatelly I still have the same problem. Crash reporter opens on each FF start.

The only problem I had is flash player but after I set this to true:

dom.ipc.plugins.flash.disable-protected-mode;true

I don't have problems with flash anymore.

Do you have any other idea what can I do? Is it possible to disable, remove crach reporter?

Thank you

Kind regards

Hello Thank you for your kind answer. I follow your procedure but unfortunatelly I still have the same problem. Crash reporter opens on each FF start. The only problem I had is flash player but after I set this to true: dom.ipc.plugins.flash.disable-protected-mode;true I don't have problems with flash anymore. Do you have any other idea what can I do? Is it possible to disable, remove crach reporter? Thank you Kind regards
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

The crash reporter is a watch dog program. It should not be the cause of your problems. Please post the new crash reports. Have you tried starting Firefox in safe mode.?

The crash reporter is a watch dog program. It should not be the cause of your problems. Please post the new crash reports. Have you tried starting Firefox in safe mode.?

Question owner

Hello

When I use safe mode, I don't get crash report. But after I run FF again in normal mode, crash report appears again.

I removed all plugins, disable them... but this does not solve the problem.

I have this problem on PC at my work. I will post new crash reports tomorrow.

Thank you

Kind regards

Hello When I use safe mode, I don't get crash report. But after I run FF again in normal mode, crash report appears again. I removed all plugins, disable them... but this does not solve the problem. I have this problem on PC at my work. I will post new crash reports tomorrow. Thank you Kind regards
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

It could be the work of one of your add-ons. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac:<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable a few add-ons, then '''Restart Firefox.''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

Question owner

Hello

My FF has only one extention:

Adobe Acrobat - Create PDF 2.0 which is disabled.

Regarding AV software, we have Symantec endpoint protection, but unfortunatelly I can't disable it. I'm just normal user, not admin.

Here are today reports:

bp-f02e16bb-7b6a-4b87-80bc-c73d12150323 bp-7ed4d013-d225-498c-98f2-6ca162150323 bp-de89ef13-6bd9-449b-a7ac-8ff632150323 bp-916a2222-fdfc-4e41-9126-9fc852150323 ....

Can you see in these reports what the problem is? I don't know how to read them.

Is it possible to disable crash report windows?

Other possibility is that I stay on v 35, but the problem is that FF automatically updates to 36 (even if I disable auto update)

Thank you

Kind regards

Hello My FF has only one extention: Adobe Acrobat - Create PDF 2.0 which is disabled. Regarding AV software, we have Symantec endpoint protection, but unfortunatelly I can't disable it. I'm just normal user, not admin. Here are today reports: bp-f02e16bb-7b6a-4b87-80bc-c73d12150323 bp-7ed4d013-d225-498c-98f2-6ca162150323 bp-de89ef13-6bd9-449b-a7ac-8ff632150323 bp-916a2222-fdfc-4e41-9126-9fc852150323 .... Can you see in these reports what the problem is? I don't know how to read them. Is it possible to disable crash report windows? Other possibility is that I stay on v 35, but the problem is that FF automatically updates to 36 (even if I disable auto update) Thank you Kind regards

Modified by gregorv

FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

gregorv said

Is it possible to disable crash report windows?

If you mean the Firefox reporter, that is a watch dog program. It should not be the cause of your problems.


The crash report flagged these programs;

Signature XPCJSRuntime

Same as the others you posted.

''gregorv [[#answer-707920|said]]'' <blockquote> Is it possible to disable crash report windows? </blockquote> If you mean the Firefox reporter, that is a watch dog program. It should not be the cause of your problems. ------------------------------------- The crash report flagged these programs; Signature XPCJSRuntime Same as the others you posted.

Question owner

Thank you for your answer.

Sorry, yes, I mean crash reporter in FF.

Yes; I know that crash reporter is not the cause for my problem. But because I can't find the right cause for crashes, I want to disable it. Is this possible?

I searched in google for - XPCJSRuntime - XPCJSRuntime::XPCJSRuntime(nsXPConnect*) - js/xpconnect/src/XPCJSRuntime.cpp

but there are no solutions for this problem.

It appears that I will have to live with with crash every time I start FF, one more click :(

Other possibility is to format disk and do a clean install of windows..., but this is not possible because our admins will not allow this.

Kind regards

Thank you for your answer. Sorry, yes, I mean crash reporter in FF. Yes; I know that crash reporter is not the cause for my problem. But because I can't find the right cause for crashes, I want to disable it. Is this possible? I searched in google for - XPCJSRuntime - XPCJSRuntime::XPCJSRuntime(nsXPConnect*) - js/xpconnect/src/XPCJSRuntime.cpp but there are no solutions for this problem. It appears that I will have to live with with crash every time I start FF, one more click :( Other possibility is to format disk and do a clean install of windows..., but this is not possible because our admins will not allow this. Kind regards
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

One last test, please.

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

One last test, please. Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' web sites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

Question owner

Hello

In safe mode FF is working without problems. No crash reports each time I start FF. I know that the problem is in my windows, clean install of windows will solve FF problems.

I will not bother you anymore. I have one last question.

FF 35 is working without problems. How can I stop FF 35 to update to 36... I disabled auto update in FF but this did not stop FF to update to 36. I don't know why this happened? Maybe security fixes...??

So, can I stay on 35, without updating, till I get new PC (end of year...)

Thank you

Kind regards

Hello In safe mode FF is working without problems. No crash reports each time I start FF. I know that the problem is in my windows, clean install of windows will solve FF problems. I will not bother you anymore. I have one last question. FF 35 is working without problems. How can I stop FF 35 to update to 36... I disabled auto update in FF but this did not stop FF to update to 36. I don't know why this happened? Maybe security fixes...?? So, can I stay on 35, without updating, till I get new PC (end of year...) Thank you Kind regards
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

Type about:preferences#advanced<enter> in the address bar. Under Advanced, select Update. Turn on; Check for updates, but let me choose whether to install them.

Note: some critical updates may still be updated.

Type '''about:preferences#advanced'''<enter> in the address bar. Under '''Advanced,''' select '''Update.''' Turn on; '''Check for updates, but let me choose whether to install them.''' Note: some critical updates may still be updated.

Question owner

Yes, I already did this but the problem is in "some critical updates may still be updated" . So, I got 36.0.4 even if I turned off updates.

I will wait for new computer. I hope I will get it soon :)

Thank you for your kind help.

Kind regards

Yes, I already did this but the problem is in "some critical updates may still be updated" . So, I got 36.0.4 even if I turned off updates. I will wait for new computer. I hope I will get it soon :) Thank you for your kind help. Kind regards