Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

lectures to watch and blank page

  • 2 replies
  • 1 has this problem
  • 2 views
  • Last reply by jojo05

more options

Hi there, im am trying to watch lectures when i click the link to open them it takes me to a new page and it comes up blank. this has never happened in the past and has only started since the new mozilla update..

Chosen solution

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Thank you. .it was because the uni has a protection mode for security. So all l had to so was click the shield in the top left corner. If only I knew that in the first place . Thank you for ur response. .