Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox master password prompt appears randomly

  • 2 replies
  • 6 have this problem
  • 207 views
  • Last reply by FredMcD

more options

Every time I open Firefox, the Master Password prompt appears randomly within about 30 seconds. Sometimes I'm still sitting on the home screen when I get the prompt.

I have tried to refresh Firefox, reinstall Firefox, I've turned my Master Password requirement on and off, restarted the computer... nothing seems to work.

I would either like the prompt right away, as soon as I open my browser, or when it is actually required, like when I open a login page. Not the current, seemingly random appearance that disrupts me in the middle of web browsing.

This bug is so annoying that it is a deal breaker for me. It's especially annoying when I am starting to type something, then the Master Password prompt appears without warning and takes the cursor focus with it. I have to stop what I'm doing, deal with the Master Password prompt, then get back to what I'm doing.

In the meantime, I've switched over to Chrome, which is serving my needs fine, but I would like to come back to Firefox if I can resolve this issue.

Chosen solution

Hi Will,

Are you using Firefox Sync?

In order to keep your sync login details secure, you have to unlock your master password before Firefox can synchronise.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Hi Will,

Are you using Firefox Sync?

In order to keep your sync login details secure, you have to unlock your master password before Firefox can synchronise.

more options

Open your Sync options, and uncheck passwords. Once in a while, check passwords again, do a manual sync, then turn passwords off.