Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My bookmarks have disappeared after I chose Safe Mode, why and how can I get them back?

  • 4 replies
  • 3 have this problem
  • 466 views
  • Last reply by mbb1060

more options

For some reason a dialogue box appeared when I tried to open Firefox. this has never happened to me before. I had to choose Safe Mode or Default. I chose Safe Mode and now all of my bookmarks are gone!! I don't know how to get out of this mode and none of the recommended ways to restore my bookmarks are working. Help! Most of my work contacts were in those bookmarks. I am pretty sure there has been an update to Firefox within the past few days. I have Windows 7.

All Replies (4)

more options

Hi there!

Has Firefox created a file on your desktop called Old FIrefox Data? If so, we can use this folder to get your bookmarks back.

But first we need to get you out of safe mode.

  1. Click the menu New Fx Menu button, and click Quit
  2. Quit all Firefox windows you have open
  3. Wait a few seconds and then try loading Firefox again. If it loads normally, carry on with the steps below. If it loads in safe mode again, quit it, restart your computer, and try again.
  4. Once Firefox has loaded normally, click the menu New Fx Menu button, then click Help Help-29 and select Troubleshooting Information
  5. This will open a new tab with extra information. Click the Open Directory button. This will open a new window containing your FIrefox profile files. Leave this window open, but quit Firefox completely.
  6. Go to your desktop, open the Old Firefox Data folder and look for a file called places.sqlite.
  7. Copy the file to your clipboard (press Ctrl+C) and then switch back to the window containing your Firefox profile files.
  8. Find the places.sqlite file here and rename it to something like places-old.sqlite
  9. Press Ctrl+V to paste your backup copy of places.sqlite into the folder.
  10. Once the paste is completed, launch Firefox again.

Hopefully this will bring your bookmarks back. Let us know if it solves the problem!

more options

Chosen Solution

more options

Thank you! The first link worked. Apparently I do have 2 profiles. You are a life saver!

Modified by mbb1060

more options

Thank you but this was too complicated for me. There was no "open directory" button so things got a little muddy after that and I did not want o go any further and risk losing everything.