X
Tap here to go to the mobile version of the site.

Support Forum

Turning off autoplay does not stop videos from auto-starting, will this be fixed, or should I switch to another browser ? (which do you suggest?)

Posted

Hi,

Firefox these days has an annoying habit of starting videos on every news page that I open and when I scroll through my facebook newsfeed. There is only a very select amount of these videos that I would actually want to watch, and it's annoying to be bombarder with this media constantly.

I have tried disabling auto-play in the config page to no avail, and am not interested in installing add-ons to accomplish a task that should be handled by the browser itself.

So, does anyone know of a method to accomplish this with FireFox's own settings, or alternatively recommend a browser that does not have this offensive behavior ?

Thanks in advance...

Hi, Firefox these days has an annoying habit of starting videos on every news page that I open and when I scroll through my facebook newsfeed. There is only a very select amount of these videos that I would actually want to watch, and it's annoying to be bombarder with this media constantly. I have tried disabling auto-play in the config page to no avail, and am not interested in installing add-ons to accomplish a task that should be handled by the browser itself. So, does anyone know of a method to accomplish this with FireFox's own settings, or alternatively recommend a browser that does not have this offensive behavior ? Thanks in advance...

Chosen solution

I think the built-in setting (media.autoplay.enabled) relates to the HTML5 player and doesn't apply to plugins such as the Flash player. You usually can tell whether it's a plugin-based player by right-clicking it and checking whether it has a proprietary context menu instead of the normal Firefox menu.

To control when plugins start, you can use the "Ask to Activate" permission setting. You can adjust this setting on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Then on the right side, change the permission for Shockwave Flash (for example) from Always Activate to Ask to Activate. (If you have plugins that run in the background or globally, such as security plugins, you may encounter problems using Ask to Activate for those.)

Of course, once you give permission to a site, each new page you load from that site will be able to auto-start its videos. Taking detailed control of that does require an add-on. I think this one might be the best integrated with the standard permission feature:

https://addons.mozilla.org/firefox/addon/click-to-play-per-element/

Read this answer in context 8

Additional System Details

Installed Plug-ins

  • Provides information about the default web browser
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Garmin Communicator Plug-in Version 4.0.4.0
  • Garmin Communicator Plug-in Version 4.2.0.0
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0
  • WebEx64 General Plugin Container Version 205
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:36.0) Gecko/20100101 Firefox/36.0

More Information

jscher2000
  • Top 10 Contributor
8580 solutions 70166 answers

Chosen Solution

I think the built-in setting (media.autoplay.enabled) relates to the HTML5 player and doesn't apply to plugins such as the Flash player. You usually can tell whether it's a plugin-based player by right-clicking it and checking whether it has a proprietary context menu instead of the normal Firefox menu.

To control when plugins start, you can use the "Ask to Activate" permission setting. You can adjust this setting on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Then on the right side, change the permission for Shockwave Flash (for example) from Always Activate to Ask to Activate. (If you have plugins that run in the background or globally, such as security plugins, you may encounter problems using Ask to Activate for those.)

Of course, once you give permission to a site, each new page you load from that site will be able to auto-start its videos. Taking detailed control of that does require an add-on. I think this one might be the best integrated with the standard permission feature:

https://addons.mozilla.org/firefox/addon/click-to-play-per-element/

I think the built-in setting (media.autoplay.enabled) relates to the HTML5 player and doesn't apply to plugins such as the Flash player. You usually can tell whether it's a plugin-based player by right-clicking it and checking whether it has a proprietary context menu instead of the normal Firefox menu. To control when plugins start, you can use the "Ask to Activate" permission setting. You can adjust this setting on the Add-ons page. Either: * Command+Shift+a (Windows: Ctrl+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. Then on the right side, change the permission for Shockwave Flash (for example) from Always Activate to Ask to Activate. ''(If you have plugins that run in the background or globally, such as security plugins, you may encounter problems using Ask to Activate for those.)'' Of course, once you give permission to a site, each new page you load from that site will be able to auto-start its videos. Taking detailed control of that ''does'' require an add-on. I think this one might be the best integrated with the standard permission feature: https://addons.mozilla.org/firefox/addon/click-to-play-per-element/

Modified by jscher2000

Question owner

Great - Thanks!

Followed your suggestion: And playing of videos have come to a halt!

Oddly enough even the HTML5 videos have ceased auto-execution as well, despite having turned this off a couple of weeks back.

There was a Firefox update today - Perhaps that helped ...

Great - Thanks! Followed your suggestion: And playing of videos have come to a halt! Oddly enough even the HTML5 videos have ceased auto-execution as well, despite having turned this off a couple of weeks back. There was a Firefox update today - Perhaps that helped ...