Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why can't I open Gmail in Firefox even though all cookies are enabled?

  • 3 replies
  • 7 have this problem
  • 4854 views
  • Last reply by FredMcD

more options

I've followed all the instructions for enabling the cookies, but I still can't get Gmail to open up. I can get Google to open, but not any of my Gmail accounts. I also can't force Google to set as my home page, but that's a minor problem compared to not being able to access any Gmail accounts from Firefox. I am NOT computer literate, so all advice needs to take into consideration that I won't automatically know every step to take along the way. I sure wish Mozilla would have a 1-800 number to call. That'd make this a whole lot easier.

Chosen solution

Outofpatience said

I went to Preferences: Privacy and did a search for "cookies.sqlite" and "sqlite" and found neither.

The "cookies.sqlite" is a file in the profiles folder.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the cookies.sqlite file, and any other cookie files. Then rename or delete them. Restart Firefox.

Read this answer in context 👍 2

All Replies (3)

more options

What happens when you try? What error messages do you see?

If clearing cookies didn't help then it is possible that the cookies.sqlite file that stores the cookies got corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted. http://kb.mozillazine.org/Cookies https://support.mozilla.org/kb/Deleting+cookies

more options

The error message I get reads: "This page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete. This problem can sometimes be caused by disabling or refusing to accept cookies. Try Again."

So I try again and try again and try again to no avail.

I went to Preferences: Privacy and did a search for "cookies.sqlite" and "sqlite" and found neither.

So now what?

Is the problem that Firefox is antagonistic toward Gmail and has no desire to allow users to access it?

And really, trying to do this all by e-mail is tedious. I wish Mozilla had a 1-800 number to call. It's much easier and quicker to talk through a problem and immediately clarify any misunderstandings or confusion.

more options

Chosen Solution

Outofpatience said

I went to Preferences: Privacy and did a search for "cookies.sqlite" and "sqlite" and found neither.

The "cookies.sqlite" is a file in the profiles folder.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the cookies.sqlite file, and any other cookie files. Then rename or delete them. Restart Firefox.