Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

E-mail to neighbor was changed into Greek letters. How fix?

  • 3 replies
  • 1 has this problem
  • 11 views
  • Last reply by FredMcD

more options

About 11:00 am on 3/6/15 sent two email. Recipients notified us that they were in Greek letters. Also, when I tried to copy email to Word Docs, they appeared in Greek letters also. Last night about 10 pm Firefox displayed a "Crashed" notice. Just after, able to use Firefox again. So . . . how do we get our emails that we are sending out in English(US) to be seen by the recipients in same. Thank you.

All Replies (3)

more options

Have you checked the setting for Character Encoding in the View menu? Is Greek checked?

more options

How do the emails show for you?

Does this still happen or was this only happening with those two mails?

What font is used to show the emails?


There are other things that need your attention.

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file is only present if you or other software has created this file and normally it wouldn't be there.

You can check its content with a plain text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself. See:

more options

Type about:preferences#content<enter> in the address bar.

On the bottom of the page, find Languages. To its right, press the Choose button. Make sure the correct language and district is selected.