X
Tap here to go to the mobile version of the site.

Support Forum

I have latest version of Firebox but the program is retaining credit card and security code numbers. How do I disable?

Posted

I saw online that there is a record history page but I can't find it....

I saw online that there is a record history page but I can't find it....

Chosen solution

thanks so much for all of your assistance! the strange thing about the history control issue is that the has been occurring with only one vendor. they insisted that it wasn't their program that was at fault, so that led to the effort to find the solution within firefox. cookies under control now too. greatly appreciated! over and out. cheers, kathleen

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • FreeConferenceCall Launcher
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.6.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • CANON iMAGE GATEWAY Mycamera Plugin
  • Package Installer & Install Conduit
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0
  • VLC media player Web Plugin 2.1.3
  • NPWLPG
  • iTunes Detector Plug-in

Application

  • Firefox 36.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
  • Support URL: https://support.mozilla.org/1/firefox/36.0.1/WINNT/en-US/

Extensions

  • Norton Identity Safe Toolbar 2014.7.10.26 ({F04D2D30-776C-4d02-8627-8E4385ECA58D}) (Inactive)
  • Skype Click to Call 7.3.16540.9015 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0126
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 04d81028
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 7-19-2011
  • driverDate2:
  • driverVersion: 8.15.10.2455
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8886 solutions 72693 answers

Helpful Reply

Are these already in the page when it loads or do they appear as suggestions when you start typing in the field?

Already in the page

Reload the page using Ctrl+Shift+r to clear out the cached copy of the page. Does that clean out the form?

Shown as suggestions

You can remove individual entries when you are in that form field: arrow down to the suggestions and press the Delete key or in some cases Shift+Delete.

You can turn off the form history feature on the Privacy panel here:

"3-bar" menu button (or Tools menu) > Options > Privacy

If the center drop-down says "Firefox will: Remember history" change that to "Firefox will: Use custom settings for history"

Then uncheck the box for "Remember search and forms history"

To clear all of the currently saved entries, you can use either:

  • "3-bar" menu button > History > Clear Recent History
  • (menu bar) History > Clear Recent History

Expand the lower part of the dialog to show all the different categories of history available for clearing and uncheck everything except "Form & Search History".

At the top of the dialog, select "Time range to clear: Everything" and then click OK.

To selectively clear form entries Firefox has remembered, you need an add-on. Here's one I have tested, although I don't use it regularly (I turn off this feature): https://addons.mozilla.org/firefox/addon/form-history-control/

Are these already in the page when it loads or do they appear as suggestions when you start typing in the field? ''Already in the page'' Reload the page using Ctrl+Shift+r to clear out the cached copy of the page. Does that clean out the form? ''Shown as suggestions'' You can remove individual entries when you are in that form field: arrow down to the suggestions and press the Delete key or in some cases Shift+Delete. You can ''turn off'' the form history feature on the Privacy panel here: "3-bar" menu button (or Tools menu) > Options > Privacy If the center drop-down says "Firefox will: Remember history" change that to "Firefox will: Use custom settings for history" Then uncheck the box for "Remember search and forms history" To clear ''all'' of the currently saved entries, you can use either: * "3-bar" menu button > History > Clear Recent History * (menu bar) History > Clear Recent History Expand the lower part of the dialog to show all the different categories of history available for clearing and uncheck everything except "Form & Search History". At the top of the dialog, select "Time range to clear: Everything" and then click OK. To selectively clear form entries Firefox has remembered, you need an add-on. Here's one I have tested, although I don't use it regularly (I turn off this feature): https://addons.mozilla.org/firefox/addon/form-history-control/

Modified by jscher2000

Helpful Reply

shown as suggestion - when i type in the first number, the rest fill in

 there is no arrow down option
 i can't find the firefox page that has a menu or tools/options option
 where can i find the page that shows the form history control?

thanks!

shown as suggestion - when i type in the first number, the rest fill in there is no arrow down option i can't find the firefox page that has a menu or tools/options option where can i find the page that shows the form history control? thanks!
jscher2000
  • Top 10 Contributor
8886 solutions 72693 answers

Let's see if I can cover all three of those:

(1) Using the arrow keys to select a suggestion

Sorry, the arrow down isn't shown on the screen, I mean the down arrow on the keyboard. The up and down arrow keys let you highlight suggestions on the list.

(2) Accessing the Options dialog

The "3-bar" menu button normally appears at the right end of the main toolbar. Some people call it the "hamburger". It looks like this: New Fx Menu

Or if you want to use the classic menu bar, tap the Alt key to show it temporarily. Then Tools > Options...

(3) Form History Control extension

This is available on the Add-ons site at this link: https://addons.mozilla.org/firefox/addon/form-history-control/

Let's see if I can cover all three of those: (1) Using the arrow keys to select a suggestion Sorry, the arrow down isn't shown on the screen, I mean the down arrow on the keyboard. The up and down arrow keys let you highlight suggestions on the list. (2) Accessing the Options dialog The "3-bar" menu button normally appears at the right end of the main toolbar. Some people call it the "hamburger". It looks like this: [[Image:New Fx Menu]] Or if you want to use the classic menu bar, tap the Alt key to show it temporarily. Then Tools > Options... (3) Form History Control extension This is available on the Add-ons site at this link: https://addons.mozilla.org/firefox/addon/form-history-control/

Question owner

ah, relief! i was able to find the options/history box via the menu on the toolbar! meanwhile, i disallowed some cookies while i was at it and now just about every time a new page comes up i have to mess around with allowing a cookie. should i just allow all cookies? thanks so much for your help!

ah, relief! i was able to find the options/history box via the menu on the toolbar! meanwhile, i disallowed some cookies while i was at it and now just about every time a new page comes up i have to mess around with allowing a cookie. should i just allow all cookies? thanks so much for your help!
jscher2000
  • Top 10 Contributor
8886 solutions 72693 answers

Here's my strategy for cookies: there are a few sites that should be allowed to remember me for the long term. Others I am happy to have forget me when I close Firefox. So...

(1) General settings in Options

[X] Accept cookies from sites Accept third party cookies: Always Keep until: I close Firefox

(2) Site-specific exceptions

These can be entered by hand using the Exceptions button, or when you're on the page, you can use the Permissions feature in the Page Info dialog to change from the default to "Allow". To access that, you can use either:

  • right-click and choose View Page Info > Permissions
  • Alt+t (open the classic Tools menu) > Page Info > Permissions
  • click the padlock or globe in the address bar > More Information > Permissions

Under "Set cookies" uncheck the "Use default" box and choose your preference.

Here's my strategy for cookies: there are a few sites that should be allowed to remember me for the long term. Others I am happy to have forget me when I close Firefox. So... (1) General settings in Options [X] Accept cookies from sites Accept third party cookies: Always Keep until: '''I close Firefox''' (2) Site-specific exceptions These can be entered by hand using the Exceptions button, or when you're on the page, you can use the Permissions feature in the Page Info dialog to change from the default to "Allow". To access that, you can use either: * right-click and choose View Page Info > Permissions * Alt+t (open the classic Tools menu) > Page Info > Permissions * click the padlock or globe in the address bar > More Information > Permissions Under "Set cookies" uncheck the "Use default" box and choose your preference.

Chosen Solution

thanks so much for all of your assistance! the strange thing about the history control issue is that the has been occurring with only one vendor. they insisted that it wasn't their program that was at fault, so that led to the effort to find the solution within firefox. cookies under control now too. greatly appreciated! over and out. cheers, kathleen

thanks so much for all of your assistance! the strange thing about the history control issue is that the has been occurring with only one vendor. they insisted that it wasn't their program that was at fault, so that led to the effort to find the solution within firefox. cookies under control now too. greatly appreciated! over and out. cheers, kathleen
paulparker 4 solutions 26 answers

BTW remember use NEW PRIVATE WINDOW option when browsing and you do not wish any details recorded.

This opens a NEW PRIVATE browser-WINDOW while leaving other browser-window still doing your other things which you wish kept.

Everything and its' history are deleted from PRIVATE WINDOW when you close it.

BTW remember use NEW PRIVATE WINDOW option when browsing and you do not wish any details recorded. This opens a NEW PRIVATE browser-WINDOW while leaving other browser-window still doing your other things which you wish kept. Everything and its' history are deleted from PRIVATE WINDOW when you close it.
cor-el
  • Top 10 Contributor
  • Moderator
17773 solutions 160751 answers

You can use these steps to remove saved (form) data from a drop-down list:

  1. click the (empty) input field on the web page to open the drop-down list
  2. highlight an entry in the drop-down list with the mouse or cursor Down key
    do not click the mouse or press the Enter key
  3. press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry
You can use these steps to remove saved (form) data from a drop-down list: #click the (empty) input field on the web page to open the drop-down list #highlight an entry in the drop-down list with the mouse or cursor Down key<br>do not click the mouse or press the Enter key #press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry *http://kb.mozillazine.org/Deleting_autocomplete_entries