Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox can't open after the new Version 36 update.

  • 14 replies
  • 3 have this problem
  • 763 views
  • Last reply by FredMcD

more options

The problem is stated above. So I can use version 35.0.1 without any problem. As soon as I update to Firefox 36, it simply won't open. By won't open I mean when I double click on the icon, it would register in the Task Manager with about 2.6k RAM usage then terminate itself right away.

Here is the spec: Windows 7 64-bits, Windows Firewall, Microsoft Essentials

Yes, I have tried all the solution offered on the forum and troubleshoot, and Yes I tried clean installation, and yes I did re-add Firefox to Firewall exception. The Version 36 just simply won't open. But when I revert it back to 35.0.1, it works perfectly fine.

Would really appreciate any solution.

Chosen solution

The problem is fixed after I deleted prefs.js under newly created profile folder.

For those who has the same problem, try to delete those file from the following Address:

C:\Users\ (user name) \AppData\Roaming\Mozilla\Firefox\Profiles\ (profile name, could be bunch random letters and numbers)

or simply type the following in "Search program and files" in start menu: %APPDATA%\Mozilla\Firefox\Profiles\ (whatever folder shows up)

NOTE: all your previous setting would be reset back to default.

Read this answer in context 👍 1

All Replies (14)

more options

Hello tscvincent, try to boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) and then see if that allows to start firefox.

If you have a 36.0 version already in a safe place and you want to install that version, delete it and try a new one from the next full installer link : https://www.mozilla.org/en-US/firefox/all/

thank you

more options

Thank you idea to for replying. I did reboot my computer in safe mode and was able to open the new v36 from there. However, when I went back to regular mode. It stops working as the way it was. Any idea on how I can solve that?

more options

If firefox works in Windows Safe mode then probably you have problem with other software, like security software or maybe a system driver, that is running on your computer. Please remove all rules for Firefox and plugin-container from the permissions list in the your firewall and let your firewall ask again for permissions to get full access to Firefox installation and at the plugin-container process and also for updater process.


thanks again

more options

So I remove every components that was included inside Firefox folder from the Windows Firewall, and did a clean installation of Firefox V36. When I try to open it, there was no prompt from Firewall what so ever. I manually added all components from the new version back to Firewall permission list, the V36 still won't open. So far I can only use Firefox only if I revert it back to V35.0.1

more options

Any luck if you delete the user.js file in your profile folder ?

The user.js file does not exist by default. If you create the file, forget it, if you have not create the file then delete the User.js file, to see if the problem goes away (some programs create and write in the file also).

thank you

more options

I check the Firefox folder in APPDATA and there is no user.js file under it. Should I be looking for something else.

more options

such issues can also be caused by malware, so please run a full scan of your system with different other security tools like the free version of malwarebytes, adwcleaner & kaspersky security scan...

more options

I have made checking Malware as regular thing for my computer. I do it on daily basis. And nope, there wasn't any malware from Malwarebytes

more options

Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

If you keep having problems then also create a new profile.


more options

Hello Cor-El, thank you for your thorough response on how to do a full clean installation. I have tried all the methods provided in all those links combined, including clearing out profile folder and registry after uninstall with Firefox own uninstall helper. But the problem still exist, the new V36.0.1 would only run in safe mode.

Currently my laptop is only running Windows Firewall and Microsoft Security Essential. It seems I still can't figure out what's terminating the process of starting up Firefox

more options

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test.

Did you try other malware scanners apart from Malwarebytes' Anti-Malware?

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select Network. Look for Configure How Firefox Connects and press the Settings button. Check the settings.


Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

Chosen Solution

The problem is fixed after I deleted prefs.js under newly created profile folder.

For those who has the same problem, try to delete those file from the following Address:

C:\Users\ (user name) \AppData\Roaming\Mozilla\Firefox\Profiles\ (profile name, could be bunch random letters and numbers)

or simply type the following in "Search program and files" in start menu: %APPDATA%\Mozilla\Firefox\Profiles\ (whatever folder shows up)

NOTE: all your previous setting would be reset back to default.

Modified by tscvincent

more options

That was very good work. Well Done.