X
Tap here to go to the mobile version of the site.

Support Forum

HTML5 Wistia and Vimeo hosted videos are not playing correctly in Firefox (Choppy, hangs on frames, jittery audio)

Posted

Hi, for some reason I can't get HTML5 videos hosted by Wistia or Vimeo to play correctly in firefox. I tried doing a fresh install of firefox, running version 35.0.1, and the videos still don't play correctly. They constantly load, videos hang on frames, and the audio gets jittery. However, if I switch to flash they do play correctly. Videos on youtube play fine. I can't figure this out. I tested the same videos with Safari, and they play correctly, which tells me there's something not right with Firefox and perhaps my system.

I use a MacBook pro (Mid - 2010) with OS X Yosemite, 10.10.2.

Any ideas?

Hi, for some reason I can't get HTML5 videos hosted by Wistia or Vimeo to play correctly in firefox. I tried doing a fresh install of firefox, running version 35.0.1, and the videos still don't play correctly. They constantly load, videos hang on frames, and the audio gets jittery. However, if I switch to flash they do play correctly. Videos on youtube play fine. I can't figure this out. I tested the same videos with Safari, and they play correctly, which tells me there's something not right with Firefox and perhaps my system. I use a MacBook pro (Mid - 2010) with OS X Yosemite, 10.10.2. Any ideas?

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.10
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • Provides information about the default web browser
  • DivX Plus Web Player version 2.2.1.2
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Picasa plugin.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0
  • Plugin for Wacom tablets.
  • WebEx64 General Plugin Container Version 205
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:35.0) Gecko/20100101 Firefox/35.0

More Information

guigs 1072 solutions 11697 answers

Try to disable all video player extensions in your Firefox and test the site that is giving playback issues. Turn on each one until there is an obvious difference.

Some video formats/codecs may not be supported by one over the other.

Right click on the HTML5 player and select: "About HTML5"

It will tell you that youtube has automatically enrolled you in their beta testing and to opt out you click the link on the bottom to stop seeing HTML5 videos.

Try to disable all video player extensions in your Firefox and test the site that is giving playback issues. Turn on each one until there is an obvious difference. Some video formats/codecs may not be supported by one over the other. Right click on the HTML5 player and select: "About HTML5" It will tell you that youtube has automatically enrolled you in their beta testing and to opt out you click the link on the bottom to stop seeing HTML5 videos.