X
Tap here to go to the mobile version of the site.

Support Forum

Flash Videos do not Operate

Posted

To begin with, The computer is WindowsXP Pro SP2, with fresh NVIDIA GeForce 6600 GT drivers version 295.73, and fresh directx version 9.0c

Firefox is a fresh new install, version 35.0.1 downloaded 2-4-2015 and virus checked There have been no preferences modified with about:config The user profile is new, all previous have been abandoned

Adobe Flash has been uninstalled, then reinstalled to the latest version. All plugins are disabled except OpenH264 1.3, Shockwave Flash 16.0.0.305, and Java SE U75 10.75.2.13

Video players partially load, but video never even begins to play.

I can load up Avant Browser Portable and they work exactly right, on the same computer. I can load Firefox 35 or 27 or whatever version on a different WindowsXP computer, and then the videos will work.

It is just the XP-Pro system that will never play videos in Firefox. I've tried all that I can think of besides reinstalling Windows itself.

How do I fix this problem?

To begin with, The computer is WindowsXP Pro SP2, with fresh NVIDIA GeForce 6600 GT drivers version 295.73, and fresh directx version 9.0c Firefox is a fresh new install, version 35.0.1 downloaded 2-4-2015 and virus checked There have been no preferences modified with about:config The user profile is new, all previous have been abandoned Adobe Flash has been uninstalled, then reinstalled to the latest version. All plugins are disabled except OpenH264 1.3, Shockwave Flash 16.0.0.305, and Java SE U75 10.75.2.13 Video players partially load, but video never even begins to play. I can load up Avant Browser Portable and they work exactly right, on the same computer. I can load Firefox 35 or 27 or whatever version on a different WindowsXP computer, and then the videos will work. It is just the XP-Pro system that will never play videos in Firefox. I've tried all that I can think of besides reinstalling Windows itself. How do I fix this problem?

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.75.2 for Mozilla browsers
  • Shockwave Flash 16.0 r0
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:35.0) Gecko/20100101 Firefox/35.0

More Information

guigs 1072 solutions 11697 answers

Hi blebadef, Thank you for the description and the troubleshooting steps in your question. I understand that Flash video partially load, but do not play, and it only happens on one operating system on the latest version of Firefox and Flash.

On the XP pro computer are your WebGL graphics drivers up to date? Is the plugin set to click to play? ("Always Ask" would be the setting on the page)

Does it happen when Firefox hardware acceleration is turned off? You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Open Firefox Options window (Preferences on Mac or Linux) as follows:
    • In Firefox 29.0 and above, click the menu button New Fx Menu and select Options for Windows or Preferences on Mac or Linux.
    • In Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  2. In the Firefox Options (or Preferences) window, click the Advanced tab, then select General.
  3. In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  4. Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

Hi blebadef, Thank you for the description and the troubleshooting steps in your question. I understand that Flash video partially load, but do not play, and it only happens on one operating system on the latest version of Firefox and Flash. On the XP pro computer are your WebGL graphics drivers up to date? Is the plugin set to click to play? ("Always Ask" would be the setting on the page) Does it happen when Firefox hardware acceleration is turned off? You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: #Open Firefox ''Options'' window (''Preferences'' on Mac or Linux) as follows: #* In Firefox 29.0 and above, click the menu button [[Image:New Fx Menu]] and select ''Options'' for Windows or ''Preferences'' on Mac or Linux. #* In Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. #In the Firefox Options (or Preferences) window, click the ''Advanced'' tab, then select ''General''. #In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. #Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Did this fix your problems? Please report back to us! Thank you.