Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes

  • 6 replies
  • 27 have this problem
  • 1506 views
  • Last reply by John99

more options

Since 28th of January, Firefox keeps crashing after 15-20 minutes of usage, if not more often. It doesn't depend on anything, it can crash on opening new page, or being idle. Tried updating all plugins, Flash, Shockwave, etc. Tried uninstalling and reinstalling Firefox (without deleting profile). Updated Windows. My browser usage habits include having a LOT of tabs open and I mean really LOTs, but that was not a problem until recent events and I already closed like half of tabs that were open.

Here are several reports from 28.01 till today.

bp-4233c198-6a34-46c4-99fd-c9d3e2150202 bp-5b3f79ac-f046-4ee2-a86c-cafd72150202 bp-c01f7992-b70b-476b-8ec4-951f32150130 bp-ce3dfd3f-409b-4d6f-9ba9-b43fe2150129 bp-2ea42459-d924-4c57-9a7a-ebcf42150128

Thanks.

Chosen solution

It seems like some yesterday's update or action solved it. Probably new Flash update ? (Though, in this case, AFAIU, it should have been working fine in Safe mode, but it wasn't) Anyway, Firefox stayed open fine during the whole night.

Read this answer in context 👍 0

All Replies (6)

more options

Start Firefox in Safe Mode to Troubleshoot the issue and to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

more options

Thanks. Started Firefox in Safe mode and went away to dinner, still it already crashed on my way back to computer.

Installed and ran Anti-Malware scan and found some stuff, like Movies Toolbar and something, not sure if any of this could be the probable cause , though...

Here's scan log if needed: https://cloud.mail.ru/public/18bc4daed65d/MalwareBytes_Log_Export.xml

https://cloud.mail.ru/public/3ebcda47cc33/MalwareBytes_Log_Export.txt

Modified by digil

more options

Just posting as a reminder to myself to look further.

This may be related to a change in how Firefox handles some media and media streams (Potential workaround Disable MSE ? or does ESR still not have MSE ?)


For forum cross referencing purposes

  • Reports for your CrashID
    1. bp-2ea42459-d924-4c57-9a7a-ebcf42150128
      bp-5b3f79ac-f046-4ee2-a86c-cafd72150202
      bp-5b3f79ac-f046-4ee2-a86c-cafd72150202
    2. bp-ce3dfd3f-409b-4d6f-9ba9-b43fe2150129
      c01f7992-b70b-476b-8ec4-951f32150130
  • Crash Signatures
    1. Signature: xul.dll@0x12a110 | xul.dll@0x39ded8 | xul.dll@0x39d27b | xul.dll@0x39d32f | xul.dll@0x39f2ae
    2. Signature: mozilla::AtomicRefCountedWithFinalize<mozilla::layers::TextureClient>::Release()
  • Related bug
  • 2. Bug 1114976 - crash in mozilla::AtomicRefCountedWithFinalize<mozilla::layers::TextureClient>::Release()
more options

Deleted all possible MalWare, everything is green now, but still crashes. Is it possible that installing previous FF version could help? Was v.35 released recently? It's important for me not to break the session (open tabs)

more options

Chosen Solution

It seems like some yesterday's update or action solved it. Probably new Flash update ? (Though, in this case, AFAIU, it should have been working fine in Safe mode, but it wasn't) Anyway, Firefox stayed open fine during the whole night.

more options

Glad the problem was resolved, and thanks for posting back. I will mark your last answer as solving this thread's question.



I was intending to post as follows

but I now have doubts

because MSE was not enabled in Fx 35 by default, (Bug 1112761 - Restrict MSE support to youtube.com domain for Firefox 36 ) But is enabled but limited in Fx36 beta

Implemented a subset of the Media Source Extensions (MSE) API to allow native HTML5 playback on YouTube. Full support is on the way


One of the crashIDs related to crashes caused by a new feature of Firefox I was going to suggest disabling that by using about:config (see) & toggling the preference media.mediasource.enabled to false.

The feature is a new method of playing some HTML5 media streams.(Background info on MSE (Media Source Extensions) https://en.wikipedia.org/wiki/Media_Source_Extensions &MDN& check your browsers status on the page https://www.youtube.com/html5 )

Other potential workarounds



Possibly you made some other change. Some of these issues could relate to low memory situations.